Sign in with
Sign up | Sign in
Your question

Cannot Enter Raid Utility

Last response: in Motherboards
Share
June 25, 2009 7:04:58 PM

This is the first time I am trying to set up a RAID so I am sure there is some small step I am missing here.

I am trying to build a raid on my Gigabyte GA-M61P-S3 using (3) WD RE2 Drives (model# WD4001ABYS BM). These drives are brand new and came factory sealed.

Basically, installed the HDs onto the SATAII0, SATAII1 and SATAII2 ports on the mobo, no other add-in cards are installed except for my NIC.

I then turn on the PC and enter the bios (F7 - the latest from the Gigabyte website) and enable the SATA RAID controller and turn on the RAID for Channel 1 Primary, Channel 1 Secondary and Channel 2 Primary. Channel 2 secondary was left disabled.

I also set CD/ROM as the Primary Boot and Hard Disk as the secondary boot as per the Gigabyte manuals instructions.

I then reboot and after POST it says "Detecting Raid Array...." but it lists nothing and then prompts me to hit F10 to enter the RAID configuration Utility.

When I hit F10, the boot sequence continues normally. Because this is a fresh install of windows xp-64, it tries to start the OS installation. I do NOT enter the RAID configuation utility at all.

Any ideas or suggestions?

Additional info:
These drives are brand new, so there's no chance of a previous RAID setup complicating things. This mobo has been stable and hasn't given me any issues previously without the RAID. I have tried removing (sequentially) each one of the three HDs and tried to enter the RAID utility with just the other two, but the same result.

More about : enter raid utility

a c 177 V Motherboard
June 25, 2009 10:00:24 PM

Well, I dl'd the manual, and know less than I started with...

1 - that's a really strange BIOS!

2 - if you'll take a look at:
http://www.nvidia.com/object/feature_raid.html
and download the "Media Shield User's Guide" (980 KB PDF), you'll see that it's ambiguous about support for any mode with more than two drives for the nForce 430 chipset, but doesn't tell you how to identify the one you've got... I'll root around a bit, and see what else I can come up with...
June 25, 2009 10:28:10 PM

Thanks for your reply.

Yes, the first bone I have to pick with Gigabyte is that the SATA ports are named "SATAII0, SATAII1..." and in the bios they are named "Channel 1 Primary, Channel 1 Secondary..."

Not a big deal, but when "something" is amiss, you start to notice things like that and start to wonder if you've got that right.

I have read and printed the MediaShield guide and basically on page 13 of that booklet step 1 asks me to hit F10... step 2 assumes the Mediashield utility has launched.

My problem is that the Mediashield utitlity is not launching, so my assumption is that something is awry elsewhere, but hard to troubleshoot.

I am going to reset the cmos and restore the bios defaults and see where that gets me.
Related resources
a c 177 V Motherboard
June 25, 2009 11:00:50 PM

Meantime, I will try to 'ignore' your first post (so I can approach this [appears to be a mess - but then, I hate nVidia ayway, because of the 'open-standard' ESA architecture] without any preconceptions) and run through the whole thing to see what I'd make of it... I do think one thing to try is only enabling two drives for RAID, and see if it will enter the RAID BIOS then... This documentation, though, is really ditzy!

Good luck!

Bill
June 25, 2009 11:20:57 PM

I appreciate your help.

I did actually try to run with just two of the drives. I removed the power and disabled RAID for that particular channel. To no avail.

Curious that you say that it claims to only support 2 drives. My understanding was that this board supports RAID 5, whcih requires 3 discs minimum (again, from my limited understanding).

Thanks again.
a c 177 V Motherboard
June 25, 2009 11:52:38 PM

I can't really say what it supports: the reason I pointed you at that nVidia MediaShield document, was to point out the page (numbered two, but my PDF reader says it's six) "Hardware Support - Table 1.1 lists the NVIDIA® nForce™ platforms supported by NVIDIA MediaShield, and the RAID arrays supported on each platform. 
Table 1.1 Supported nForce Platforms and - RAID Arrays:"

now, about two thirds of the way down

"NVIDIA nForce 430 X X X X X" (i.e., supports RAID 0, 1, 0+1, 5, & JBOD and next line -
"NVIDIA nForce 430 (NVIDIA Business Platform) X X" (i.e., supports only 0 & 1...)
but nowhere I can find does it say what the hell an "NVIDIA Business Platform" is, how to tell if you've got one, or which subset GB used in this board - all three of these items are on my 'to be researched' list for this problem...

And those are only a few of my confusions - reading the manual is literally making my head hurt - but then again, I'm spoiled by usually dealing with GB's 'd' series boards, where I know how to find (& make sense of) everything.

Take heart, though, I'm always confident that, with a little digging, we will figure it out, one way or the other!!

I'm gonna take a break for supper - maybe something will jump out of the manual at me, afterward :hello: 

a c 177 V Motherboard
June 26, 2009 1:39:15 AM

I came across this -
NVIDIA Business Platform Certified Motherboards
http://www.nvidia.com/page/nbp_certified_mobos.html
It would seem to me that it's kind of a little 'niche' product, so I'm thinking we can probably safely discard that whole issue; one thing that bugs me - I usually dl the Intel design specs for the northbridges - seeing the actual hardware block diagrams, and bus interface specs sorta makes the BIOS 'click' into focus - "ahh, setting this actually does that register select, and makes it do thusly..." But the equivalent nVidia stuff seems to be well hidden!
a c 177 V Motherboard
June 26, 2009 3:27:22 AM

Their wording is awful, but from looking at the way this thing is laid out, my guess about the first, or "Standard CMOS Features" BIOS features page, is that, unlike every other board I've seen, here, the first two items are likely the actual IDE connector's ports (as they're labeled master and slave), and the next four are the actual SATAs; i.e., displayed channel 2 is connector SATAII0, channel 3 is SATAII1, etc. Make sure that these are set to "Auto" on this page; won't matter (I shouldn't say that - "shouldn't" matter) if one is turned on that isn't connected - should just waste a smidgen of time at boot doing 'discovery' for an empty channel... If any are somehow getting set to "None", it will disable the detect, and futz things up. The nomenclature is 'broken' - they refer to all as "IDE/SATA Device", which only serves the confusion...

On the "Advanced BIOS Features" page, I'd first try it with SMART disabled - my reasoning is that if the RAID BIOS can't deal with the SMART data (and where do you need it more than on a RAID?), it might be 'hosing' the loader...

Now we come to the part that makes my head hurt! On "Integrated Peripherals" we are given a "Serial-ATA RAID Config" sub-menu, whose nomenclature flies in the face of common sense, as well as contradicts the apparent layout of the "Standard CMOS Features" page! I'm gonna post it vebatim, to make my comments (if not the page) clearer:

NV SATA RAID function
Enabled Allows users to configure individual SATA channels as RAID or ATA mode.
this is the only item that makes clear sense - obviously, this must be "Enabled"

NV SATA 1 Primary RAID
blah blah...
NV SATA 1 Secondary RAID
blah blah...
NV SATA 2 Primary RAID
blah blah...
NV SATA 2 Secondary RAID
blah blah...
WITF are they calling these primary and/or secondary for?!? SATA has no primary/secondary relationship (unless it's called that in the 'secret' chipset documentation?) - it's just, well, SATA!! I've gotta assume (always dangerous) that the relationship, contrary to the first page, is actually: NV SATA 1 Primary RAID is connector SATAII0, NV SATA 1 Secondary RAID is connector SATAII1, and NV SATA 2 Primary RAID is connector SATAII2, leaving NV SATA 2 Secondary RAID to be connector SATAII3 - so, I'm again guessing that you want the first three set to "Enabled"...

Then we come to:
NV Serial-ATA Controller
"SATA-1 Enable the first onboard SATA 3Gb/s controller.
All Enabled Enable all of the onboard SATA 3Gb/s controllers. (Default value)
Disabled Disable the onboard SATA 3Gb/s controllers."
Now this is looking like there are actually two (or maybe an indefinite number - enable 1, or enable 'all'?) SATA controllers, each with two channels (primary/secondary?), though the block diagram certainly doesn't show this... My guess - "Enable All"...

Both the "On-Chip IDE Channel0" and the "IDE Prefetch Mode" seem to refer to the actual IDE controller, so they shouldn't make a difference to the matter at hand...

"Legacy USB storage detect" - always disabled, on all GB boards - unless, on your next boot, you actually need to boot to a USB drive, or need the BIOS to access one for a BIOS flash - otherwise, the thing can cause really spooky symptoms, including the dreaded GB reboot looping...

...and that should do it; check my reasoning, set it up, and see if it will 'let you in' to the RAID BIOS to set up the RAIDs...

Good luck!

Bill
June 26, 2009 5:01:28 AM

Okay, I've figured out a few things through trial and error here.

The bios is not recognizing the drive once I enable RAID on the channel it is connected to. I realized this by cabling up my old boot OS HD (which still boots fine, btw) and putting it on SATAII03 (which is in fact NV SATA 2 Secondary with respect to the bios nomenclature).

When I made all other channels (Pr1, Sec1, Pr2) RAID enabled, the OS boot without registering the other drives. When I diabled one of them (let's say Pr1), the OS did not boot and it hung up. The bios listed that empty drive now.

This really doesn't get me anywhere except to confirm that we were both right about the nomenclature.

I followed all of the points in your post. Unfortunately, you pretty much named the default settings which I had already gone to war with, and it's still not letting me into the RAID utility.

Again, new to RAID. I know I will require drivers for the OS to recognize the RAID, but is there some other utility perhaps that I am missing here?

My assumption is the the utility is on the board, a part of the bios, is that correct?

I have also tried a cmos wipe and, as I said, when I disable RAID on all of the channels, all of the HDs are registered by the bios, so I am sure the drives are functional.
June 26, 2009 6:32:59 AM

Dug out the utility disc that shipped with the mobo and updated ONLY the chipset drivers--which includes Mediashield.

Immediately I am able to enter Mediashield and add the RAID enabled HDs to the array.

How noobish of me not to do this yesterday. I assumed that because my bios rev was up to date, so was the chipsets.

Anyway, problem solved, thanks for your help. Very unselfish of you and it's appreciated.
a c 177 V Motherboard
June 26, 2009 3:10:56 PM

Quote:
My assumption is the the utility is on the board, a part of the bios, is that correct?


I think this was both of our problems (remember me saying assumptions are dangerous? :lol:  and we both made the same one...); we assumed that, because every other board on the planet contains BIOS code that does the RAID setup, once it's been enabled, that this one worked that way, too...

Always welcome to help here; I learned a lot from that one, and it won't 'bite me' again!

Have fun!

Bill
June 29, 2009 6:47:39 PM

Okay, this just might be a bad board.

Here's what I am now experiencing:

Each time I want to enter Mediashield, I must first uninstall/install the chipset drivers. After that, Mediashield will no longer launch after hitting F10.

Additionally, I have had my old OS HDD running alongside the RAID array so I had something to boot into, and it's going into dual-boot after post.

Problem is, the bios is not recognizing the RAID array as a boot disc once I pull out the other bootable drive.

WHA? Why on earth would it give me a dual-boot option, but once I pull our the other OS drive, it fails to boot at all??? Makes no sense to me, and on top of the other issue, I just think I've got a bad board-bad for RAID anyway.
a c 177 V Motherboard
June 29, 2009 8:09:53 PM

Yipes! It just gets weirder and weirder... Well, either a defective MOBO - or - somebody at nVidia needs to be shot!

BTW - I can point out a really excellent boot manager; it handles RAIDs perfectly, allows you to resize and 'slide' partitions around, will 'swap' logical drives at the boot, hides partitions so they can't be seen by other OSs - the features just don't quit. It works by creating around a 10Meg Extended Master Boot Record at the nose of volume zero (and I've found I can have one on both of my RAID0 VR pairs - just to have a backup), and then writing a different actual MBR on a per-boot basis.

Try a peek here:
http://www.terabyteunlimited.com/bootit-next-generation...
June 29, 2009 8:49:15 PM

Okay, I figured out that when I installed the new OS on the RAID, somehow the boot manager and mbr was on the extra (OLD OS) drive. So I am pretty sure if I just start from scratch without an extra HD connected I will be fine.

However, once again, it says NOTHING GOOD for this board (or this manufacturer) that uninstalling/installing chipset data is the only way to access the RAID utility. That, I am 99.9% certain, is not a user error.
June 29, 2009 9:08:59 PM

At this point I am scrapping trying to boot from the RAID. It's probably a better idea for me to boot from a single disc and use the RAID for storage (including the root folder for all of my virtual machines).

Should I still worry about the mediashield issues then? Really, how often should I have to work with it under this new config?

The only thing I can think of is if for whatever reason the RAID degrades and I have to rebuild it. I would probably have to do the unintall/install madness once again, but it does work..

What do you think? Scrap my RAID plans for this board?
a c 177 V Motherboard
June 29, 2009 10:27:27 PM

Ye gods - I sure don't know - I can't yet fathom how it's supposed to work, less how it will? I gotta dig up more documentation & wade through it. (I knew there was a reason I hate nVidia...)
June 29, 2009 11:29:23 PM

Okay, last thought on this issue. Here is why this makes no sense to me.

Correct me if I am wrong:

The chipset drivers "should" have no effect here. Those drivers I am uninstalling/installing are OS dependent and they are not flashing anything on the board (unlike a bios update). They are part of the software layer.

If that's correct, my thinking is that the uninstall/install process for these drivers is toggling something on the board that is allowing me to access the MediaShield for the first reboot, but then that toggle is once again changed and I get locked out subsequently.

This leads me to belive there are two flavors of mediashield.

One flavor is part of the onboard instruction sets (bios or chipset) and a second is a OS dependent application that allows you to access the RAID and reconfgure things from within Windows.

So, basically, what I am after here is "what" onboard instruction is being toggled when I update the chipset drivers for my OS. And why is that setting not "sticking."
a c 177 V Motherboard
June 30, 2009 12:20:35 AM

Ahh - like I've said, it all seems to be a deep, dark, secret - like everything else nVidia does. I don't know if it takes an NDA, or hacking their design database, or what; but I wasted a good five months trying (offered an NDA; begged; threatened a lawsuit; tried public humiliation) to get any kind of information on the enthusiast system architecture, and know I wasn't the only one trying - several utility developers were in the same boat! NADA! In contrast, I just hauled down all the tech specs, programmer's notes, chipset schematics - everything - for Intel's i7 stuff - search me why nVidia doesn't see fit to do the same!
a c 177 V Motherboard
June 30, 2009 12:22:55 AM

BTW - your concept of the dual nature of the RAID IS correct for other manufacturers; mostly, the RAID is a BIOS block that's 'toggled' on when you enable RAID, and then an OS driver that 'hooks in' to that BIOS, and monitors the status of 'recoverable' arrays!
June 30, 2009 12:48:39 AM

I'm just going to go ahead with a fresh install on a single HD, and have the RAID group as a storage solution... with an air-tight backup routine.

Shame on nvidia and shame on Gigabyte for using this chipset and having cryptic nomenclature. They've lost a customer.
July 23, 2009 2:27:38 AM

Hi,

I was reading your posts with interest. I have a similar problem with my gigabyte 8I945pro MB and have tried e/thing to get rid of the RAID setup. Some IT nut decided to link my two drives with raid when all i wanted was a second drive to use as storage/backup.

All I want to do is get my ide 2 and 3 to recognise my (new) hard drive as independant and it wont auto detect anything in the BIOS. Still thinks raid is active. Have done all the settings in BIOS.

I do NOT u/stand why I do NOT get the <ctrl I> option on boot up so I can disable RAID altogether. Reading what you guys have discussed, am I correct in assuming I probably need to reload the driver for the RAID chipset? Instructions welcome and a link to the drive please.

You are 100% right about Gigabyte..their tech support is also %^$# useless. They responsd like you are the type of person who cannot even read the manual. F me I am more technically trained than the 2 bob opertaors they employ who cant even translate to english. Quote .."if you enable BIOS active you may cause broken" What hope have we got, so much for customer service. The world according to ..Made in China!!

regards
Rod
a c 177 V Motherboard
July 23, 2009 3:30:52 PM

First things first - do you have anything on the RAID that you want to preserve? Once you 'break' the RAID, the data on it is gone!

Quote:
They responsd like you are the type of person who cannot even read the manual.


This is due to the fact that ninety-five percent of the people they handle as 'first level' support are people who either can't or haven't read the manual - I know this all too well from doing support here - more than half of the questions here can be answered by finding and posting the relevant page from the manual...
July 24, 2009 7:26:08 PM


Rod,

I would definitely back up everything from the RAID array before you continue.

The first thing I would try to do is remove everything but the hd you want to boot from, (after turning off all raid functions like you said you did), and do a fresh install of the OS with only this disc in the machine. If it still recognizes the disc as raid, however, i would try resetting the cmos (you can short it out or remove the battery for a few minutes).

Then you can connect the other HD, and add it through computer management console if it doesn't show up in windows but the bios recognizes it.

Hope that helps.
!