Sign-in / Sign-up
Your question

[Hard Drives] Bios/OS will not recognize storage drive

Tags:
  • Hard Drives
  • BIOS
  • Storage
  • Product
Last response: in Storage
August 4, 2010 10:08:34 PM

Hello everyone,

Last night, I put together a really nice new build, and everything seemed to be working very well. However, today, I decided to take my old pc's second hard drive (used for storing music, videos, etc) and isntall it into my new build. Unfortunately, both my bios and OS will not recognize it at all, so I am somewhat lost in terms of what I should do. Initially, I tried different sata ports and cables, but nothing seems to solve the problem. Furthermore, I also tried to switch the hd mode from ahci to ide, and this still did not allow the bios to recognize the hd (I didn't try to boot up the os, since I didn't want windows to reinstall drivers/flip out). So, if you guys could help me out, I would be very grateful! In case you need information on the motherboard and HD, here they are:
ASUS P6X58D-E Motherboard (http://www.newegg.com/Product/Product.aspx?Item=N82E168...)
WD 640 gb 3 gb/s Hardrive (http://www.newegg.com/Product/Product.aspx?Item=N82E168...)
Windows 7 Professional 64-bit

Since it won't recognize my HD, I'm deathly afraid that it was damaged somehow, even though I took appropriate measures to prevent that (grounded myself with the case, did not directly touch the silicone part or any connectors, etc). Do you think that I could have damaged the drive? After I post this, I'm going to try and isntall it back into my old pc to make sure =x. If it's dead, I might just cry lol; I had some important data on it.

Thanks for your time!

More about : hard drives bios recognize storage drive

August 4, 2010 10:56:35 PM

Alright, here's a little update. Fortunately, my drive is definitely not dead; both my old pc's bios and windows xp recognize the drive (yay....I'm backing up everything now lol; I learned my lesson). So, I'm assuming that there's some sort of conflict in my motherboard's bios. If my main drive is a 6 gb/s drive, would I have problems installing this 3 gb/s drive (into the appropriate 3gb/s port....I checked)? I could not find any information regarding this within the motherboard manual.
m
0
l
August 5, 2010 12:17:43 AM

Alright, I FINALLY figured it out. For whatever reason, one of the new SATA cables in my mobo box must have been broken. When I used my old sata cable and plugged into a different port, everything worked properly. However, now my dvd burner gives me an "atapi incompatible" message at the post, despite the fact that it works. Any idea what is up with that?
m
0
l