Sign in with
Sign up | Sign in
Your question

Sudden drop in fps in crysis

Last response: in Graphics & Displays
Share
February 23, 2009 10:22:47 PM

hello all

need help

While playing crysis1.2 i get a sudden drop in fps

usually i get abot 25-35 fps in high setting @ 1280 x 800 noAA

but today the fps drops to about 10-15 at any random point during the game (always with 20-30 minutes of play)

iv done 2 things that may case this

1.
i installed new ram this morning 2 1 gig patriot low latency 4-4-4-12 800mhz DDR2 chip and enabled them
in sli ready mode in the mobo bios

iv checked the memoey clocks and timing and everything is as it should be

iv also tried turning the sli ready mode off and that didnt help

2.
i upgraded to the nerw nvidia driver 182.06

i would roll back the driver but i formatted this morning and dont have the previous driver anymore


any help would be apprciated


vista home premium 32bit
Alienware 680i sli mother board
Intel duo E6850 @ 3.00 ghz cpu
2gb patriot 800mhz ddrz low latency 4-4-4-12 ram
500 gb raid (x2 250gb sata) drive's
creative xfi extreme gamer sound card
x2 Nvidia8800gtx SLI gpu's



p.s
dont belive the SLI hype (it suck's balls)

More about : sudden drop fps crysis

February 24, 2009 11:19:05 AM

99% chance its the drivers; NVIDIA driver support has been poor lately...

NVIDIA's website should have a button on the driver page that takes you to a list of all previous driver versions.
February 24, 2009 4:45:45 PM

gamerk316 said:
99% chance its the drivers; NVIDIA driver support has been poor lately...

NVIDIA's website should have a button on the driver page that takes you to a list of all previous driver versions.



I installed the previous driver and it didnt help

iv also installed speedfan 4.34 and found that my cpu is 56c without the game running

could a cpu overheat cause the problem
February 24, 2009 4:45:52 PM

gamerk316 said:
99% chance its the drivers; NVIDIA driver support has been poor lately...

NVIDIA's website should have a button on the driver page that takes you to a list of all previous driver versions.



I installed the previous driver and it didnt help

iv also installed speedfan 4.34 and found that my cpu is 56c without the game running

could a cpu overheat cause the problem
!