Sign in with
Sign up | Sign in
Your question

P5Q3 Won't POST or beep or display anything on monitor.

Last response: in Motherboards
Share
June 26, 2009 11:28:48 AM

I've had a look around and this seems like quite a popular problem, however none of the answers have worked for me

All parts are entirely brand new straight out of the packaging. I'd just finished building it together, but to no avail.

So I've cleared the CMOS, no dice. Turned on without RAM, no beeps at all. Not sure if there's an on-board speaker but I put my headphones in the jack and no beeps. Bench-tested with just the MoBo, GPU, CPU, HSF, RAM, Keyboard and monitor, but still no dice. MoBo light is green. Every single fan works perfectly.

Testing
Monitor- Both my 2243BW's work fine through my laptop, so they're clean.
GPU- When I pull the graph. card out there's still no beeps. I don't have another one to test this, so I'm just assuming here.
RAM- I've got 2x 2GB sticks, I've checked with both of them and none of them and a single one, then the other and still nothing.
Speakers- work perfectly through my iPod and laptop, so they're fine
MoBo- I'm guessing the problem might lie here. I don't have a case speaker or a motherboard speaker attached, because I'm guessing a $230 AUD motherboard would have something of the sort set out.
CPU- Here's my other hunch. However it gets hot to touch the CPU once it's been on for a while, so it seems to be working?

Could it be a short-circuit? I've set it up on the cardboard box and there's no screws or anything wedged in anywhere...

Should I organize to send my MoBo or CPU back to the retailer for a replacement, or can I fix it here?

BTW, it's my first shot at building a comp.

Specs if it would help:

CPU: Intel E8400
Motherboard: Asus P5Q3
GPU: Powercolor HD 4890
RAM: 2GB sticks of Kingston 1333 DDR3
PSU: Thermaltake TR2-550w. (one other thing- it's only got a 4-pin connector for the power, should I change it to get something with an 8-pin one?
a b Ĉ ASUS
a c 229 V Motherboard
June 26, 2009 11:53:28 AM

The P5Q3 most likely doesn't have an onboard piezo. Connect a case speaker to the panel connector and check for beeps when you power on. Connecting headphones in the headphone jack just won't help. You didn't forget to connect the ATX CPU cable?
June 26, 2009 12:11:21 PM

ATX CPU cable is most definitely in. Case is a thermaltake spedo-advance, can't seem to find a case speaker on it. Would it be called "AC'97" by any chance if it existed on the case? Looks similar to the USB connector.
Related resources
June 26, 2009 12:47:21 PM

I see where it's meant to be. 95% sure the case doesn't have anything that would even almost fit in there.
a b Ĉ ASUS
a c 229 V Motherboard
June 26, 2009 4:29:01 PM

Most cases no longer include a speaker or piezo (the Antec Sonata III still does). You should be able to find one at a computer shop or in an old case. I always have one around as they are useful when debugging issues like yours.

http://computershopper.com/feature/75-pc-building-tips-.... Look at #15 to see what the built-in speaker looks like. Since your motherboard most likely doesn't have one, you can buy something like http://www.directron.com/d500speaker.html or http://www.cwc-group.com/8ohm.html.
June 27, 2009 2:29:31 AM

Ok, I've found one from another desktop we have around the place. I've tested it on the other computer and the speaker works fine.
When I put it in on the P5Q3, there's still no sound, even without RAM.

So I think I've narrowed it down to
a) motherboard
b)CPU
c) faulty PSU cable?

As they're the only parts connected at the moment. Any clues?

EDIT: Heard somewhere that flashing my BIOS may help... Would it? Considering I can't get a screen it may be a bit hard. (never done it before, so I wouldn't know)
a b Ĉ ASUS
a c 229 V Motherboard
June 27, 2009 12:52:51 PM

If it won't even beep, flashing the BIOS is impossible and certainly shouldn't be attempted. Are your parts outside or inside the case? You should test your parts outside of the case to make sure that the motherboard isn't shorting out to a post that shouldn't be there or something else. I've seen faulty PSUs, but not a faulty cable.
!