How do I prevent my secondary hard drive from going to sleep?

I have an intel 80gb ssd as a primary drive, and a 640gb WD caviar black as the secondary drive, for music, movies and data.

The problem is that whenever i dont use my secondary hard drive for a little bit, and i want to play music, or browse folders, there is a delay, about 2 - 3 seconds, and i hear the hard drive powering up.

There must be a way to prevent my hard drive from sleeping?

Thank you very much guys.

btw i am running windows 7 ultimate (x64)

EDIT : in control panel, my power option is "High Performance"
2 answers Last reply
More about prevent secondary hard drive sleep
  1. Go into the "Change advanced power settings" link in your power management profile. Click the plus sign next to Hard Disk, then click the + next to "Turn off hard disk after" and change to 0. That should do it.
  2. As far as I've experienced with several samsung disks is that power setting prevents system drive ONLY. Might be the BIOSes of the drives or mobo communicating with them. BIOS may want prevent bearings from wear and such.I haven't figured out.Only solution seems 3rd party software that uses hard disks on regular interval.
Ask a new question

Read More

Hard Drives Storage