Sign in with
Sign up | Sign in
Your question

BIOS detecting SATA drive but not recognizing

Last response: in Storage
Share
Anonymous
a b G Storage
August 9, 2010 6:09:29 AM

Hi, I've searched through several threads looking for a solution and while some seem to have had similar symptoms, nothing I've tried has worked. First of all I have two internal HDDs on my Windows 7 machine. One is a Maxtor IDE and one is a WD SATA. I use the IDE for storage and have my OS installed on the SATA. For quite a while I've been having some trouble with booting up involving Verifying DMI Pool Data, etc. and after several weeks I noticed that sometimes my SATA drive would not be listed in my BIOS.

Usually the problem resolved itself (kind of) if I restarted my computer a few times. For some reason after CTRL ALT DEL'ing a few times to restart the computer, the SATA drive would magically appear and I would be able to boot my OS. I've been using a different machine for the past couple of days and now when I try to boot my other computer up to back up some data and then reformat to sell it, I'm unable to boot because my BIOS won't recognize my SATA drive!

I titled this thread in such a manner because of one thing I've noticed, and have noticed that some other people have inquired about as well : where ever SATA port I plug the drive into, my BIOS always shows that port with an empty space. I have an EVGA nForce 790i Ultra SLI mobo. It has I believe 6 SATA ports, and each of them are listed every time the BIOS comes up. If I plug the drive in SATA 1, the other five ports (excluding my SATA DVD burner which is detected correctly every time btw) show "None" but SATA 1 just shows a blank space. If I change the port, the same thing happens where ever the HDD is plugged in to. This seems to tell that the drive is in fact being detected, just not "recognized" like the IDE Maxtor drive and the SATA DVD burner are.

I would like to rule out the possibility of the drive being bad. I've booted into the Ultra Windows Boot Disc and ran 2-3 different HDD diagnostics on each of the drives and no errors were found. Another thing that baffles me is that the problem, again, seems to resolve on its own if I sit there and restart enough times. I've tried resetting CMOS, switching through every different SATA port, switching the SATA cables between the DVD burner and the drive, turning the SATA cable around, just about everything I can think of. I hope someone can help! Believe me though as soon as I'm able to boot from the drive, I'm xferring everything to an external and reformatting the IDE, possibly chunking the SATA drive if I must. I just don't think there's a problem with the drive itself :??: 

Thanks in advance!
August 9, 2010 6:25:40 AM

Sounds like a bad HDD to me.
m
0
l
Anonymous
a b G Storage
August 9, 2010 6:35:02 AM

I am seriously floored by my carelessness sometimes. Of all the tech forums, I (THINK) I've found my solution through a random Yahoo Answers link. I unplugged the power from my only other SATA device (DVD burner) and plugged it into the SATA drive - voila. Although I have gone several days without any problems from the drive before, so does it sound plausible that this isn't a real solution? I've just never known a single cable from a PSU to give out. Is it normal for that to happen? Everything else (GTX 260, CPU, fans, IDE, etc.) all seem to work fine so it appears that only the power supply cable going to the SATA drive is malfunctioning. Thanks again.
m
0
l
a c 93 G Storage
August 9, 2010 4:13:02 PM

You could simply have a flaky SATA power connector. As long as you can power all of your devices/sub-systems you are good to go. My suggestion was going to be, check/swap your SATA cables. You were describing a loose connector. Been there, done that. Good luck!
m
0
l
!