Sign in with
Sign up | Sign in
Your question
Solved

EP45-UD3P: eSATA, AHCI and BIOS help please

Last response: in Motherboards
Share
July 5, 2009 2:30:17 PM

Ok, I'm gonna try to give you so much info as possible.

My rig consit of:
MB: EP45-UD3P
CPU: C2D E8500 @ 3.16
RAM: 4x A-Data 2GB PC6400 800mhz
GFX: XFX Geforce 9800GTX+
DVD: Samsung 52x Sata Writer
(C: ): 500GB Seagate Barracuda Sata
(D: ): 1.5TB Seagate Barracuda Sata
(E: ): 250GB Seagate Barracuda IDE
Card Reader: Random *** with 8 card slots and a USB slot
Case: Cooler Master 690 with eSata, 2xUSB, firewire and Mic on the case roof
OS: Windows Vista Home Premium 64bit SP1 OEM

So 2 weeks ago I bought another 1.5TB Seagate drive to put in my Tvix (media jukebox), I first connected it internally in my PC, rebooted and formated. Then last week I bought a Revoltec Alu Guard hdd case with eSata and USB connection. I haven't got my third 1.5TB yet (this one I'm gonna put in the case and store backups on)


Well, now the the problem.
I put the Tvix 1.5TB hdd in the case just to try it out. I connected it to the PC with eSata for faster transfer rates just to discover that it ain't plug and play. I don't want to reboot every time I connect it so I started to google for answers.
I found out that I need to activate something called AHCI in the BIOS to enable hotswap with eSata.

But when I enabled AHCI the system fails to boot, it says that it will do a test for AHCI for a couple of seconds, then some text scrolls by (the usual just before windows starts loading) and ends with "Verifying DMI Pool data".
But then I just stands there, blinking, like it doesn't recognize either my hdds or dvd drive.

I rebooted and turned of AHCI, then it goes trough the text again and stops at "Insert system CD/DVD", like it doesn't recognize my hdds.
Reboot again and press F12 at startup to go into boot sequence, select HDD, then my C: drive. Now it finally boots correctly.

I continue to google and see that you can't enable AHCI on XP machines after OS install.
And that some people have had problems on Vista pc but solved it by changing a value in the registry ( http://support.microsoft.com/kb/922976 ) . I do that and try to enable AHCI. But same problems again.

I read that some people are having problems with detecting DVD drives with AHCI enabled and they active something called Native IDE in BIOS. I see that this apparently make the SATA slots 0-3 to become something with IDE. I think that this will solve my issue and enable it without any success. I then change it back to what it was before.

About here I'm starting to give up, 5 hours of "try and error". So I startup a game and spend some time with the family.
Then this morning when I start my PC it shows the "Insert system CD/DVD" again and I need to press F12 to get into windows.


So could anyone please help me? =(
If I can't make eSata plug and play I at least want to be able to start my PC normally.



Some more info:
I haven't reformatted since I bought the PC this Christmas.
I don't know if you could change some setting for AHCI when installing the OS. I just did it the ordinary way.
I haven't flashed the BIOS either.
My C drive is on Sata port 2_0
D drive on Sata port 2_01
DVD drive on Sata port 2_02
IDE drive on IDE
My eSata ports are on Sata port 2_04 and 2_05
Nothing on my purple (raid) Sata ports
a c 236 V Motherboard
July 5, 2009 2:53:07 PM

Why not connect your eSATA to the GSATA controller (purple connectors)? You could configure the GSATA as AHCI, install the JMicron drivers and it should work. That's how mine is setup.
m
0
l

Best solution

a c 177 V Motherboard
July 5, 2009 3:08:23 PM

Ghislain has it; my purple ports (GSATA connectors, jMicron ports) also are my eSATA with AHCI enabled (and I have a Seagate 1.5TB on them); if you still have grief, here is an article regarding installing AHCI drivers on a functioning OS:
http://forums.hexus.net/hexus-hardware/112584-how-enabl...
The "Native Mode" setting in the BIOS simply turns on interrupt request sharing for the drive controllers; it has been supported by Windows pretty much forever; it should be enabled unless you're running Windows ME or earlier...
Share
Related resources
July 5, 2009 5:01:03 PM

Ok, I feel like killing something right now...

When I rebooted after switching the cables again I changed to AHCI, then it halted at "Verifying DMI Pool data" again and I thought "Hmm, can I press F12 with AHCI enabled?".
Yes I could, and when I got into windows drivers were being installed by Vista. I rebooted again and the system halted again...
I checked the bios again and saw that the 250gb IDE drive had become first boot device. I changed it back so the 500GB was the first and rebooted.
Now it works, and eSata is recognized when plugged in ._.*

I saw that Native IDE mode became Inactive when I switched to AHCI. Hope that's ok..
And somehow my system seems to boot faster now, don't tell me that I've been running all the drives on IDE speed until now...


Thanks for the tip anyway GhislainG, it solved my issue with running out of Sata ports and tightened up some of the chaos in my case.


Hope this thread can help other people with the same problem in the future.
m
0
l
November 18, 2009 11:37:14 AM

To enable AHCI You need to install XP with AHCI already selected in your BIOS.

m
0
l
a c 177 V Motherboard
November 18, 2009 12:22:21 PM

Now ya see here son, this is what we call a dead thread, it died as no one was interested or no one had info for it, or the author found the info and decided to let the thread die.

So we buried it, gave it a funeral and let it lie in peace.

Now what ya have done here is Necrothreaded it back into the living realm, disturbing its grave and its peace! Why boy, why? The poor thread has suffered enough! Let it rest!!

For your own info, should you ever need to, here is procedure for 'adding' drivers to an existing OS - it ain't pretty, but it (most often) works:
http://forums.hexus.net/hexus-hardware/112584-how-enabl...
http://edmundtse.wordpress.com/2008/11/06/upgrading-com...
m
0
l
November 19, 2009 7:20:53 AM

lol. brilliant man. you should be comic writer.
m
0
l
a c 177 V Motherboard
November 19, 2009 2:02:24 PM

Aahhh - I can't really take credit for that one - found it somewhere and figured "I gots to have this" - happens three times a week!
m
0
l
!