Sign in with
Sign up | Sign in
Your question

Seagate FreeAgent Go only recognized through 4-Port hub

Last response: in Storage
Share
August 12, 2010 11:41:49 PM

I have an HP computer running Windows XP, SP3. I had been using my Seagate FreeAgent Go with no problems until my son used it on his laptop and now when I try to plug it back in to my computer I get the "Not Recognized" message.

The twist to this though is if I use my cheap little 4-Port hub and plug it into the computer and then plug my Seagate into that, the computer recognizes it. The problem with that is that the harddrive doesn't run fast enough through the hub and every time I try to back up files it "fails".

I have tried uninstalling/re-installing Seagate harddrive, etc, but nothing is working. It won't recognize it if it's plugged directly into the computer. Any help is much appreciated as I have been trying to fix this for days now.
August 13, 2010 9:25:24 PM

is the usb hub that you're using powered?
m
0
l
August 15, 2010 3:47:55 AM

nsquid said:
is the usb hub that you're using powered?


No, it's just one of those cords that's about 1' long, with a USB plug on one end that plugs into computer, and the 4-port on the other end.
m
0
l
August 16, 2010 5:31:53 PM

i'm wondering if there's something wrong with the drive and windows isn't able to see that properly when it's connected via the hub, if it's failing when you try to back it up and not recognizing it at all when directly connected.

see if you can connect it to your son's computer or plug it in via hub and run a chkdsk. i run hard drives through hubs frequently, and while slow, it never prevents them from running. i'm wondering if the computer is seeing a generic storage device plugged into a hub and not being able to see anything wrong with it, but when it's plugged directly in it's able to see a problem with the drive.
m
0
l
!