Sign in with
Sign up | Sign in
Your question

Gigabyte GA-945D-PS: 2nd drive not showing correct size

Tags:
  • Gigabyte
  • Hard Drives
  • Motherboards
Last response: in Motherboards
Share
July 7, 2009 5:48:41 PM

The above MOBO used to run my gaming rig. At the time it ran two drives (250 Gig & 200 Gig) with no problems. I have since tried to install Windows Home Server. I bought two 1TB Western Digital Caviar Hard Drives to do this. In BIOS, the first drive shows the correct size of the hard drive, the 2nd hard drive is only showing 33 Gig even though it's a 1TB drive. When I go to "my computer" in WHS, the 2nd drive doesn't even show up.

Any theroies on why this is happening and how to fix it?

More about : gigabyte 945d 2nd drive showing correct size

a c 177 V Motherboard
July 7, 2009 6:45:28 PM

That's a characteristic of Home Server; it 'consolidates' available drive space, rather than normally showing the partitions; it may, also, by default, be duplicating your files on two drives - kind of like using a RAID1 array, but, technically, doesn't actually support RAIDs...
July 7, 2009 7:11:17 PM

I agree, it does consolidate but it should show well over 1800 Gig were as it only shows a little under 1000. There are two partitions set up right now. C: Partition is only 20 gigs and I expected that. This is reserved for small programs to be installed on the server, the second partition D: shows 913 Gig and this is the begginging of the storage pool. If that second drive was funcitoning, that pool should show well over 1500 Gig.

The fact that the 2nd drive only shows 33 gig in BIOS makes me really think the MOBO isn't picking up on it properly.
Related resources
a c 177 V Motherboard
July 7, 2009 11:52:25 PM

I'll do some serious rooting here for you - I wanna know everything I can about this anyways. I'd like to put in a home server with a ten drive x 2Tb hardware RAID6 array: 10 - 2 parity - 1 hot spare should give me around 12 - 13 Tb; I like the idea of all the nearly effortless functions that WHS performs, but I'm not thrilled that MS says directly 'no RAID support' (though some actually have it working), and they don't make a 64 bit version (I've thought to use a 12Gb i7 board, use the first four for the OS, and run a RAMDisk on the remainder, to use it as a swap drive...)

Ahhh - now I see, not showing in the BIOS - um, maybe there's some kind of problem in the MBR on the drive itself - nah, that shouldn't matter, mine write an MBR on a per boot basis, and the BIOS still always knows... I have no manual (yet) for that MOBO - does it have Intel and GSATAs? If so, which is the errant drive on? Meanwhile, I'll get a manual, and dig a bit into the actual BIOS' mechanism for 'seeing' the drive size/organization...

Back in a bit...

Bill
July 8, 2009 12:12:49 AM

My apologies, yes, typo.

It's a Gigabyte GA-945P-S3. There are a few revisions of the MOBO, I'm pretty sure mine is 3.3. Sorry bout that, was posting from work and going by memory. Another correction, BIOS is showing the 2nd drive as 33 Meg, not Gig.

Somone else suggested that formatting may need to be done, what do ya think? How the heck do you format a drive these days anyways? Been ages since I did that and certainly didn't do it on the first one but that may have been part of the install process.

Quote:
does it have Intel and GSATAs? If so, which is the errant drive on?


Sorry, not sure what you are asking here. Intel procsessor? As far as I know, these are just regular SATA drives. Once you are able to pull up that manual, my primary drive (the one that works) is sitting in the top left SATA plug on the MOBO.

Thanks for the help so far Bill, appreciate it :) 
a c 177 V Motherboard
July 8, 2009 12:54:09 AM

God almighty! I swear Gigabyte runs their web site on an old Apple IIe with 16K of RAM! Took forever to even get to the product page, much less dl the manual... I've got it now, but will be out of action for say, an hour and a quarter - I turned my dad on to an old pot grower's trick - gibberellic acid - and his tomatoes are threatening to take over the whole yard if we don't get some fencing up, and, the damned rabbits are eating the shoots of the cantaloupe as fast as they can spring up - I'm thinking maybe we should just put out a bottle of salad dressing for them...

Talk at ya' soon...

Bill
a c 177 V Motherboard
July 8, 2009 1:17:45 AM

Ackk! This is really wierd; if it showed the size of the last drive you had plugged into the port, I say, fine, it somehow got 'stuck'; but WITH is it getting 33M from? One thing came to mind - it's kinda back there - has it had a BIOS update recently? You'd think, though, if it could read one big drive OK, it should do the same for the other... My router has that peculiar braindead quality to it - if I format my 1.5 NAS drive to 1023 G, it works, well, not fine, but adequately - If I format a TB or more, zoop - it's gone (I think it's running a Linux kernel...)!

Well, I'm tackling the manual now - will post when I have, at least, a guess...

Bill
a c 177 V Motherboard
July 8, 2009 1:24:20 AM

Never guess what I found on the GB BIOS page:
"F7c 2008/06/05 Support 1000 GB (1TB) HDD"
May be our problem??
http://www.gigabyte-usa.com/Support/Motherboard/BIOS_Mo...
If you need any BIOS flash info, post back - and, I don't know if, back then, it came with the @BIOS flasher, but if it did - DON'T use it! Kills more GB MOBOs than the next four causes combined...
July 8, 2009 1:27:57 AM

lol, nope, it wasn't the issue. Get this, I'm one of the 1% that got a defective drive!!!

I had enough, took it to the place I bought, explained the situation and asked them if they diagnostic machine just to see if they are seeing the same thing, sure enough they were. Replaced it, brought home the new one, BIOS is now showing 1000GB on each!! Thank GOD!!! All this time I thought I was doing something wrong, guess it was looking at the cache as the fill capacity of the disk, ehehe.

thanks a ton for your interest in my issue, Bill. Your a good man :) 

PS - Glad I'm not the only one that thought Gigabytes website was garbage.
a c 177 V Motherboard
July 8, 2009 1:44:45 AM

Always welcome, and glad you got it solved - I got a couple of the 1.5s with the infamous 'Seagate Stutter', and thought I had SATA problems with my jMicron ports - 'till 'the Stutter' became well known. Recently hunted around for drive prices on NewEgg, and saw someone with a failure rate of three out of ten in the first month of service - Seagate appears not to be 'what they once wuz!' My first ever hard drive was a Seagate ST-225 (20 meg, in three partitions 'cause CPM had an 8M max) stuffed into a 64K KayPro (KayPro only offered 10M drives from the factory...), & I paid about $600 bucks for it! Couple years before that, in '69, our HS math class got access to a corporate mainframe, and they had new hard disks to supplement their tape drives - a ten meg drive was the size of a chest freezer...
!