Windows 7 Preventing Overclocking?

Hi all,

I recently performed a clean install to Windows 7 from Windows XP on my desktop computer. In Windows XP, I achieved a stable overclock of 2.96 GHz from 2.33 GHz (more specs below). This was done from BIOS and confirmed by CPU-Z. With Windows 7, however, the same exact BIOS settings appear to have no effect: CPU-Z reports the factory default 2.33 GHz. EVEREST Home Edition concurs with CPU-Z.

I've tried several things, but all to no avail. Software overclockers (such as SetFSB and ClockGen) read the FSB as 333 (factory default), but when I attempt to increase this FSB, there is no effect - they drop back to the default. This makes me wonder if Win7 is over-riding any overclock - but shouldn't at least the BIOS settings dictate FSB speed?

From BIOS, turning off the C1E feature and EIST function have all had no effect. Updating my BIOS also had no effect, and neither did downgrading the BIOS.

This seems to be a Windows related issue, since from Ubuntu 10.04, I can run a simple CPU speed script that gives me substantially higher values than with no overclocking - indicating overclocking is successful in Ubuntu. It may be worth mentioning that my XP edition was 32-bit, whereas the current Win7 is 64-bit.

I've spent awhile searching for forum posts of similar problems but have found nothing. Any thoughts or ideas would be greatly appreciated!

Thanks in advance.



Intel Core 2 Duo E6550 @ 2.33 GHz, 333x7 (factory default)
2x 1 GB RAM, DDR2 800, A-Data (will be upgraded soon)
nVidia GeForce 7600 GT
Dual-boot: Windows 7 Enterprise x64 with Ubuntu 10.04 x64
4 answers Last reply
More about windows preventing overclocking
  1. Windows has no reign over you CPU speeds. Are you sure you disabled EIST. Just load up the CPU (Prime 95) and check its speed. Hopefully you are running proper speed otherwise it is very weird.
  2. It appears you are trying to use software running from within windows to perform an overclock. Please stop. Use the Bios.

    As pointed out, the OS has no direct impact on whether or not an overclock is successful. So there's no reason why an otherwise fully stable speed would be do~able on one OS and not on another. Also - going from 2.33 GHz to 2.96 is only a 22% effort, which on a Core2 should be easily achievable.

    Suggestion: If you're simply turning up the Front Side Buss, then I strongly recommend *lowering* your memory divider (i.e. UNDERclock your RAM) to allow proper overhead while you work on your processor. This is a very common mistake.
  3. Seems I've found the answer to my own question. This morning, after a cold boot, found that BIOS would not save my FSB options no matter what. I then reset CMOS, flashed the latest BIOS version, and loaded optimized defaults. Now BIOS remembers the overclocked setting, and CPU-Z reports the proper overclock in Win7. Even Win7 itself reports the correct CPU speed under System. :bounce:

    Happily overclocking at 2.98 GHz, undervolted by 0.05 V to keep it cooler (idle temp at 34 C, under full load at 45 C - seem reasonable?), and finally got a 1:1 FSB:RAM ratio - thanks for the RAM tip, Scotteq!

    Quite odd, since apparently yesterday BIOS would remember the settings but not put them into effect. Anyways, thanks for all the help!
  4. Very Nice :)

    To check stability, I recommend running Prime 95 and/or OCCT overnight or while you are away at work. 6, 10, 12 hours... Longer is better, though it's easy to get stupidly anal retentive while testing. In the morning, if your system is running error~free; at stable and sustainable temperatures, then you are good to go.

    I like OCCT, since it makes graphs which you can review later on and see things like whether or not your voltages are stable (good), or do they vary (bad). Temperature fluctuations... etc.. But they're both excellent tests, and one can find errors the other misses.
Ask a new question

Read More

Overclocking Windows 7 BIOS