Sign in with
Sign up | Sign in
Your question

The MB does not "find" the onboard LAN (Gigabyte X58 UD4)

Last response: in Motherboards
Share
July 10, 2009 5:23:42 PM

Greetings!

I've recently purchased the Gigabyte EX58-UD4 and I'm having some problems with the onboard LAN. (I've tried with both XP and Windows 7 64-bit, currently using W7)

The Device Manager or the Control Panel does not list the the onboard card, and I can't seem to find any drivers that will work.
It's like it's not even there!

When installing the driver, I get this message:

"The Realtek Network Controller was not found.
If Deep Sleep Mode is enabled Please Plug the Cable."

The cable is of course plugged in.

In the BIOS (F5), there is a function called "SMART LAN", but this function does not work either.

What is wrong, and can you please help? If so, can you give me link to the correct driver, beta or not?

Thanks alot! :) 
a c 177 V Motherboard
July 10, 2009 6:26:04 PM

As you mention being in the BIOS, I assume you've got it all set OK, but just as a 'searchable' review:

On the "Integrated Peripherals" page:

"Onboard H/W LAN" to "Enabled"
"Green LAN" to "Disabled"
"Onboard LAN Boot ROM" to "Disabled"

Obviously, because the RTL8111D that does you LAN connection is 'hung off' the southbridge (ICH10R), the drivers for it must be successfully installed first, to enable 'discovery' of the LAN chip, before its own drivers can be loaded. That said, I've seen some chatter that, for some setups, the Win7 'native' drivers don't seem to do the job (in my own experience, one of the nicest things about Win7 is that I've been able to 'throw away' the GB driver disk - the 'natives' work like a charm) and updating the system will replace the RealTeks with MS drivers that don't work...

The latest RealTek drivers are here:
http://www.realtek.com.tw/downloads/downloadsView.aspx?...

If you're simply not showing the LAN hardware in device manager, something else is hosed... This is, essentially, a public beta: the x58/i7 combo is unknown territory; you will want to update your BIOS (F8 is current):
http://www.gigabyte-usa.com/Support/Motherboard/BIOS_Mo...
and your drivers:
http://www.gigabyte-usa.com/Support/Motherboard/Driver_...
as new ones become available - that's one of the prices you pay for 'the latest and the greatest'!

If you need assistance with flashing the BIOS, post back - but - DO NOT use the @BIOS utility; it's like saying "may I have a dead MOBO, please?"

Once you get drivers in, there is an excellent RealTek LAN subsystem diagnostic at:
http://rapidshare.com/files/123870646/RTNICDiag_v1003.z...
July 10, 2009 9:46:05 PM

Thank you for a great reply!

I've flashed the BIOS to F5 (That's the most recent - I have UD4 not UD4P).
I've tried every possible driver. (I think)
I just really don't know what to do anymore. My BIOS settings were just like you suggested.

All the forums I've visited before, had problems with the drivers being the native ones from MS. Solution was to install the ones from Realtek. I think my biggest problem is that mine does'nt even show up in the device manager. It kinda feels like I've disabled it somewhere (not BIOS I think), like it just needs to be activated.. I'm just not able to intstall any drivers, because it's nothing there!
When running the diagnostics tool you gave me, it just opens up with a message saying: "Install the correct driver", with no more info, but still not able to roll back any drivers.


Some history though:

When booting the very first time, my keyboard did'nt work in the BIOS, due to the USB/PS2 thing, so by default it booted into Ubuntu instead of Win (Grub - Dual Boot). Ubuntu was able to find the HW, so I was connected to the internet just fine.

I got my keyboard to function, so tried XP. XP did'nt find anything, so I thought that Win7 would solve this, since I was gonna install it anyway. To do this, I had to remove Ubuntu. (My HDD is a mess)

Actually, thinking of this, makes me wanna run a Live CD, but that would not solve the problem for Win7.
I think that this means that the HW is fine, but the SW is not. I mean, why am I able to ping my self. This makes no sense to me, whatsoever.


I'm so tired of this, and it really really bums me out, as this PC is a completely new.

Any ideas? Is there a way to make the LAN controller to "wake up"?
Related resources
July 10, 2009 11:03:32 PM

How many different drivers have you installed? goto AddRemove Programs and take a look in there, multiple drivers might be fuxin with you.
a c 177 V Motherboard
July 10, 2009 11:04:51 PM

Ackk! I just assumed (yeah, I know) that you typo'd the UD4P; I usually use this page:
http://www.gigabyte-usa.com/Products/Motherboard/Produc...
to find boards (and more importantly - manuals!) If I need something other than 775s, I click on the socket # - clicking 1366 gives:
http://www.gigabyte-usa.com/Products/Motherboard/Produc...
or, at the original page, typing "GA-X58-UD4" into the "More product search" gives: "product not found", and using the second board selection menu set gives:
http://www.gigabyte-usa.com/products/motherboard/Defaul... 1366&ChipsetType=Intel X58&IsChked=N

In other words, they seem to be hiding your MOBO in a closet somewheres; nor is it still for sale anywhere I can easily find... I don't know if you're old enough to have seen Mission Impossible on TV, but this reminds me of where Mr. Phelps would get his instructions for the weekly caper via tape or wire recording, it always included "If you or any of your IMF team are caught, the president will disavow all knowledge blah blah blah", and then the tape would go up in smoke!

I don't want to 'preach to the choir, here, but when the i7s were released I posted this a few times:
Quote:
" This is a completely new chip mask, with a completely new northbridge, a completely new memory technology ('direct connect three channel'), which requires completely new boards, with completely new BIOS! There were bound to be problems, and some serious! You should expect weekly BIOS upgrades, and scads of difficulties - it's, essentially, a huge 'public beta' project..."

This may have been one beta gone south...

Mind you, I'm pretty much of a 'Gigabyte supporter' (and no - that's not something like a jockstrap) here, but I think you've been hosed...

I think your board may be 'orphaned'; if it were mine, I'd get on the phone, and tell GB that if they don't RMA your board 'gracefully', you'll make the biggest public stink they've ever seen on the web, and you'll personally camp in your company's IT department, until they change suppliers to ASUS!

I'm really at the end of options (and knowledge, for that matter - mine is fairly slender - I'm about halfway through reading the [50 meg of] Intel tech documents on the i7/x58 combo); one thing I might recommend, is doing a clear CMOS, followed by a "Load Optimized Defaults, just in case something is getting somehow 'stuck' in the BIOS' discovery routines; it's also possible that if there's anything even slightly 'flakey' being set at auto in the QPI channel, it could be the culprit - there is no 'northbridge' anymore, pretty much the x58 just 'twiddles its thumbs' and manages the QPI interconnect - everything goes through it...
July 10, 2009 11:24:10 PM

Haha sweet! I should actually do that! However, Ubuntu got the LAN Controller to work. Very strange.
I wish I didn't have to RMA, I just waited over 3 weeks to get all the parts I needed for this build.
It must be a way to get this to work! I will at least try to Load Optimized Defaults, as you said.


@doormatderek:
Actually I just checked, and I found two drivers specified for the LAN Controller.
I uninstalled them both, and re-installed the "right driver" (realtek_rtl8168_7003_win7 - am
I way off here?), but it still didn't work. But good a thought though! :) 
a c 177 V Motherboard
July 11, 2009 12:06:13 AM

Quote:
Ubuntu got the LAN Controller to work.


Well, then, at least, we know the hardware is 'pretty OK'. Isn't it amazing how a bunch of geeks hacking to the common tune of the GNU can get this **** to work, when Gates' crew of geniuses bobble at every turn?

Quote:
I wish I didn't have to RMA, I just waited over 3 weeks to get all the parts I needed for this build.


I'll tel 'ya what - I'd rather wait ten extra days for an RMA of a UD4P, than spend eighteen months or two years struggling with a sub-optimal product!
July 11, 2009 1:10:58 AM

I agree. I just installed a fresh copy of XP, which Gigabyte has plenty of drivers for. Still no network adapters in the Device Manger. (Well except 1394)


Thanks alot for your help! Even though I'm really sad that I have to return it, I'm glad that it is an actual solution.

Last question:

I should proberly go for someting else than Gigabyte now? Any suggestions? I guess not ASUS, because I hear that they have issues with OCZ RAM, and I have OCZ RAM.
a c 177 V Motherboard
July 11, 2009 1:34:03 AM

Nah - a lot of people have GB x58 boards cranking; take a look around TweakTown:
http://forums.tweaktown.com/f69
http://www.tweaktown.com/news/10827/gigabyte_shows_how_...
These guys are serious crazies, they're posting modded BIOS, and hardware board mods:
http://forums.tweaktown.com/300786-post1025.html
just for example; I think GB makes the best boards out there, but with all the utterly new **** with the i7/x58 combo, there were bound to be some 'mis-steps'...
You just happened to get (I think) one of them!

July 11, 2009 10:43:12 AM

Great links! Thanks! I've asked the same question there, as it seems that there are some Gigabyte techs there. If this does not work - RMA

Yeah, but what are the odds for that happening to just me. I think it's strange that I haven't seen this problem anywhere else, on any of the forums. I mean, someone has to have same problem as me. I guess I'll start play the lottery from now on :) 
a c 177 V Motherboard
July 11, 2009 2:44:08 PM

Quote:
Yeah, but what are the odds for that happening to just me.


I'm again guessing that this is a cover-up job; they've probably RMAd hundreds of boards, and it's pretty obvious that they've 'pulled it' from the channel... This has to be something that's a marginal, 'ragged-edge' problem - as it sometimes works (under linux); it could be a problem with the SMB (Systems Management Bus) or the DMI enumeration (Desktop Management Interface), just not presenting Windoze with the properly formatted data for DeviceManager/PnP to find it...

You know, now that I mention this, I remember there being a problem involving mis-identification of the SMB identifier; I think (but am no longer sure) it was mostly an issue with MOBOs using ATI vidcards, but the SMBs were getting ID'd as ATI, and the wrong driver was getting installed - which hosed up other drivers that are managed by the SMB. Go into the device manager, open the 'system devices' item, and about half-way down, check that you have an "SMBus controller item, and that it's identified as Intel. It would strike me as odd if this were it. though, as I recall it being a Win7 issue - don't believe I've heard of it affecting Xp.
July 11, 2009 8:30:57 PM

You know, this is the strangest thing ever;

I reinstalled Win7 after trying XP again, changed the HDD's Master/Slave (I had them backwards). That's all I did.
Now it all works perfect! The LAN card is now showing in the Device Manager with a driver installed.

I really don't know why its working now, but I'm very happy that it does. :D 

a c 177 V Motherboard
July 11, 2009 8:39:40 PM

I think Rod Serling is standing in a corner smewheres here narrating...
July 11, 2009 9:16:19 PM

I think so to! I better check! :lol: 
July 12, 2009 8:20:11 AM

WTH... Here I am with my new i7, X58 UD4P setup, been working great for about a week. I installed Win7 on a new SSD and everything has been working. I have a HDD with Ubuntu and XP that I want to get working with the new i7 machine. I add an entry for the Windows boot loader to point to Ubuntu. I reboot into Ubuntu and get to the desktop. Good, but no network. I need the LAN driver, so I reboot into Win7 and... NO FREAKING NETWORK!

Device manager does not show that a network adapter exists. We can't even start talking about drivers, because as far as Win7 is concerned, there is no onboard LAN!

I have tried many things: I used Device Manage to remove almost everything under "System devices" (SMBus, etc), reboot, Win7 finds stuff, still no LAN. Made sure onboard LAN is enabled in bios. Disabled, booted Win7, enabled, booted Win7, nada. The Smart LAN entry in bios shows a blank page until I hit escape. I remember using this entry a while ago and after a delay (where I could not press escape) it showed me some info, like how long my ethernet cable is. When I plug in the ethernet cable I get a green light right away, on steady then either the orange light doesn't come on, or sometimes it blinks a few times then goes out. During boot orange blinks a couple times. I tried different ethernet cables and connected them to a different computer to ensure the cables/router/ISP/etc are working. I was running bios F8, but I reflashed it, loaded the defaults, booted Win7, still nada.

Is it possible that something Ubuntu does causes the hardware to get smoked? That is crazy, but I'm pulling my damned hair out! Stupid thing was working fine, then all of a sudden doesn't work!? The OP here has the same problem and the common factor seems to be Ubuntu!? I feel like I'm in the f---ing Twilight Zone!

The only thing I can think to do now is try to restore to a backup I did with Acronis a few days ago. I'd really rather not though (some say Acronis won't restore the partition with the same alignment for my SSD). I just want my LAN back. /cry

Any help, ideas, advice, etc would be great!
July 12, 2009 12:35:52 PM

I found the fix: power down and unplug the PC. Do a little f---ing dance, power back on and it works. Apparently Ubuntu really does somehow smoke the LAN so even the bios can't see it, and powering down fixes it. Never heard of such a crazy thing!

I would have found something earlier, but you see, the internet didn't work... iPhone browsing sucks!
a c 177 V Motherboard
July 12, 2009 2:36:24 PM

Ahhh! That explains (or at least insinuates a cause for) a problem I've got with Ubuntu in a Sun Virtual box under 7x64 - LAN goes away - doesn't come back 'till a cold boot! (Ang I can't blame this one on the x58 - I'm running an x48...

nates - you might want to work with us here:

We seem to be accumulating a sizeable crowd of people here who are having problems with the new i7/x58 hardware. I have seen the 'boots with one stick of ram' thing from several, a couple of 'non-discovery' of various hardware, some clocking inconsistencies - well, a pretty good sized mess!

I have an idea, and I'm going to 'plant' this post everywhere I think it might do some good, and see if we can get together a bit of a 'real-time' experiment; I'd like to try to see if as many as possible can get together at one, mutually convenient time, and try to whip these things as a group. I've been studying both the Intel docs for the i7/x58, and the GB manuals; my guess is that, for all the things that count (like QPI adjustment, 'uncore' handling, memory interface, etc.), all the GB 1366 MOBO's circuitry and BIOS are pretty much the same, so hopefully if we come up with a workable strategy, it should be workable for all...

I'm going to start a new topic (say 'Ganging up on the i7/x58'), and, if you're interested, please copy the following, and post to that topic:

MOBO Model:
CPU:
RAM (Manufacturer, speed, model number, # of sticks, nominal voltage):
BIOS rev:
Short, concise problem definition:



Suggestions for a time (date?) when you could (I'm pretty flexible here) spend an hour or two kicking its ***! :





If there are bad components involved, we'll try to isolate them, and probably we'll learn a lot about what works, and what's marginal, for others to draw on...

Bill

aka: bilbat
July 12, 2009 9:32:45 PM

Funny how I had the exect same proble. But when formating the HDDs, and then changing the Mastar/Slave config, it all worked. One of the partitions had Ubuntu on it, which was deleted in the process.

But how could Ubuntu make the LAN disapearin Windows? It should be impossible, but I very much doubt that this is a coincidence. This is just wierd, it makes no sense. At least not to me.

Glad you solved the problem tho, it's still working right? With Ubuntu too?

July 14, 2009 6:07:03 AM

Ubuntu doesn't just make the LAN disappear in Windows, it messes it up for the bios as well. That is the nutty part! Ubuntu tries to use the wrong driver. I successfully followed some directions to install the right driver, after which the LAN worked in both Ubuntu and Windows 7, without any stupid business. Here are the directions, for safekeeping:

http://ubuntuforums.org/showpost.php?p=4563390&postcoun...

1 - Downloaded current driver from :
http://www.realtek.com.tw/downloads/downloadsView.aspx?...
2 - Unpacked on the Desktop
3 - $ sudo mv r8168-8.004.00 /usr/src
4 - $ cd /usr/src/r8168-8.004.00
5 - $ sudo make clean modules
6 - $ sudo make install
7 - $ sudo depmod -a
8 - $ sudo insmod ./src/r8168.ko
9 - $ lsmod | grep 8186 #just to check it was there
10 - $ cd /etc/modprobe.d
11 - $ sudo touch blacklist-network
12 - $ sudo vi blacklist-network # add "blacklist r8169" to the file
13 - $ sudo update-initramfs -u #to make the change permanent
14 - reboot

When I did it the latest driver was r8168-8.012.00 and it worked fine, just change the bits above to match the latest version.
a c 177 V Motherboard
July 14, 2009 12:39:14 PM

Thank you ever so much! I'm quite sure this will fix my virtual machine as well - will report back when I get time to implement..
September 13, 2009 4:18:39 PM

Hi, I got the same problem twice with X58 Extreme.
First time, I unpluged the power and cleared the bios, then both Win7 and Mac recongnized two network adapter;
Second time, Only one network adapter is reconginzed. Not sure if it's a problem for the motherboard or not?
a c 177 V Motherboard
September 14, 2009 2:44:05 AM

Have you sped up your PCIe frequency to facilitate OCing? The net chip is the first to go...
a c 177 V Motherboard
September 14, 2009 2:44:48 AM

not go as in 'cooked'; go as in inaccessible
Anonymous
a b V Motherboard
March 12, 2010 7:10:58 AM

I fix the same problem in the same way -> unplug the PC for 10 min und the onboard LAN works again.
June 4, 2010 5:37:04 PM

I had the same problem after trying to install Kubuntu on my Win7 Dell Inspiron. Apparently, Linux changes BIOS settings. I've set up BIOS to "default" and it solved the problem.
June 10, 2010 5:50:29 AM

The root cause is found to be Ubuntu problem. Ubuntu built-in driver for Realtek has used the incorrect 8169.ko. 8169.ko will cause two registers inside LAN GPHY to have incorrect values, thus, causing the LAN GPHY stops working after system shuts down from Ubuntu. To solve this, you must clean out the built-in 8169.ko from Ubuntu. Install the correct driver from Realtek website 8168.ko.

All the motherboard vendors who ever using the Realtek LAN will have the same problem. Since it is the lousy Ubuntu built-in driver.
July 15, 2010 4:54:14 PM

I signed up to post this because I was having problems with my network adapter. It is a rudimentary fix but it worked for me.

It would appear that when the pc goes into deep sleep sometimes the adapter simply doesnt "wake-up". After fiddling with software and drivers for an hour I just shut it down, unplugged it, pulled out the RAM and MOBO battery, put it back in, reconfirmed the cpu settings in the BIOS and booted......worked great.

Hopefully this will help people skimming through this forum looking to fix their Gigabyte Network Adapter.
July 17, 2010 11:16:29 AM

I just signed up to say:

THANK YOU, SO MUCH!!

My internet was working perfectly yesterday - but overnight suddently stopped working!
I have had my PC for almost 1 year and this has NEVER ever happend before..

But taking out the RAM, MOBO battery, waiting a few mins and putting it all back in worked!

Thanks you!
July 18, 2010 2:08:40 AM

Haha, glad to see that it has already helped someone. :hello: 
Anonymous
a b V Motherboard
August 1, 2010 6:49:31 AM

hey guys i just purchased an msi 870a fuzion mb, and i installed it and hooked everything up, put fresh windows 7 my hdd, pluged in ethernet cable and it worked, i had internet, then all of the sudden bam i dont have internet anymore, tried and tried and tried to get it to work, uninstalled drivers then reinstalled them, tried device manager, tried bios stuff, tried some registry stuff, but still getting that same damn message about being in that stupid sleep mode ect.... i cannot figure it out, wtf, i know you guys are talking about gigabyte mbs but this is the same problem, i need your help please, i also lost my audio stuff to, and in my device manager i got that stupid yellow ! under my pci devices, i tried updating but it then says windows was unable to find driver software for my device, i have the cd that came with my board and i lose option in it, this sucks
a c 177 V Motherboard
August 1, 2010 1:31:28 PM

First place to check is in Device Manager; select your LAN connection, right-click, select Properties; on the Advanced tab, check that 'Green Ethernet' is Disabled; on the Power Management, uncheck "Allow the computer to turn off this device to save power":
a c 715 V Motherboard
August 1, 2010 7:37:46 PM

From above - it was the dancing!
April 14, 2011 7:53:46 AM

I was getting the same error:
"The RealTek Network Adapter/Controller was not found. If Deep Sleep Mode enabled Please Plug the Cable"

Found that Windows 7 had detected the hardware incorrectly (perhaps due to a recent OS update?). Fix is explained here:

http://forums.tweaktown.com/asrock/43109-need-help-p67-...

Hope that helps somebody.
November 2, 2011 2:51:59 PM

willisbmitch said:
I signed up to post this because I was having problems with my network adapter. It is a rudimentary fix but it worked for me.

It would appear that when the pc goes into deep sleep sometimes the adapter simply doesnt "wake-up". After fiddling with software and drivers for an hour I just shut it down, unplugged it, pulled out the RAM and MOBO battery, put it back in, reconfirmed the cpu settings in the BIOS and booted......worked great.

Hopefully this will help people skimming through this forum looking to fix their Gigabyte Network Adapter.



Thanks man, I had the same issue and this totally worked for me. I had recently flashed bios on my gigabyte z68 mobo and I didn't realize my ethernet controller
went out. Not sure if this is common or not.
Appreciate the info, hopes it helps others out too.
Anonymous
a b V Motherboard
May 25, 2012 2:47:31 PM

i had the same problem myself, i thought i'll pull my hair out. the ethernet card stopped working after waking from sleep on my hackintosh. after that i lost network access in ubuntu as well (couldn't boot to windows due a MBR error, but i suppose it wouldn't find the ethernet card as well). i couldn't google anything so i turned off the computer and switched off the power source and went to sleep. in the morning, the ethernet card woke up. hopefully the next time it is gonna happen it will be only a t10 minute dance/sleep :) 

mobo: z68xp-ud4
!