Sign in with
Sign up | Sign in
Your question

Does anyone know how to fix my Maxtor Personal Storage 3200 Portable Hard Drive?

Last response: in Storage
Share
August 19, 2010 8:27:49 PM

I have a Maxtor Personal Storage 3200 Portable Hard Drive and a Dell Inspiron 8200 Laptop with Windows XP Pro on it. Last night I was using a photo editing software that is on my Maxtor Drive and i decided to take a break. I simply logged off of my user account (something i'd actually never done on this computer before) and left the computer for about a half an hour. When i came back, i logged back on but noticed my computer didn't list my Maxtor Drive under "My Computer". So, the first thing i did was restart my computer without the drive plugged into it then tried plugging the drive in after the computer rebooted. Only thing that happened was a bubble popped up saying something like "this device can perform faster with a 2.0 USB cardbus." So then i tried restarting the computer with the drive already plugged in...same thing happened. Then i tried plugging the drive into different power sources (this fixed a problem i had in the past with the drive) but, that didn't fix the problem. Then i uninstalled the driver, unplugged the drive from the computer, and then plugged it back in figuring that since it is a Plug n Play drive, maybe it would automatically pick it up and just reinstall the driver. When i did this, the "new hardware found" bubble popped up as it should but, it was unable to install the driver.

Also, before uninstalling the driver (which incidentally appears simply as "USB Mass Storage Device" in my device manager with a yellow exclamation point next to it) I checked my Disk Management and the drive does not appear there either.

I opened up the case to the drive thinking that maybe, on an off chance, it was a hardware issue i could fix (a loose card/plug or something like that) but nothing seems to be wrong. While it was opened i noticed that the drive itself is a Seagate Barracuda 7200.10 (500GB).

When i open up the USB Mass Storage Device Properties the Device Status box says "This device cannot start (code 10)"

And the "Location" reads as 'Location: Location 0 (Maxtor 3200)'

If anyone can help me fix this problem i would GREATLY appreciate it so, thanks in advance for any advice. :) 
a b G Storage
August 19, 2010 8:37:11 PM

try looking for a driver from maxtor's website
m
0
l
August 20, 2010 12:04:44 AM

tried it but, to no avail. Couldnt get a driver for this particular model.
m
0
l
Related resources
!