Sign in with
Sign up | Sign in
Your question

Rampage ii Gene not recognizing all my RAM

Last response: in Motherboards
Share
July 14, 2009 2:21:35 AM

I just put together a new system with OCZ3RPR1866C9LV3GK memory...3 sticks with 1 gig each.
My rampage ii gene is not recognizing all the memory, only 2 gigs of it. My bios is updated, I have windows vista 64, and my graphics card is only an 8600gt (waiting for the new one). Could my RAM be bad or is one of my DIMMs bad? Is this something that can be fixed in the BIOS? Thanks for reading my post...hope someone can help!

i7 920 chipset btw.
a b } Memory
a b V Motherboard
July 14, 2009 4:07:09 AM

There probably is something wrong with one of your DIMMs. Have you tried using the sticks one-by-one? (i.e., running the system with 1GB RAM) Try each stick on the different slots.
February 6, 2010 7:41:06 PM

I've tried each stick in DIMM two and only two of those sticks worked. Is this bad? I did try one or two in a few different DIMMs and it wouldn't post. Could this be the Mobo or RAM? CPUz is still showing 6GB though.
Related resources
February 8, 2010 9:43:29 AM

1 stick dead sounds like, is the memory on the QVL list
February 8, 2010 12:06:38 PM

It's not on the list because it's new. I'm pretty sure it's compatible though. I've posted this question on the Asus forums and they've never said anything about the ram not being compatible.

I RMA'd the Mobo and may do the same with the RAM. The interesting things was that when I fired up each stick and the one that didn't work, I got a "Locked" display on the Asus digital Tweakit. I looked this up and it didn't mention anything about RAM causing the "lockup" so I'm think the RAM may be ok. Oh and the fact that Buy.com says it could take 3 weeks to process my return, so fingers crossed the RAM is ok LOL!
!