Sign in with
Sign up | Sign in
Your question

Defective hard disk

Last response: in Storage
Share
August 20, 2010 1:13:55 AM

Hello,

About 1 month ago, I bought a new comptuer:

- Case... Corsair Obsidian 800D + Corsair HX 850W
- Motherboard... Asus P6X58D-E Intel X58
- Processor... Intel Core i7 930 2.8GHz
- Memory... Corsair Dominator 6Gb DDR3 1600MHz
- Video card... ATI Sapphire Vapor-X HD5870 1Gb GDDR5
- Hard disks... Intel SSD X25-M 80Gb + 2x Western Digital Caviar Black 1Tb 6Gb/s

I installed Windows 7 Home Premium 64-bit on the SSD and I activated raid0 on the two 1Tb disks for programs and documents.

Everything was fine for 1 month until last Monday.

Day 1 - Monday August 16

I was playing Company of Heroes for those how know it and I decided to pause to go eat. When I get back, the game is now in windowed mode although it was fullscreen before and the colors are all messed up. I quit the game but since my PC is slow, I reboot. While booting, I get this message at the raid0 screen:



The booting continues since Windows is on the SSD and once I get to Windows, I try to go in my raided disks and it works fine. I can read my files, watch my videos and listen to my music. However, when I try to open Steam, which is a program to launch games like Company of Heroes, it doesn't work. Nothing happens and there is no message. I shutdown my PC but it's stuck on Windows's logoff so I hard shutdown. Since my hard disks are in the hot-swap bay, I switch the two 1Tb and I boot. This time the "Error Occurred" is on top so I suppose it means that the problem is really on the hard disk and not in cables or on the port. I shutdown my PC since I have to go to work and I put back my disks in their original spot.

Day 2 - Tuesday August 17

I boot my PC and I install the Western Digital diagnostic software but I can't seem to get infos on my disks and I think it's because of the raid0. I backup all my data on another external disk. I un-raid my disks and I format them. I don't raid them again and I put the programs and my games on the disk I believe to be the functional one (the one on top in my case) and I put my documents on the disk I believe to be the defective one (the one on bottom). Everything works fine during all the morning. I test with the Western Digital diagnostic software and both disks give no errors. I slowly transfer all my documents on the "defective disk but once I try to transfer a big video file, the copy seems to get stuck in the middle. I cancel and I try again many times with that file and other big files with no success. I shutdown my PC and this time Windows shutdowns correctly.

Day 3 - Wednesday August 18

I boot my PC and I try to copy my big problematic files of yesterday and it works. Later, all my files are back on my "defective" disk. After dinner, I start watching a video of about 45 minutes in length and after a while, the video freezes and I can't access to that disk. It starts to work again a couple of minutes later and I can finish the video in multiple segments because the same problem come back and disappear a couple of times. I tried to test with the Western Digital diagnostic software at the exact second the video was freezing and the diagnostic seemed to get stuck at the beginning but after a couple of minutes it was starting and finishing without errors. I shutdown my PC.

Day 4 - Thursday August 19

I boot my PC and I don't really use it. I only check if my disks are all there and if I can access to the files and everything looks fine. I leave my PC for the morning and when I come back after diner, the documents disk is gone. I can't see it in Windows and it seems like it unmounted. I shutdown my PC.

--------------------

So, anyone else had a similar problem? Am I right to believe the problem is on the disk and not a cable or a port? Why is the Western Digital diagnostic software never giving any error? Since it takes a while to start to bug, can it be related to heat? I tried using the Asus Probe software but there is no temperature for disks. Is there something else to do than buy another disk?

Sorry for my English, it's not my first language.

Thanks.

More about : defective hard disk

August 20, 2010 2:12:10 PM

I just want to add that my disk is visible today and I can read the files for the moment.
m
0
l
a b G Storage
August 20, 2010 2:37:28 PM

If the hard disk is under warranty, I'd look at swapping it out. Sounds like you have a good backup of the data.
m
0
l
Related resources
August 20, 2010 8:56:48 PM

I'm having a similar issue with my 2TB WD Caviar Black, I checked the file system for errors and looked for bad sectors (right click the drive, then properties, then tools and error-checking), it didn't fully work for me but it might work for you.

Now, in this thread (http://www.tomshardware.com/forum/261280-32-file-system...) this guy suggested me to run memtest86+, it might work for you as well but I can't even run it in my PC.

Hope this helps.
m
0
l
August 20, 2010 10:02:37 PM

I'll try Window's file system check thanks.

I'm not sure about memtest tho, I don't think it's related to ram like you since I don't have corrupted files.
m
0
l
August 21, 2010 5:59:17 AM

You have checked your cable and power connections to your hdd's,,etc ???,,,. I had a similar problem with "bad blocks" across three relatively new WD hdd's, anyhow turned out it was one of my removable caddies was snafu'ed, replaced same problem gone,so far...
Just a thought , would not your hdd's be somewhat corrupted if your ram were pants, because hdd read/writes are DMA??? :) 
m
0
l
August 21, 2010 3:43:54 PM

Well, as I said I switched drives and the problem is still on the same one so I don't see how it could be the cables. The tests show no bad block or corruption.
m
0
l
!