Sign in with
Sign up | Sign in
Your question

D-Link DIR-615 setup problems

Last response: in Networking
Share
June 25, 2009 2:52:38 PM

I have been trying to help my friend get his cable internet setup. I gave him my old toshiba modem and had him purchase this router because I really like the DIR-655 that I have, it has been very stable and I don't recall having any problems getting it set up. We both have Cox communications in Omaha, NE.

Anyway, we can get an internet connection while connected directly to the modem but not when connected through the router. We have not been able to run the router setup disk because we are waiting on a new DVD drive as his old one bit the dust. I was pretty sure that you really didn't need to use the disk though, I don't recall using it any time I have set up my routers. I went through the setup wizard on the router, cloned the mac address from the PC, DHCP is enabled, NIC is set to obtain IP address automatically, tried different ethernet cable, exchanged the router thinking it was bad. I am at a loss as to what is going bad. I took a look at the status page and the router pulls the information from Cox's servers and then just loses it after a few seconds. It connects for a while, pulls the information and then loses it again.

I went home last night and checked the settings on my router after trying again in vain to get his working. The only thing that I have set up differently than him that I can tell off hand is that I have changed my local IP and range from the d-link default of 192.168.0.1 to 192.168.1.1. I have yet to try switching this out on his but I doubt this is the problem. What am I missing? Oh yeah, I also tried connecting on his router with my laptop to see if his PC is the issue and I had the same problem. Can anyone point me in the right direction?
June 26, 2009 5:03:03 PM

You are unplugging the modem when you add the router correct? If not you need to plug in the modem, wait for it to initialize, then plug in the router, wait for it to initialize then turn on the computer. Most cable companies I have messed with don't require you to clone your mac address so try removing the clone unless you are sure Cox requires that.
April 10, 2012 11:18:18 PM

I had the same problem and here is my fix. When I buy a device, I usually put the instructions in the garbage.
(It's a guy thing) Anyway, after configuring this DIR-615, my devices (2 Ubuntu laptops and one Win7 desktop) could see the router but internet was not available. After 2 hours of swearing, I pulled the instructions out of the garbage can.
One of the first questions on the document was "Is this a new router install or are you replacing a router?"

Well, that turned out to be very important. I do not fully understand why but my devices were very happy with my old router and the IP's it gave out. My fix was to do the following from a Windows machine. Go to a command line and enter the following command "ipconfig /release". Next, shut everything down including your modem and router.
Next, I turned the equipment on in the following order. Computer first, modem second and router third.
Now, if you have DHCP selected on your router, which most of us do, then the router will issue new ip's to any device logging in the correct password.

Once everything is running, I turned a wireless device (Ubuntu laptop) and bingo all is working.

Jacques
!