Sign in with
Sign up | Sign in
Your question

Weird usb issue with usb gamepad on gigabyte "MA790XT-UD4P"

Last response: in Motherboards
Share
July 16, 2009 2:53:23 AM

I just got a new suite of computer components to replace my old core2duo, which include a MA790XT-UD4P mb, 2 kingmax 1333 DDR3 1G ram, and an athlon II 240 CPU.

The new system runs smoothly, except that I find occasionally the gamepad of mine, which is a SEGA saturn USB model, loses after reboot or startup of my computer.

I was running a Windows 7 pre-RTM, the device icon of the gamepad in "devices and printers" has the yellow triangle on it, and stat "this device cannot start". Troubleshooting it and by chance the state can be fixed by "reinstall the device driver".

Then I find by experiments that when you plug the gamepad into another USB port which hasn't been used for the gamepad before while the OS is running, there are chances the system fails to install its driver.

I tried VISTA and different version of Win7, same sydrome exists. While on linux (I used the installation system of ubuntu 9.04) there is no issue recognizing the device and having it work.

BTW, The gamepad worked fine on my previous P35 MB with any windows system. And any other USB devices worked fine with my new MB---Another gamepad of the same model from my friend has the same problem on my MB.

I exchanged the MB with the dealer, replaced my PSU, changed BIOS options that may had anything to do with USB, nothing worked on the gamepad and Windows.

Suggestions will be well appreciated. Thanks.
a c 177 V Motherboard
July 16, 2009 8:23:28 AM

There may be no easy soution, aside, perhaps, from replacing the gamepad with a different model. Gigabyte boards are well known for being 'picky' abour their USB ports - some devices simply will not work; and, the worst part is, that this will often cause the dreaded GB reboot looping. We surmise this by the evidence that, for the largest part, the 'unacceptable' USB devices tend to be older pieces, from back in the days when USB was new, and spec conformance was mediocre at best - you had a two in three chance of it working at all; the 'failing' newer devices tend to come in 'spates' - some months back, several people had trouble with a new external DVD player, always the same make, always the same model - until, eight or ten weeks later, the manufacturer came up with new firmware that made the problem go away...

The only BIOS option likly to affect this is the "Integrated Peripherals" page's "USB Storage Function" (also known as "Legacy USB Support" on older BIOS), which has always been problematic, and in most BIOS, defaults to "Enabled"; this thing causes endless weird problems - the thing is, if you need, on your next boot, to either boot from a USB device (pendrive or external HDD), or access a USB device from the BIOS (say to save CMOS parameters to a pendrive, or access a BIOS file for flashing from it), you need it enabled - it allows the BIOS to 'see' USBs before the OS' USB drivers can be loaded; however, if you leave it enabled - all hell can break loose, and it's different with each possible scenario; the most common one I see is, if it's enabled, and no bootable USB is present, but a USB device is plugged in that's not bootable (even sometimes HID spec devices that are incapable of being bootable), it will either cause a hang before POST completes, or go into the dreaded Gigabyte reboot loops...

Does your gamepad simply plug in and work, or does it require you to load some driver software? If it needs a driver, you might check for a newer (or, in desperation - older) version and give that a try...
July 16, 2009 8:54:55 AM

Thanks for the detailed explanation, bilbat.

My gamepad uses a rather common controller (by Cypress I gather from what Linux device name suggests), and can be drived by the stock USB drivers come with vista or 7. I doubt if there is anything newer for these "standard" gamepads.

And I did turn off and on the "legacy USB storage support" option and several other things alike. They cause neither further problems nor cure of my gamepad.

Speaking of USB storage booting, I wonder why a Win7/Vista installation from usb drive spends so long a time (3-minutes) on "windows is loading files" screen with my MB. The progress takes only about 30 seconds on a much cheaper ASRock 780g (which I built before for a friend). It looks much like that the MB doesn't have its EHCI in effect when booting the installation disk at early stage.

I will try over-voltaging the sourth bridge slightly, and play with the ACC options a little tonight to see if the gamepad problem can be resolved. And if those don't work, I guess I'll just wait for newer bios from gigabyte, or newer SB driver from AMD.
Related resources
a b V Motherboard
July 16, 2009 4:34:44 PM

Probably a problem with the Win 7 driver
July 17, 2009 1:03:22 AM

Thanks Mega. Probably, because the usb controller/hub/HID device drivers are dated sometime 2006 in Win7, and in Vista as well, I think. The thing is that there is no newer driver by MS or 3rd party for those usb devices on Windows. And vista has the same problem.

I raise SB voltage by 0.1v the last night (It's morning now here in china), no luck. And exhausted every means tuning the bios, still no luck.

Maybe I will replace the memery modules for another try. They are a little suspicous anyway: it runs at 1.6v instead of the 1.5v standard, which is marked in SPD---may be another trick of gigabyte to increase performance and stability.
July 19, 2009 2:57:58 PM

Tried the kingstone value ram, which is very similar to the kingmax model at every aspect, nothing changed.

And XP, doesn't help the situation either. It just behaves like vista and 7. I can only say that there may be compatible issues between the gamepad and SB750, while windows usb drivers working on them.

Unfortunately, I can not give up the gamepad right now, it is the best for me to play japnese FTG games, like street fighter IV.
July 22, 2009 2:26:44 PM

Finally I fixed (or rather worked around) the problem. The fix is simple: use an external usb hub---I myself bought a small, passive one---and the issue with the gamepad is gone.

The reason why there is the issue keeps a mystery. It can be the integrated usb hub in SB750, but they works fine with any single piece of my other usb devices. As for the gamepad, it's a genuine SEGA, and works fine too with any other MB I (and a friend of mine) own.
a c 177 V Motherboard
July 22, 2009 10:38:42 PM

A mystery, indeed! You would think, that if there ever was a device that would definitely not have much of a current draw, it'd sure be a gamepad. I've had some comical times here, over that specific issue; went round and round with somebody who insisted that he had to find a way to get more current out of his USB port, by like, a factor of four, than what the USB spec says it will supply... After two days, and five posts, I finally pried out of him that he was trying to run a USB DESKLAMP!! :pt1cable: 
!