Sign in with
Sign up | Sign in
Your question

Safely Remove Internal Hardrive?!

Last response: in Storage
Share
August 23, 2010 6:41:10 PM

I have a newly bought western digital 320gb SATA after 1week the icon appears. How to remove this annoying safely remove icon on my task bar? :( 
a c 372 G Storage
August 23, 2010 7:32:59 PM

As far as i know, you can hide it, but you can't get rid of it. (For XP) Right-click on the task bar, click properties, then click the customize button on the taskbar tab.
m
0
l
August 23, 2010 8:20:41 PM

SATA drives are hot-swap capable, i think that's why that option appears.
m
0
l
Related resources
a c 415 G Storage
August 24, 2010 2:09:09 AM

This Microsoft paper includes information about Registry changes you can set so that the system will treat the drive as not removable.
m
0
l
August 24, 2010 12:23:04 PM

Thanks guys.. hope it works..:) 
m
0
l
August 26, 2010 5:54:02 AM

HELP!!!! nothing happens:(  the safely remove icon is still there:( 
m
0
l
a c 372 G Storage
August 26, 2010 11:33:28 AM

Did you try hiding it? SATA hard drives will show up there if the chipset supports hot swap and you are using AHCI in the BIOS.

I don't see why it matters anyhow. If it's a system drive you can't accidently unmount it anyhow.
m
0
l
a b G Storage
August 26, 2010 11:35:23 AM

As already mentioned by others, AHCI allows you to "hot swap" internal drives. You can't remove the drive containing a running Windows installation though, because it is constantly in use and therefore can't be unmounted.
m
0
l
a c 415 G Storage
August 26, 2010 4:31:15 PM

servico said:
HELP!!!! nothing happens:(  the safely remove icon is still there:( 
What drive number are you trying to set, and exactly which registry key and value did you change?
m
0
l
August 30, 2012 12:24:13 AM

I had the same problem too. My SATA6 "C" drive was being shown as being removable. After doing a lot of Googling I found none of the suggestions worked. My system is a
Z77X-D3H Gigabyte MB with a WDC 1002FAEX as my system drive. What I did to fix the problem was go to "Device Manager-Storage Controllers-Marvell 91xx-Policies" and uncheck the box that says "Enable safely remove disks." Problem solved, for me. :pt1cable: 
m
0
l
!