Sign in with
Sign up | Sign in
Your question

Discs not reading in Windows 7 (they are detected and listed in BIOS)

Last response: in Storage
Share
August 25, 2010 10:14:56 PM

This relates to a new build. I have a Samsung SH-S222L 22x DVD burner (connecting via IDE) which does not work in Windows 7. When I put a CD or DVD into the drive, it spins and Windows is able to see how much space is used on the disc (although it says 0 out of x MB remaining, so it seems as if it looking at a blank/rewritable disc or something). When there is a disc in the drive, anything I do with that drive (view properties, manually explore the disc contents, etc), will freeze up the computer until I eject the disc. Then I'll get a "please insert a disc" error. This is the case for both CDs and DVDs.

The odd thing is that when I first tried to install Windows 7 using the ISO I downloaded from Microsoft, I was able to boot into set up without a problem. I did get an error about DVD drivers which prevented me from installing, but a quick Google search lead me to believe that my disc was just poorly burned, so I ended up installing Windows 7 via USB. Regardless, I was still able to boot into the setup program, so I think that at least means the drive is operational.

I have tried reconnecting the IDE cables, uninstalling/reinstalling the drivers, updating the drivers, and checking the registry for the upper/lower filters (again, google search gave me that as a possible solution). I have also tried using the Microsoft Fix it program, but with the drive empty, the solution it gives is to put a disc in. With a disc, the program just seems to run forever (I left it on for 45 minutes before deciding to manually crash it).

Does anyone else have any ideas on what I should do? Even though I know the drive works, I feel as though I have tried everything, and maybe I should just RMA it, and get a SATA or different brand.

Ideas/suggestions would be much appreciated! Thanks
August 26, 2010 12:38:46 AM

You can try changing the drive letter. Might help, I was having a problem with Win 7 on a friends build, it didn't even assign a letter, even though it had assigned other partitions on the drive a letter.<G> Worth a shot.
m
0
l
!