Sign in with
Sign up | Sign in
Your question
Solved

External Drive recognised in ESATA connection. Using AHCI.

Last response: in Storage
Share
August 28, 2010 11:23:05 AM

Hi,
I have a Western Digital 1TB external hard drive I use for backup. I'd like to use ESATA to connect as in my amateur mind I understand it's the quickest way to transfer data. I'm unable to get the drive to be recognised when I open the Computer Management in Windows 7. The connection/ recognition works fine when I connect via USB.
I'm using an ASUS Crosshair IV motherboard and don't can't see any settings in the BIOS that I would guess need changing. On my internal drives, I have drives 1-4 set as AHCI and 5-6 (DVD drives) set as IDE.
As I'm using AHCI for the boot drives, does the WD eSATA drive need to have AHCI drivers on it? If so, how do I install them? I'd quite like to get it setup in AHCI to make it hot swappable.
Any guidance on how to make it AHCI and any other BIOS/ Windows settings needed to get it recognised would be very welcome.
FYI, when I plug the ESATA lead in the lights come on the front, so it does appear to be making a connection (I read the connection has been an issue with other WD external drives).
Thanks in advance for the advice,
Andy


My setup is:
Windows 7 Professional 64 bit
Asus CROSSHAIR IV FORMULA 890FX Motherboard
AMD Phenom II X6 1055T 2.8GHz
Crucial 4GB (2x2GB) DDR3 1333MHz/PC3-10600
2 x Sapphire HD 5830 1GB GDDR5 in CrossfireX
Corsair 650W TX Series PSU

Internal Drives
Primary Drive OCZ 60GB Vertex 2E SSD 2.5" SATA-II Read 285MB/s Write 275MB/s
Samsung HD103SJ Spinpoint F3 1TB Hard Drive SATAII 7200rpm 32MB Cache
Samsung SH-B083L 8x BD-ROM with DVD±RW DL & RAM SATA Blu-Ray Drive
Samsung SH-D163C 16x DVD-ROM CD-R SATA Optical Drive
August 28, 2010 11:30:57 AM

Sorry, title should have read: 'not recognised'!
m
0
l

Best solution

a c 357 G Storage
August 28, 2010 3:20:27 PM

Commonly an eSATA port that is part of your mobo is provided by a dedicated chip. To get it to work you need two things done. One is to ensure in BIOS Setup that the port is Enabled. The other it to be sure that the driver for it is installed in Windows. Many times when you first set up your system that driver will be loaded along with lots of others from a CD that came with your mobo. But just to be sure, use Device Manager to find that device (check your manual for chip identification - it may be under SCSI / RAID controllers in Device Manager, rather than eSATA), right-click and ask for Properties, click on the driver tab and Update it. The driver to use may be already on your main HDD, on the CD that came with your mobo, or the latest driver you download from the ASUS website.

You do NOT need to place any driver on the external HDD. But Windows does need the driver for the mobo chip that provides the eSATA port. I fully expect that the eSATA driver will actually include AHCI operation of the SATA HDD in the enclosure. Unlike the SATA Port Mode specification you must make for internal SATA drives, I doubt there is any such Mode setting in BIOS for the eSATA port.
Share
Related resources
August 29, 2010 4:47:25 PM

Thanks Paperdoc. I've read around a bit and the more I read, the more I'm convinced the WD My Book is the problem. They seem to have a common problem with the eSATA socket. I've followed your instructions plus many other hints from other forums on this my PC. The connection I thought was working doesn't appear to be ideal, and I was unable to get the eSATA connection working on my old PC too. I've ordered a new drive enclosure and drive I'll see if I can have more luck with that.
Appreciate your advice.
Cheers,
Andy
m
0
l
September 9, 2010 7:42:08 AM

Best answer selected by andy_s.
m
0
l
!