Sign in with
Sign up | Sign in
Your question

My AMD Phenom 2 X4 940 BE does not recognize my dual channel

Last response: in CPUs
Share
May 18, 2009 6:09:00 PM

My current build is this:

Gigabyte Motherboard MA790GP-UD4H
AMD Phenom II X4 940 BE 3.0 Ghz
2x2gbs OCZ platinum 1066 mhz ram dual channel kit
ATI 4850 512mb gddr3
1 tb western digital
(that is all that sorta matters...)

So when i boot up it says that firstly my ram is detected at 800 mhz ungaged 64 bit mode.
Gaged is single dual-channel where as ungaged is two single channel.
So when i went the the bios config, i went to the MB Intelligent Tweeker to change the DCTs Mode to gaged.
Only problem was that it was not there.

Can I get some help configuring my ram to be used in gaged mode?
May 18, 2009 6:39:39 PM

Super Peen said:
My current build is this:

Gigabyte Motherboard MA790GP-UD4H
AMD Phenom II X4 940 BE 3.0 Ghz
2x2gbs OCZ platinum 1066 mhz ram dual channel kit
ATI 4850 512mb gddr3
1 tb western digital
(that is all that sorta matters...)

So when i boot up it says that firstly my ram is detected at 800 mhz ungaged 64 bit mode.
Gaged is single dual-channel where as ungaged is two single channel.
So when i went the the bios config, i went to the MB Intelligent Tweeker to change the DCTs Mode to gaged.
Only problem was that it was not there.

Can I get some help configuring my ram to be used in gaged mode?


What bios are you using? The option for ganged exists inside the first selection. (M.I.T.) The setting is called "DCT's Mode" and can be set to ganged or unganged.

BTW: Other than for benchmarking there is no reason to set it to ganged mode. Ganged will give you less than a percent of performance increase on single threaded applications; multi-threaded applications or normal system use will be slightly slower with ganged mode. Unganged would be where most people set it for all normal use. (Which is also why it defaults to unganged.)

(ALSO: Most ram will always be detected at 800mhz. Always. You must specifically either set the ram to 1066 OR turn on the EPP Mode to "AUTO" which will allow the BIOS to read the ram's EPP profile. That setting defaults do disabled. Either way you then either need to manually set the VDIMM or turn the EPP VOLTAGE setting to ENABLED.)
May 18, 2009 8:16:12 PM

No it's just that phenom's can't run ddr2 ram running at a certain speed or above in dual channel.
Related resources
May 18, 2009 8:26:24 PM

Update the bios. I have a Gigabyte Mobo that came with Bios that wouldn't activate Dual Channel and I am running Corsair Dominator DDR2 1066. Update the bios the go into the memory setup and enable ganged mode (dual channel). It works fine and yes the CPU does support it.
May 18, 2009 8:30:12 PM

I should mention I am also running the Phenom II x4 940 as well...
May 18, 2009 11:01:07 PM

Helloworld_98 said:
No it's just that phenom's can't run ddr2 ram running at a certain speed or above in dual channel.


The Phenom can easily run DDR2 at 1066 in dual channel.

Some people do have problems if they fill all 4 of their memory slots. Although some people have no problem running at 1066 with all four slots filled.

But generally with only two memory slots DDR2-1066 will run at 1066 without any problems. Especially with the second generation of the 790 chipset motherboards. (Like the UD4H.)

Although I would recommend setting the timings by hand so that you set the tRFC to 195ns. (Often the default of 127.5ns works okay, but 195ns is generally more stable. Especially if you are going to overclock.)
a b à CPUs
May 18, 2009 11:53:34 PM

First off, I'd recommend leaving it in unganged mode, though I have not seen much of a difference between the two settings. Second, get the newest BIOS. I know F4 has the setting, while some of the older ones do not. And finally, just setting it to use the EPP timings for the ram works for me.
May 19, 2009 5:53:10 AM

EXT64 said:
First off, I'd recommend leaving it in unganged mode, though I have not seen much of a difference between the two settings. Second, get the newest BIOS. I know F4 has the setting, while some of the older ones do not. And finally, just setting it to use the EPP timings for the ram works for me.


The F2 bios is the newest one available on the UD4H. (It was released 2 weeks ago.)
May 19, 2009 6:29:40 AM

i had same problem all i did is look on the side of 1 of my ram stick it said 2.1v means it capable of handling that voltage
then i went into bios and changed the ram multilayer from 4 -5 or to the max it could go then i bumped up the voltage to the ram to 2.050v and it wok's fine just have a look in bios and bump it up to 1066 then give it some more juice if its not stable
a b à CPUs
May 19, 2009 1:13:26 PM

The Phenom should be left in unganged mode if you are only running 2 sticks of memory. This allows the dual memory controllers on the Phenom to work independantly of each other, supposed to be faster. It you have 4 sticks, so you are running 2 banks in dual channel, then each memory controller will run a bank, and then dual channel mode should be enabled.
BTW, my 920 on my Gigabyte board runs at 1066 without doing anything, detects it automatically, and sets my 2 sticks to unganged, as it should be.
could it be possible your BOIS needs updating? If the voltage requirement is like 2.1 volts, I would opt for some better memory. (not saying OCZ is bad memory, but if you have turn the voltage up to get it to run at 1066, meh....there is better memory out there) My Crucial runs at 1066 at stock voltage, 1.8.
June 7, 2009 4:32:24 AM

I had the same problem with a Gigabyte GA-MA78GM-US2H board with 7750 BE processor and a dual channel Patriot 4 gig 1066 kit. That option wasn't there in the Tweaker. I upgraded the BIOS to F4 which enabled that option. Now I have the RAM at dual channel at 1066.

Maybe your BIOS needs to be updated.
September 4, 2009 8:01:16 PM

__AMD__,

I have the same board and processor, paired with two 1GB sticks of Kingston HyperX DDR2 1066 (KHX8500D2K2/2GN). I would really appreciate it if you could let me know exactly what settings you had to change to get your BIOS to post at 1066. Cheers!

Here's what I've got:





I should note that above 'DDRII Timing Items', the setting 'DCTs Mode [Unganged]' is cut off.

Thanks!
-Kp
March 2, 2010 5:36:45 PM

Hi, :cry: 

I've similar problem about my Gigabyte GA-MA770-DS3 v.2.0 mobo. I've 4 identical stick of Kingston DDR2 KVR800D2N5/1G RAMs (800Mhz). All works without problem with my Athlon X2 6000+ 3.1Ghz (Dual Channel). Last week I upgraded my CPU to Phenom II 955 BE (Stepping C3). I've already upgraded my BIOS to FDc to support this CPU. With 4 slot RAM board makes long beeps and no boot. 2 sticks with seperated channels boots normally. I cannot change DCT to Unganged to Ganged. It changes but when boot screen says still 800MHz unganged. Gigabyte PDF file support that model of RAM. And only 1066 Mhz ram needs 1 stick per channel. I also sent a service request mail to Gigabyte about the issue but no reply so far.

Is there any advice..? Thanks.

Ps.

+ Cleared CMOS, Hard set RAM Timings, lowering mhz to 667, even increase Voltage +0.1, tried different RAM's KVR800D2N6/1G.

Now I'm not even sure if i get 2x2GB 1066Mhz RAM works.. :pfff: 
!