Sign in with
Sign up | Sign in
Your question
Closed

Black screen after WinXP Loading screen Radeon HD 3850 AGP

Last response: in Graphics & Displays
Share
March 15, 2009 12:28:38 AM

I had a Sapphire Radeon X800GTO working fine before and I bought a Powercolor Radeon HD 3850 AGP card. I uninstalled the old drivers and shut down. After I put in the new card, I booted into windows and tried installing the latest 9.2 Catalyst drivers but it would not install, telling me it could not find the hardware. Then I tried the driver the card came with and it installed correctly.

The problem happens when booting. After the Windows loading screen, the display just turns black but the monitor is still receiving a signal (does not go into standby). Ive waited almost 5 minutes and the Windows Welcome screen never shows up.

I have the same problem with any driver version that I install.

I also backed up my drive and formatted and did a clean install of windows and the drivers installed properly and the card worked correctly so I dont think its a hardware problem. Since I dont have time to do a clean install right now and start from scratch (have an important project Im working on), I had to restore my backup, but I have spent the last 24 hours trying to figure this out.

I tried reinstalling .Net 2.0 with no results.

How can I fix this without reformatting?
March 15, 2009 1:15:14 AM

try pressing F8 before windows loads and change the res or refresh in safe mode
Score
0
March 15, 2009 1:36:20 AM

rangers said:
try pressing F8 before windows loads and change the res or refresh in safe mode


If I select "Boot in VGA Mode" or Boot normally, the problem occurs. I can only get into windows in Safe mode, but I have already tried at 1024x768 and 800x600 and the problem still occurs.
Score
0
Related resources
March 22, 2009 1:17:03 AM

I returned the card and bought a new computer, so this problem can be considered FIXED!

Old System:
Athlon XP 2500+ @ 2GHz
Asus A7V8X VIA KT400A mobo FSB: 333MHz
2GB PC2700 DDR
Sapphire Radeon X800 GTO 256MB (unlocked all 16 pipes)
Windows XP SP3

New System:
Phenom II X3 720 @ 3.2GHz
Asus M4A79 Deluxe
8GB PC2-8500 DDR2
Asus Radeon HD 4850 TOP 512MB (O/C to 680/1050)
Windows Vista Enterprise x64
Score
0
October 18, 2009 9:27:30 PM

I am currently having this same problem, so if anyone has any input on how to fix the problem, I would appreciate it.
Score
0
October 20, 2009 2:32:11 PM

I encountered this same problem when upgrading my Dell XPS Gen 1 AGP video card, replacing my existing card with a Sapphire HD 3850 AGP 512 Mb DDR3 card. Operating system Windows XP SP3. My original card was an ATI X700 Pro, which had failed (so I had a reasonably current version of the ATI drivers installed, but no video without a new card).

I physically installed the 3850 with only minor problems trying to run two power connections to the included adapter. I closed everything up and booted the system. I was very happy to see the Bios display and post process again, however just after the Windows Splash screen (where the card switches from standard VGA mode to whatever it is set for) the screen went black and remained so as the system completed its startup. As mentioned, the monitor continues to receive a signal, it is not sleeping or hibernating, however the screen is black/blank. I assumed the issue must be the installed ATI drivers, so I booted in Safe Mode and uninstalled all ATI software.

I booted the system (Which now did not recognize the card) then installed the Sapphire software that came with the card. Same result - boot, post, Windows Splash, black. I now assumed that perhaps the drivers that came with the card were too old: they were Catalyst 8.1 and the latest version on the Sapphire site was 9.9. Being cautious, I stayed off the cutting edge and downloaded Catalyst 9.8 and installed them. Same process, same result.

I repeated this uninstall, download, and install process 4 times using randomly chosen version of Catalyst between 8.1 and 9.8 and achieved the same result in all cases. I gave up for the day, slept on the problem and was visited by the CompuNerd fairy as I slept because I awoke with a plan.

In my sleep I somehow realized that issue was not that the card wasn't working, it was that the card was working in a manner that the monitor (a Dell Flat screen) could not process (Maybe some super high resolution... I don't know cause I could not see a screen to ask). Anyway, here is how I fixed the problem:

1. I reinstalled the drivers for Catalyst 9.8 from the Sapphire support site.
2. Restart the system.
3. Hit F8 immediately after the POST to enter the Windows startup menu.
4. Select Enable VGA mode (System boots in 640x480 VGA)
5. Do not allow Windows to Select the VGA mode stay in 640x480 until startup is complete
6. Go into display properties and manually set the resolution and rate to one you know your monitor can handle (1280x1024 and 60 hertz in my case)
7. Restart and, in my case, the "Black Screen" was gone.

Hope this helps!
Score
0
October 20, 2009 6:24:42 PM

I tried it, and was able to get it to start in 640x480 VGA mode, but when I tried to change the resolution in the display properties, the screen went black and never came back. I tried this several times with the same results.
Score
0
August 29, 2011 5:10:27 PM

This topic has been closed by Mousemonkey
Score
0
!