Sign in with
Sign up | Sign in
Your question
Closed

HDMI not good enough for PC applications

Tags:
  • Radeon
  • DVI
  • Monitors
  • HDMI
  • Graphics
Last response: in Graphics & Displays
Share
March 17, 2009 10:51:10 PM

Damn...I just wrote war and peace about this and it seem that my post was lost during the "signon again process" !!!!

Bottom line is I can't get a good picture from HDMI at 1920x1080 on samsung panasonic or LG displays witha native res of 1920x1080.

It seems to be something to do with the extra processing that goes on when it's connected via HDMI such as pixel mapping (CYbCr 4:4:4 etc). If i take a monitor, an HDMI cable and a PC and connect via HDMI I get a soft image. If I disconnect the hdmi cable from the monitor, add a dvi converter and plug it into the dvi port on the same monitor I get a crystal clear picture. It's like writing with a 2H pencil on DVI and with a 2B pencil on HDMI.

On ATI command center there is a difference between the two conections. DVI comes up as Digital Monitor and HDMI comes up as DTV with an increased set of parameters. Also with DVI/VGA the display info shows 1920x1080 but with the HDMI it shows 1080p. I believe that the HDMI 1080p implementation is introducing so much processing that the image is not pixel-mapped 1:1 as it is with DVI.

Anyone got any ideas as to how I get a good picture trough HDMI?
Cheers

More about : hdmi good applications

a b C Monitor
March 17, 2009 11:33:46 PM

No idea. I don't have that problem when I hook up my PC to my Plasma with HDMI on my 3850, but then my Plasma is 720p not 1080p. Some of the bandwidth on the HDMI is reserved for audio so that may have something to do with it, but I doubt it. I do know that if you have a low quality HDMI cable the signal can degrade and lead to a softening of the picture. That has to do with the fact that the HDMI standard was relaxed at the last minute thus allowing sub par cables to be made that seem to degrade over time.

What Video Card do you have and what driver version are you using? It could just be a driver issue so perhaps updating your video driver may help.
March 20, 2009 12:14:44 AM

Don't think it's a bandwidth issue (isn't audio delivered on a different wire?). Cables are good quality ver 1.3 so no probs there (and DVI works fine through the same cable).

In UK 1920x1080 monitor hybrids have only just started to come out. There have been 1920x1200 out for a while and the problem doesn't exist on those because the PC runs at that native res rather than 1080p. This seems to be raising it's ugly head just because the displays are capable of 1080p native (16:9). I reckon it's something they (manufacturers) just didn't consider. What's really bugging me is that they haven't accepted there is an issue yet. Untill they do that they obviously won't look to resolve it. I'm waiting on LG to come back to me but not holding my breath! Just wondered if anyone else had experienced this elswhere.

PS apologies to all for my multiple posts - it seems my ISP was doing maintenance at the time - Again!!!!! absolutley NO votes for orange home broadband!!!!!!
Related resources
March 20, 2009 1:48:42 AM

Hmm interesting... I dont know what to say. I have it connected here through HDMI on Samsung LN32A550 at 1920x1080 and it's Cristal clear and sharp.
For Pixel Format I have RGB 4:4:4 (Full RGB)

BTW, I am getting Sound and Video through same cable.
March 20, 2009 3:21:51 AM

Thanks Euphoria_MK,

I'll see if I can find an LN32A550 in one of the stores to try. I Tried Samsung T series but they have the same issue.

Sound and video is through the same cable but I thought on different wire pairs (pins). However I just looked on wiki and I think i'm wrong. If I read it right something called TMDS is used which transmits video data periods and data island periods and it says the sound may be transmitted during a data island period. So I guess they can coexist on the same wire pair. I assume therefore that DVI just ignores the audio in the data island periods. It all looks very complex to me.

Have you ever connected your pc via VGA? If so did you see a difference? When I tested in a shop the manager didn't see a problem with the image until I showed him the VGA connected picture. He then saw the difference and aggreed that there was something "not right" as the VGA picture was clearer.

I found when two monitors displaying the same image were side by side it was very apparent. For instance on a Works spreadsheet the little icons for centred/justified text showed black lines with distinct white spaces between when connected via VGA but when connected via HDMI the lines appeared closer together and some of them appeared to touch. Also it was quite easy to mistake normal for bold text especially on adjacent lines Via HDMI. I saw this yesterday in PCworld with a couple of 32inch LG TVs and one of their laptops. This why I'm assuming that it's not my kit or configuration which is at fault.

I'm so glad the guy in PCworld saw it as I was beginning to think I was complaining about something that was only in my imagination. Halucinations in my younger days I would accept but 20yrs on and much less adventurous..... now that would really scare me! lol
March 20, 2009 6:05:30 AM

Yeah give the LN32A550 a try. I love it. Excellent picture quality at 1080p.

Well the TV has only one VGA port and I have my Xbox 360 connected to is, so I haven't tried the VGA port on the PC. I just did not see a reason for switching to VGA since HDMI works great.

I think I know what are you referring to. I use to have a Sharp Aquos 28 Inch 720P HDTV and I had the same issue, but in that time I had a Nvidia 9600GT.
The card wasn't the issue, because once I sold my old TV and got the Samsung LN32A550 the difference in picture quality was Day and Night comparing to the Aquos at 720p.

Also if you get the same TV, make sure you download the latest Firmware from the Samsung website and put it into a USB stick and update you TV Firmware.
The TV has a USB port on the left side.

BTW this are my PC specs:

Phenom II 940 BE @ 3.515GHz
4GB 2x2 G.Skill 1066
Vista 64 Bit
HIS Radeon HD4870 1GB @ 790/1050


Cheers
Anonymous
a b C Monitor
March 11, 2010 9:40:11 AM

Hi all. I just have the same proble. I put HDMI cabel into the laptop, that into a 27" LG monitor (2753V) and the picture is very very little blurred. especially looking into text file. Are lost half a day to solv the problem.

So into the menu of the monitor (no matter samsung or LG...) go to Setup and that to OVERSCAN than make this OFF. The overscan MUST be off.
Than because you will eventually have black lines all around the picture you go to the program of the video card.
For me it is Ati Radeon and I have CCC program. There go to DTV (HDMI) 2 menu. There is Scaling Option. There you must put it at 0%.

And the picture is now crystal and is in all the visible part of the tv or monitor!

Hope this help.
topsi
Anonymous
a b C Monitor
August 16, 2010 8:16:06 PM

Hi Guys,

I had the same issues, solved by the steps outlined in the previous post, although I hadn't read it. I spent a little time in the Catalyst Control Center and figured it out. You must know how to get to the correct place though. I'm running version 10.7 of the mentioned drivers. On the CCC "Graphics" Dropdown menu in the top left corner I chose "Desktops & Displays". On the screen the display is shown in the bottom left as an icon with a small black arrow pointing down. After pressing it a menu opens.... Choose "Configure" and another screen appears. Somewhere in the top-half off the screen press the button with the text "Scaling Options". On the next page drag the slider to the right until it is at 0%.

This should fix the problem, wonder why this is set to 7.5% at default though....

I hope it helps...

F.A. Boumeester
October 20, 2010 8:59:53 PM

I had the exact same problem, and i couldn't fix it just by setting the scaling to 0%, beacause the desktop "overflowed" the monitor (the edges of the desktop were outside of the edges of the screen) so what you need to do, besides the 0% scaling, is go to menu/video/advanced video/ and set the hdmi mode to "graphic". that solved it for me. the only problem is that now the display kind of flickers some times, displaying a distorted desktop for a brief instant (1/50th of a second or something like that) but i attribute that to my hdmi port being a little dirty or a bad cable, when i find a fix for that i will post it in case anybody else has the same problem.

if anybody has an explanation/fix for my problem, please post it!
a b C Monitor
October 20, 2010 10:00:01 PM

This topic has been closed by Mousemonkey
!