Sign in with
Sign up | Sign in
Your question

Display driver stopped responding (ATIKMDAG)

Last response: in Graphics & Displays
Share
March 18, 2009 2:54:11 PM

Hi all, i have recently bought a new Dell laptop but have been having a problem normally during gameplay, it can go for hours, sometimes seconds before the game backs out and crashes displaying the error 'Display driver has stopped responding and has recovered', it tells me this is relating to the driver ATIMDAG, i had the problem on the old and the newer drivers, i found this on here but im wanting some advice on if its safe or carry any risks:

********************************************************
Hi Everybody,

I have had a running ticket with ATi for 2 weeks now and found the solution myself as they are useless. This is what I sent to them today from within my ticket! This works for me! (Also make sure you have enabled ACPI 2.0 support in BIOS not sure if it helps but best to be safe)

**************************************************

"I have the solution for my problem. I strongly suggest you post this to anyone else having this problem! (PS I am using 7.5 catalyst)

I found that if you go into the system configuration utility (Start menu then type "system configuration" in the search bar) and the choose the boot tab and then to advanced options. There you will see at the top two boxes that you can check one is processor and the other is memory. If you check both of these and choose one processor and then the max amount of memory that is on your system. Hit apply and ok. Restart your system and it should run quickly in 2d and 3d works! Yay!"
********************************************************

Thanks in advance!
Stew
March 20, 2009 12:29:49 PM

Welcome to the forums!

I guess you have Vista. Do you have the instructions for XP also?
I can't get the "system configuration" in XP.

March 20, 2009 12:52:35 PM

This error is more or less a driver + vista hate fest. (See my sticky in the amd.game forumes) Your solution, while working for many people is not a solution as you are effectively turning off every processor core you have but one, quartering your performance if you have a quad (roughly).

As for the memory, msconfig is still bugged in vista 64. If you select the checkbox for memory and enter a value it will default your system to the old 32bit max if the value ismore than that. The only way to use all of your ram is to have that box unchecked (if you have more than 3.something Gb).

As for XP, this issue is by definition vista only. If yuo get a bsod pointing to atikmdag you have other problems. The issue in question is actually, in part (and assumign no other faults in your system), a bug with TDR and how ati drivers interact with it. If however you do want to get into teh system configuration he mentions in xp simply type "msconfig" in run.

-Cheers
Related resources
March 21, 2009 6:43:17 PM

Ok,

If i were to leave it as is and take it as a vista issue, is there any risk of damage to the PC by it backing out of programs like that, will it shorten the life of the system or is it just a software problem thats simply more annoying that dangerous?
March 22, 2009 9:25:46 PM

stew890 said:
Ok,

If i were to leave it as is and take it as a vista issue, is there any risk of damage to the PC by it backing out of programs like that, will it shorten the life of the system or is it just a software problem thats simply more annoying that dangerous?


It isn't dangerous generally. It borders on unbearably annoying though. The thing with this error is that it can be caused by anything. TDR is in principal there to protect your system if the hardware actually is at fault.. The only thing is that it is often bugged, especially with ati drivers. The onyl way to be sure it isnt a hardware issue d to try it in another computer or another OS. If it is the software bug you dont have anything physically to worry about.. its just REALLY annoying at times.
March 23, 2009 9:35:11 PM

ok cool :)  thanks alot everyone great help!
!