Asus 4870 Low Performance?

Hello Everyone, I have been trying to solve this problem for about a week, but with no luck!

I recently put together my first computer and bought an ASUS 4870 DK TOP Graphics Card, but I do not feel I am getting very good performance out of it.

I initially could not get Direct X 10.1 to work in Stalker Clear Sky, nor could I get “Very High” detail for shadows in Age of Empires 3 without the two games crashing, or textures being removed.

I solved those problems by formatting the computer, and reinstalling everything (I had originally installed the ASUS drivers, and then updated to the ATI 9.2 Catalyst drivers – so I think a conflict was causing the problem.)
My 3DMark Vantage Score before I formatted was a little over 8,000 and a little over 9,000 after the format.
Here is what is in my system:

CPU: Intel Q9400 2.66
Motherboard: Gigabyte EP45-UD3P
Memory: Mushkin 800hrz 6400, 4gigs (2 x 4)
Graphics Card: ASUS EAH4870 DK TOP
Hard Drive: Western Digital Caviar Black 640gigs
DVD: LG DVD Burner
Operating System: Vista OEM 64bit
Max Screen Resolution: 1680 x 1050

Playing Stalker Clear Sky with everything maxed gives me FPS around 25 or lower.. sometimes higher, but generally not.
I am not sure which monitoring programs I should run in order to see what part of my system may be constricting the graphics card, or to see if it is the graphics card itself.

If anyone has any opinions or suggestions that would be great!

Thanks,
30 answers Last reply
More about asus 4870 performance
  1. your score is LOW, thats for sure.

    you have 4 or 8 gigs of memory ? (+ timing plz )

    What about your PSU ? power and brand plz ?
  2. Make sure your graphics card has both power connectors connected.
  3. I have both of connectors connected.
  4. Power Supply, I knew I was forgetting something.

    Corsair TX Series CMPSU-650TX 650W ATX 12V 52A 24PIN ATX Power Supply Active PFC 120MM Fan

    I'm at work so I do not know the timing of the RAM, but this is what it is listed as:
    Mushkin HP2 6400 4GB (2x2GB) DDR2 800 5-4-4-12 (1.8V) 240pins (996587)

    What would be the most accurate way to find the actual timing for my installed ram?

    Thanks,
  5. take a look at BIOS. if its AUTO. boot into windows and use CPU-z. CPU-z can tell you everything you want to know about mobo-ram-cpu.
  6. I have attached the results. Could this low performance really just be my Ram?

    DRAM Frequency: 399 - 400 MHZ

    FSB:DRAM - 5:6
    CAS# Latench (CL) - 5.0 Clocks
    RAS to CAS # Delay (tRCD) - 4 clocks
    RAS# Precharge (tRP) - 4 Clocks
    Cycle Time (tRAS) - 12 clocks
    Bank Cycle Time - Blank
    Command Rate (CR) - 2T
    DRAM Idek Timer - Blank
    Total CAS# (tRDRAM - Blank
    Row to Column (tRCD) - Blank
  7. Thank You.

    What about the low score with 3DMark Vantage? I also noticed that Age of Empires 3 was "skipping" slightly when I scrolled quickly over the map. However, it was only useing 40 - 50% of my GPU Load.
  8. I tried the Crysis Demo. I had to but all the detail on High and the screen rate at 1680 x 1050. At first it seemed fine, 25-35 fps. But as soon as I get this dock scene, with water and mountains in the back, the fps dropped to 9 or lower.
  9. Crysis is an HARD game ;) but yes 9 fps is low. Remove AA if you were using.

    Watch for Running application behind the scene, CTRL-ALT-DELETE and see if you have any non wanted application running. It can be PSU related. Youv plugged the 2 6pin from the SAME PSu rail ? and you used 2 différent Rail. You can try switching PCI6 for testing, it can be a lack of power.
  10. How would I tell if it is a lack of power?

    There was only one cord that had the 2 6 pin connectors for the graphics card, so I used it. Is there a specific order they need to be plugged in?
  11. I dont think its a lack of power.... since you have a 650TX and the 12v is a single rail.... +this PSU is a good one.
  12. Thats what I though. Could the cord be defective, and it is not getting enough power? Or is it one of those, if its broken it would not work at all??

    I will try and switch the card to a different slot when I have a moment. I will also try booting the computer with nothing running. But I just set this thing up, I feel the performance is too low to just be some background programs!
  13. i would say you nead to overclock ur CPU
  14. I wondered if it was the CPU, but I ran Crysis and I maxed out the GPU, but I was only useing half the CPU if that!
  15. I just tried a clean book of Windows. On "High Detail" and 1680 x 1050 I was able to now get 25FPS up from 9, during the outdoor/dock/mountain scene in the demo. However, in Stalker Clear Sky, I got maybe 2 or 4 FPS hight (Same Resolution, and MAX settings) - I was getting around 12 FPS for both Clean/Programs running.

    I really think the card should be performing better under both circumstances.

    How much can the +12V fluctuate before it would cause problems?
  16. A clean book ?

    FRESH windows install ?
  17. Sorry, Boot! I had already re-installed Vista. This stopped some crashes I was having, but did not fix the low FPS. I re-started windows with almost all programs and drivers disabled to see if they were causing the problem, but I do not think they were.. I did get better performance out of Crysis, but not great! From what people have been telling me, which my setup I should get much better performance with my resolution on High Detail
  18. Your ram is running DUAL channel ?
  19. I believe so... all I have to do is put it in the correct slot right? Is there anyway to confirm this?

    Thanks,
  20. You can Use CPU-z . youll see if its running DUAL chanel.
  21. Thanks!

    # of channels: Dual

    Hmmm.. I am really confused. Some people say its Fine, but some say I should get much better performance at my resolution. Is it possible that my card could actually be broken so that it works... just not great (The problem is the GPU load maxes on lower settings/resolutions then I think it should).

    I do think their is no problem with the CPU,since when I maxed out Crysis I did not use all of my CPU. Unless I am wrong in thinking this?
  22. try other games. 3dmark06, COD4 and COD waw ..
  23. I tried the Demo for COD4. I only played the first part, everything Maxed I believe.

    Resolution: 1680 x 1050
    FPS: 60, dropped to 42 for a split second every once in awhile.

    I noticed, that if I looked at a spot (Team Mates standing) while I moved around them (with my curser/field of vision locked on them) they were "jittery" is the best I could describe them. It looked like they were shakeing. Same thing if I was moving around a corner (The corner of the stairwell would look shakey). Is that normal? - or at least normal for that game?

    Thanks,
  24. Immm ill have to reinstall the game for testing. Maybe someone that already have it installed can reply ;)
  25. Nope nothing shakes, i have 4670 and i play cod4 in 50-60 fps 1680x1050 everything maxed out, AA=2
  26. i do use xp maybe its os
  27. im XP too. With my SLI Vsync on. i get 60fps no drop @ 1650x1080 MAXED. full AA.
  28. I tried GRID Demo.. Everything seemed to go alright. I maxed out the Graphics at 1680 x 1050, and had my GPU load hit 80%. WIth a GPU Temp Memio of a Hight of 80C.

    Anyone tried this demo and could let me know your performance at these settings with a 4870? My card is supposed to me 9% faster then average 4870... so it says..
  29. I only got about a 9000 score on vantage and low fps on crysis and i have the 4870. What is causing this?
  30. try starting a new thread .. this one is VERY old.

    Have fun !
Ask a new question

Read More

Radeon Asus Graphics