Sign in with
Sign up | Sign in
Your question

PE45 UD3L doesn't see hard drive

Last response: in Motherboards
Share
July 31, 2009 3:14:30 AM

I've spent about half the day building my new PC - a Windows XP Pro 64-bit box. I've installed the hardware and it is recognized by the BIOS on my Gigabyte PE45 UD3L motherboard.

The next step was to install the OS, a 64-bit version of Windows XP Pro. All went well until the installation program prompted me to remove the disk and reboot. I received the message: "A disk read error occurred. Press Ctrl+Alt+Del to restart." I've ruled out any physical defects with the XP disk, the LG optical drive or the hard drives, because the installation files were successfully copied to the hard drives during each attempt.

There is a section in the BIOS called "Integrated Peripherals", which includes these three settings:

SATA AHCI Mode [Disabled]
SAT Port0-3 Mode [Disabled]
Onboard IDE controller [Disabled]

The "Standard CMOS Featues" section is a little odd. The HD settings are the same for IDE and SATA:

IDE Channel 0 Master [Auto]
IDE Channel 0 Slave [Auto]
Etc, Etc,

According to the manual, these settings "autodetect the parameters of the IDE/SATA devices on these channels." But no matter what settings I used I get the message, "A disk read error occurred. Press Ctrl+Alt+Del to restart." :( 

Any ideas?

Much thanks in advance,

Roy

More about : pe45 ud3l hard drive

July 31, 2009 4:04:47 AM

maybe you just had a bad install. start over and re-install windows. if that isn't working, reformat the hdd
a c 177 V Motherboard
July 31, 2009 2:01:23 PM

Would help to know what you have plugged in (IDE or SATA, drive make, model) and where... Assuming you just have one SATA HDD, and one SATA ODD, the hard drive wants to be plugged in to the connector labeled 'SATA2_0'; doesnt matter where the ODD is.

Start out by doing the "Load Optimized Defaults" function from the main BIOS page.

Then, reboot, and in the BIOS:

On the "Advanced BIOS Features" page,

"First Boot Device" to "CD-ROM"
"Second Boot Device" to "Hard Disk"
"Hard Disk Boot Priority" should only show your drive...
"HDD S.M.A.R.T. Capability" to "Disabled" (for now)

On the "Integrated Peripherals" page,

"SATA AHCI Mode" to "Disabled"
"SATA Port0-3 Native Mode" to "Enabled"

The stuff on the "Standard CMOS Features" should take care of itself...

and that should do it!

BTW: if your boot drive is a Seagate, please post back - there are a large number of them wandering around that have a known firmware problem...
Related resources
July 31, 2009 6:20:32 PM

Many thanks, bilbat!

Your instructions got me a little further.

The HD is on SATA2_0, by the way. The only other drive present is an LG GH22 optical drive on SATA2_1.

I loaded the XP installation disk again, let the program reformat the HD (a WD 320GB Caviar Blue), and begin to install XP. The files were all copied over to the HD, and then I was prompted to reboot and remove any disks.

When I rebooted, I received this message:

Invalid Boot.INI file
Booting from C:\windows\
NTDETECT failed
August 1, 2009 4:07:10 AM

Bilbat:

After I read your post, I called Gigabyte. I was on the phone with their tech support for about ten minutes, and we got the XP installed! As a matter of fact, I'm posting this from my new 64-bit box.

The problem was with the BIOS. We went into the BIOS and set the Fail-Safe Defaults and then the Optimized Defaults. then removed one of the 2GB memory sticks and rebooted. To my delight, the "Windows XP 64x " logo screen appeared, and it was all smooth from then on. I installed the six Gigabyte drivers AFTER XP had been installed.

I spent the next few hours installing the wireless Internet card, the printer, the scanner, etc.

The only downside was that Gigabyte's support is not an 800 number, so I used my cell phone, and the long-distance charge was absorbed in the cell phone's monthly fee, anyway.

Have a good weekend!

Roy


a c 177 V Motherboard
August 1, 2009 4:12:55 AM

Excellent! It's nice to hear about successful help from GB tech - so often the communications barrier seems insurmountable, and only leads to frustration on everyone's part...
!