Sign in with
Sign up | Sign in
Your question

Wireless Router Assigning Wrong IP Address, Need Help

Last response: in Wireless Networking
Share
November 25, 2009 1:37:29 PM

Hey all, Rob Wright here, formerly of Tom's Games. Got a major headache with my wireless network, need some help....

I recently moved into a new apartment and set up a wireless network through Verizon (Westell 7500 router). Everything was working fine for about a couple weeks. But then two days ago my wireless goes down. None of my machines (Vista desktop, XP desktop, XP laptop, iMac, iPhone, etc.) can connect to the Internet, and my wireless signal is gone. But the router is still on and functioning properly; the lights are all green. I turn the router off, unplug it, allow it to recycle....but nothing works.

I call Verizon tech support and they confirm that, according to their end, the router is working and receiving DSL service through the phone line. After a long and lengthy phone call, it turns out that the IP addresses on ALL my machines have been changed; the tech support guy tells me that there must have been some kind of power spike or electrical disruption that caused the router to reset the IP addresses (I tell the guy that I have the router plugged into a surge protector and that there's been no storms or power outages or anything like that in my area, but it's clear he doesn't quite believe me). So I got through all of them and change them back to the right IP address. The wireless signal comes back, and all my machines are connected again. Problem solved.

Or so I thought. Last night, almost 24 hours after the first incident, my wireless goes down again. I call Verizon back. It's the same issue. I tell them the router is screwed up, that there's been no power surges or lightining or damage to the router. The tech support guy (different one) walks me through the problem -- again -- and I reset the IP address on my laptop and reconnect it to the wireless router.

Except there's a problem this time -- for some reason, when I open up my wireless network connection in XP, the WEP key has been changed. It's 8 characters instead of 10. That's strange, I say to the tech guy. I delete it and change it to the proper one. But it still doesn't connect. So I go back and re-enter it and I see that the 8-character WEP is in the field. I clear it and enter the 10-character key AGAIN, try the connection, get denied and go back to the WEP key. Yup, it's back to 8 characters again. The system either won't save the correct 10-character key, or it's somehow being changed back to the 8-character key.

I check the other machines. It's happening to ALL of them. None of them will save the correct key, and all of them have an 8-character key in its place. The Verizon guy tells me that I have some kind of virus that's infected all of my systems, which I find hard to believe since the problem is affecting my PCs, my iMac and my iPhone. I argue that the router is causing the problem. I tell him my machines, to the best of my knowledge, are protected and clean, and that obviously the wireless router is on the fritz since it was assigning the wrong IP address the day before. I know that systems are never truly protected, but the idea that some kind of super virus has infected every system/device in my home seems far-fetched. The common link between all of them is the wireless router/network, so the issue must be there.

While we argue about this, I power down the wireless router, recycle it, and viola, everything is back to normal -- correct IP address, correct WEP key on all the machines. I ask Verizon to send me a new router, which they will, but they're still contending the problem is on my end. Of course, later that night, my wireless goes down AGAIN and it's the same problem. Wrong IP address, wrong 8-character WEP key. This morning it's back to normal.

Thoughts? Any ideas would be greatly appreciated.
March 22, 2012 7:59:16 PM

Rob: Password hash will make it look like 8 C. but its what you typed. There are few things you can do when you have this sort of issue.
1. Are you getting an IP from your wireless router. Using command prompt type below to see all of your IPs (ipconfig /all)...then type (ipconfig /release) and then (ipconfig /renew)... After releasing, you should see things without any IP and then with renew all IP should be back. NOTE: press enter after each command and don't use parenthesis.

2. In most cases, your DNS is not working. To test, using command prompt type (ping www.yahoo.com)...if your internet seems down, then you should get a timeout...BUT, what if your internet is not down but your DNS is not working... This time type (ping 8.8.8.8)... This is Google's DNS server. If you get request timed out...then your Internet is down or your wireless is not giving you an IP or your WEP or WAP2 key is mis-matched....But if you get a response, your DNS is not working. A quick fix is to go to control panel, networking, find the wireless adapter, right click on it, and click on properties..find the TCP/IP settings and enter the Google's DNS manually and click OK twice. Now, go back to your command prompt and try pinging www.yahoo.com again and it should work.

3. If you placed a pin or so in reset button of your router, you may have reset the wireless keys. You must connect to it via the private IP (if your wireless is totally down, you may have to connect via Ethernet cable)..login and check wireless setting and setup WEP or WPA2 again.

Hope some of these helps. 4/5 times, its a DNS issue. :sol: 
m
0
l
Related resources
!