Sign in with
Sign up | Sign in
Your question

TPM help

Last response: in Components
Share
May 27, 2009 6:59:50 AM

I am using a Gigabyte GA-EP45-UD3P (rev. 1.0) (F9)

I need to clear the TPM. In the TPM manual it says in the BIOS under "Security Chip Configuration" there should be an option "clear security chip" but there is none. A curious point, if you look at the manual, in the TPM part it shows that this is there in the pic, then tells you to go to the part about configuring the BIOS for more details, but if you then go to part of the manual that covers each screen of the bios and lists the options on that screen it shows it as not there and dose not list the option . Well the case is it is not there, I figured perhaps it needed to be in a cretin state for that to appear, so I have tried enabling, disabling, and having it as enabled/ active, going into windows and choosing clear TPM in the TPM mgt untility then following the reboot and all sort of combinations and in all cases, the "Clear Security Chip" option fails to show.

If I go to windows and use the Trusted Platform Module Management tool and try to clear the TPM, it has me reboot and well it dose not clear it.

The Infineon utility has been useless in trying to clear it and Gigabyte has been unhelpful at best. I tried updating the BIOS, that is why I have the F9 version, no help.

I have spent a good 12 hours over the last two days on this and have failed to find a way to clear it, and my guess is there is a very easy and simple answer I am missing. I can't be the only person who has ever had to do this on a gygabyte board so if you know anything, please help.

Thank you.

More about : tpm

May 27, 2009 9:26:24 AM

Exactly how has Gigabyte not been of help?
May 27, 2009 12:09:35 PM

Have you tried Google?
Related resources
May 27, 2009 6:04:42 PM

Yah, I have spent a lot of time searching google and I can't seem to find an answer
May 27, 2009 11:20:33 PM

Yes, it is unhelpful as "Clear Security Chip" is not really in the BIOS. See my original post.

In fact if you check out the mother board's manual, at
http://america.giga-byte.com/FileList/Manual/motherboar...

and reference Page 64 (2-15)

You will even see this reflected,

You can set it to

Enabled

Enabled/Activate - You set it to this if locked down for example say the owner password was entered incorrectly too many times.

Disable - This turns it off

No clear.... can't find clear anywhere else, and using the windows to tell it to clear, dose nothing.

Yet if we look at the TPM manual, it shows there is a nice and easy, clear security chip option there, ahh would't that be so nice if it was true.

I have tried a lot to get it to appear see my orig. post at the top.

My guess is the answer is out there and odds are it is not that hard, but I am sure stumped. If anybody knows why or can help, you will have done me a HUGE favor! Thanks!
May 28, 2009 1:32:23 AM

Well, I don't have your particular MB so I'm just trying to interpret what I read.

So I see what you mean about the MB manual and the TPM manual. Only thing I see is that the MB manual shows:

Security Chip: Disabled
Security Chip State: Disabled/Deactivated

Whereas the TPM manual shows:

Security Chip: Enabled
Clear Security Chip: Enter
Security Chip State: Enabled/Activated

I wonder if the Clear Security Chip option only shows when the chip is in Enabled mode.

The MB manual Does show a Security Chip State option of Enabled/Activate. Not sure if that's a typo or if when you first set the chip to Enable it says "Activate" instead of "Activated" meaning it's still looking to be activated, perhaps by the TPM Utilities.

Also, the TPM manual shows usage of the Infineon TPM Driver and the GIGABYTE Ultra TPM Utility. You don't specifically say you used the Gigabyte TPM utility. I just want to clarify that you installed the Driver and Utility.

The TPM manual talks of Initalizing the TPM chip after Driver and Utility installation. Where you able to get this far????

Anyway, I'm only asking this to verify what you did and your results. After all, with out hands on, all I can do to try and help is read the manuals and see if maybe your steps were out of order or something.
May 28, 2009 4:18:38 AM

Yep, I have the Infineon driver and software and it is up to date, I also updated the BIOS just in case.

I have tried turning the chip to all of the different states to see if the "Clear Security Chip" option appears when it is in certain state, no luck.

Yah the Activated / Activate thing was a typo.

May 28, 2009 6:02:27 PM

One more question.... Why do you want or need to clear the TPM chip???

I'm now wondering if maybe the Clear Security Chip option ONLY shows in the BIOS if data is being stored that can be erased.

So if you haven't created any encrypted files yet, the Clear option doesn't show.

So I'm wondering if you created any keys yet or if the driver is preventing you from doing so until you clear the chip first.
May 28, 2009 7:50:35 PM

The ownership token is taken from a previous user, that data has been transfered to another system, so I will not lose any data by destroying the TPM data or any stored keys.

I want to ensure that I hold the ownership key before using it for bitlock. This means clearing the TPM and then restablishing ownership. Then that key can be placed onto backup and stored in the safe.

I do not want to enable bitlock until I hold ownership of the TPM. It would be necessary if I ever encounter the event of needing to perform an emergency recovery. They key will also be necessary for cretin administrative tasks.
May 28, 2009 8:56:04 PM

Ok, I found some pics on another site using the ep45-dq6, not your ep45-ud3p, but I think they should be similar enough. There are screen shots showing the Clear Security Chip option.

I know you said you tried enabling, disabling, rebooting and so on. But I would try this....

Start computer and go into BIOS.
Set Security Chip to Disabled.
Save settings.
Reboot.

On restart, go back into BIOS. See if chip setting stayed at disabled.
Set Security Chip to Enabled.
Save settings.
Reboot.

Again go back into BIOS on restart.
See if chip is set to enabled.
See if Clear Chip option is finally there.

If not... I'll be still scratching my head.

If your interested, this is the site I was talking about:
http://matt.dcnet.ro/gigabyte-ep45-dq6.html
May 29, 2009 2:11:03 AM

Alright, I tried it. No luck. I was able to get it to enable and disable.

I disabled, rebooted, it was disabled

I enabled it, rebooted, it was enabled.

Rebooted again, and the option did not show.

Then I tired a number of reboots between the options again and while I can turn it on and off a bunch, no luck.

Thanks for trying, if you come across anything else, let me know.
May 29, 2009 3:36:10 PM

Searching for info I found your post on computerhope dot com....

I like how Mulreay RIPPED my post from here at Tom's and posted it as his own.....

That no good @$%^^&$#$#$ ..... LOL , Guess my words must be good for something.

If you ever figure it out, be sure to post back as to your fix. Someone else might find it useful.
May 29, 2009 3:39:08 PM

Oh yeah, you should post back to Mulreay the ripper.... and tell him: If he's gonna cut n paste.... give credit where credit is due.
May 30, 2009 12:29:31 AM

Well I've been doing some research and currently found the following:

Can't find anything useful via google. So I decided to see what was IN the BIOS file. I DLed the F9 BIOS from gigabyte and opened it with a BIOS Mod tool.

As the following pictures show, the Clear Security Chip option IS there.



All I can suggest right now, if you haven't already tried it, Clear the CMOS and see if it appears.

I'd say to make a note of any important changes you made to the BIOS settings, (such as voltage tweaks, etc.) but if you already flashed your BIOS to the newer F9 from an older version, all the settings should be at the default settings anyway.

You could also try the F8 BIOS to see if that helps.

For now, that's all I've got. Good luck. :D" alt="" class="imgLz frmImg " />" alt="" class="imgLz frmImg " />
June 1, 2009 6:35:55 PM

Thanks! I will post back if I find a solution. I am still going back and forth with gigibyte support, they seem to keep misunderstanding me and replying with irrelevant solutions. It is a very slow processes, I have an open ticket with them, ever time I reply it takes them a few days to reply back. But I think I may be making progress and I hope that with my last reply they finally understand what I am trying to do.
June 3, 2009 10:37:56 PM

Victory is mine! For anybody else out there with this model of Mobo, If you come across the same problem, here is the solution.

At the main BIOS screen, Press Ctrl + F1

Now go into the Security Chip part and the Clear Security Chip option will be there.
June 3, 2009 11:15:30 PM

Good to hear you got it figured out.... Now why would they put that in the hidden options menu??? Damn you Gigabyte....!!!! LOL

Anyway, Gotta remember most gigabyte boards have that "hidden" menu.

I think we both figured it had to be something simple. Simple when you know about it.
!