Sign in with
Sign up | Sign in
Your question

ATI 4850x2 STUTTER PROB.

Last response: in Graphics & Displays
Share
March 22, 2009 1:44:06 PM

so i got my self a new card the 4850x2 2gb edition and when i play gta iv it stutters like hell!!!! how can i fix it?????? is there anithing what i can do to stop stuttering? thx! :cry: 
March 22, 2009 4:13:43 PM

There is a patch for the game that fixes alot of issues I believe, so check that out. Also you might need to crank settings down alot, specifically viewing distance. The game runs like *** on every system within patching/tweaking.
March 22, 2009 5:41:36 PM

yes i have patched the game but i didnt helped.. PLZ HELP
Related resources
a c 84 U Graphics card
March 22, 2009 5:48:07 PM

system specs, pls...
March 23, 2009 2:10:33 PM

Core Quad 3ghz
4gb ram
ati 4850x2 2gb
850w PSU
March 23, 2009 2:31:33 PM

This is my bench using Catalyst 9.3 Drivers and GTA IV runs smooth at 1920x1080.

Statistics
Average FPS: 53.77
Duration: 37.21 sec
CPU Usage: 66%
System memory usage: 81%
Video memory usage: 86%

Graphics Settings
Video Mode: 1920 x 1080 (60 Hz)
Texture Quality: High
Render Quality: Very High
Reflection Resolution: Very High
Water Quality: Very High
Shadow Quality: High
View Distance: 32
Detail Distance: 100
Definition: Off
VSync: On

Hardware
Microsoft® Windows Vista" Business
Service Pack 1
Video Adapter: ATI Radeon HD 4800 Series
Video Driver version: 8.14.10.647
Audio Adapter: ATI HDMI Output (ATI Function Driver for High Definition Audio - ATI AA01)
AMD Phenom(tm) II X4 940 Processor


The game is a really poor port from console to PC and is plagued with memory leaks.
Is not just ATI cards but Nvidia cards have issues when running this game.
I try to leave at least 100MB free from my video RAM when configuring the game Display Settings.

Before my HD4870 1GB I had a hd4850 x2 with only 512MB per GPU and the game ran smooth I just couldnt max my graphics settings due to lower VRAM.
Your card should run perfectly fine. Try and do as I said and leave 100MB of your VRAM free to deal with memory leaks from this port./

Detail distance should not effect your performance as you have a hd4850 x2. AS you can see in my settings I have the detail distance maxed out to 100.
I lowered the Shadow quality from very high to high to free up some additional VRAM.

BTW my CPU is running at 3.515GHz, and my ATI card is at 790/1000
I also have 4GB RAM 2x2 G.Skill @ 1066
I've noticed that the slowdown in FPS occurs when I am driving in a car and when the game is loading the textures of the surroundings really fast.
March 24, 2009 2:01:14 PM

I know the prob

stutters are ,becouse the gta IV is not "ready" for crossfire (that means my card has 2 gpus you know becouse its x2) and if i disable crossfire in Catalyst control panel the game dosnt stutter but it has lower frame rate than enabled
March 24, 2009 2:03:06 PM

and im very ANGRY!!!!!
do u know a solution to enable crossfire in gta IV???
March 24, 2009 2:20:41 PM

Cross fire works in GTA IV. Well at least it worked on my side....
In the Catalyst Control Center you can check the box to show a CrossFire Icon in the right top corner of the game, and when you run the game if you see the Icon that means that the game is using crossfire.
As I said before this game is very CPU dependent. So enabling cross fire will help you with some things like Rendering and detail distance, but it wont give you drastic improvement.

About the stuttering... If you google it, you'll find out that 1000s of people have this issue...
I am not sure if it will be addressed by any further patches from Rockstar, but as for the moment, try playing around with the in game settings. I've found that after changing settings it works better if you restart the game.

I just found this mentioned on another forum:

try this:

run gta

alt+tab out

ctrl+alt+del to acces device manager

process tab

find GTA executeable

right-click, select "set affinity" and uncheck core 0

right click again, set priority to high or real time.

right click explorer exe

set affinity, uncheck every core EXCEPT "0"

you game no longer shares cycles with the cluhnky os, performance should improve.




I will try it out later tonight....
!