Hardware Interrupts Using 30% of CPU

Hello, recently I bought an Antec earthwatts 500W PSU. When I turned on the computer after installing it CPU usage was about 30% at idle. According to Process Explorer, that 30% is Hardware Interrupts. I know this only popped up AFTER installing the new PSU. Unfortunately, in trying to find a solution on google no one else with the problem seems to have solved it in a way that works for me, and I've already checked my IDE ATA/ATAPI controllers in device manager, and they are all set to DMA if applicable. I tried the old PSU and the hardware interrupts is still there. Safe mode, it's still there, and I also tried the RAM, only using 1 stick at a time to test if one is broken but it didn't solve the problem.

Because of this, I'm guessing it is the CPU, hard drive, or motherboard. What comes to mind is I did remove the heat sink when I first put in the new PSU, and I had some troubles as one of the two sockets for the securing screws for the heat sink seemed to sink down lower than it should be, so that it was actually under the motherboard and I had to push on the other screw socket to push it back up above. In the course of this the heat sink would have rubbed against the CPU itself and I wonder if something was messed up, though I would think that would make the CPU not work rather than give this strange hardware interrupts. Is there anyone who has experienced this? Is there a way to test if it's the hard drive? Is it possible just to unplug it and run the computer without it?

I appreciate any help.
43 answers Last reply
More about hardware interrupts
  1. How do you know that it's hardware interrupts? By themselves they do absolutely nothing unless you have code to trap them and do something. Replacing the PSU can't cause that issue, but why did you remove the HSF? There wasn't enough clearance to install the PSU?
  2. Hi, I had the same problem a few years back. It turned out to be a bad sector on the hard drive that the system was trying to continuously read. I solved this by running "chkdsk" in dos mode. It moved the information on the bad sector to another location and my cpu usage was back to normal. Hope this helps you.
  3. Welcome, Felicia, to the forums.
  4. I'm not sure what you mean by code to trap the hardware interrupts, but I know it's here from running Process Explorer, which tells me the CPU usage of it (it does not show up under Task Manager). I removed and put back the heatsink as it was blocking access to the motherboard power connector. Thanks for the replies, I will try to check the harddrive.
  5. What is you CPU usage in Task Manager? Check Show Kernel times to see how busy the kernel is.
  6. Unfortunately checking the harddrive didn't do anything. My CPU usage is 30% idle on the Task Manager. Where is the Check Kernal times box?
  7. View, Show Kernel Times.

    To determine if the disk is causing that issue, create a BartPE disk and boot from it. Then run Process Explorer to see if the issue still exists. It could also be caused by the video card or any other device that uses hardware interrupts.
  8. This is sometimes caused by a fault within the windows or IDE drivers.

    The system goes into PIO mode, even though it says its running as DMA.
    When you find this, go to control panel, system, device manager, and remove the IDE controllers, Primary and Secondary.

    Reboot.
    The devices will get re-installed back to DMA working state.

    This happens because the driver detects a timing or crc type error when in use, and degrades the system to guarantee data integrity. Change / fix your cables/update the drivers.

    AdmV
  9. Sorry but where is "View"? I don't see it in the windows task manager.
  10. Also I tried reinstalling the IDE/ATA controllers from device manager, unfortunately didn't fix the problem.
  11. jonathan142 said:
    Sorry but where is "View"? I don't see it in the windows task manager.

    At top of the Task manager window, you should see File, Options, View. If not, what OS are you running?
  12. I'm not sure what kernal is, but in the CPU usage display while idle most of the bar is red, only a sliver is green. The green gets larger if I do something.
  13. It proves that the kernel is doing most of the work, i.e., interrupt handling, I/O, etc. You'll have to disconnect your hard disk and boot from a BartPE CD or DVD. Then check if you still have the hardware interrupt issue. I doubt the hard disk itself is the source of your problem, but disconnecting it should at least prove that all other components are not the source of the issue. Narrowing down the issue to the hard disk or software will be a step in the right direction.
  14. Is hard disk the same as hard drive? Can I just unplug the power to it?
  15. Yes, but you have to boot from a CD to check if hardware interrupts still are an issue.
  16. Alright I couldn't find any blank CD's in my house, tomorrow I will buy a pack. Also the instructions mention using Windows XP installation files, not just the already installed windows data. Does that mean I need to have the original Windows XP installation CD, because my computer came with it pre-installed and HP doesn't give out backup CD's with their computers.
  17. Yes you need a copy of Windows XP CD to create a BartPE CD, but you don't need a key.
  18. jsc said:
    Welcome, Felicia, to the forums.


    Is it just me or are there more gals around these days?
  19. I should ask this ahead of time; how do you boot from the CD drive? If the CD is there and I turn on the computer without a hard drive, will it be automatic? Also how will I be able to tell if the interrupts is still there, since Process Explorer is saved onto the hard drive? I guess you can use task manager still?
  20. If your system is configured properly, the CD-ROM should be before the hard disk in the boot device list. The CD-ROM drive will be ignored unless a bootable CD is inserted. Process Explorer will be available if it's on the BartPE CD that you created or on a USB key.
  21. When I try booting with the disk it tries to load the BartPE, but I get an error "\i386\system32\ntoskrnl.exe could not be loaded error code 32768". The site's FAQ section says I did not slipstream my service pack to my windows installation files correctly, do you know what that means?
  22. How did you slipstream the service pack?
  23. Vlite or something.
  24. When I try to slipstream, the command prompt is stuck on C:\Documents and Settings\HP_Administrator, cls won't clear it. Typing in the integrate command, it says the filename, directory name, or volume label syntax is incorrect even though everything typed seems in order.
  25. Did you use this procedure: http://www.winsupersite.com/showcase/windowsxp_sp2_slipstream.asp? It will work with SP2 and SP3 and it might be easier to follow.
  26. why not just use knoppix

    http://www.knoppix.net/
  27. BadTrip said:
    why not just use knoppix

    http://www.knoppix.net/

    Please explain how it will help the OP run Process Explorer. The OP most likely has no knowledge of Linux.
  28. booting from the knoppix cd will let him determine if it is hardware or software
  29. BadTrip said:
    booting from the knoppix cd will let him determine if it is hardware or software
    What I wanted to know is what tool can he use to determine if the hardware interrupt issue is still there or not? What's the equivalent of Process Explorer in Linux?
  30. Thanks for the step by step guide, using it I got PE working. Anyway while booted using the CD I checked Task Manager, and sure enough the CPU idles at 40-60%. I didn't use process explorer but while idle the system idle process claims to be using 99% of the CPU but it obviously isn't so I guess we know the hard drive isn't the problem. I guess that means it must be the CPU itself or the motherboard. Is there any way to test that?
  31. Before having the CPU and/or motherboard tested, you should remove the heat sink again, clean up the heat paste on the CPU and HSF with rubbing alcohol. If removing the HSF could dislodge the CPU from the socket (you didn't specify what CPU you have), remove it and reinstall it. Then use Artic Silver 5 (follow the instructions and use the required quantity) and reinstall the HSF. It might solve your issue.
  32. It just seems odd, if the CPU is dislodged or something I would think it would simply not work. Though I'm not a computer expert of course. My CPU is AMD Athlon 4200+ x2, socket 939. Motherboard is MSI AMETHYST-M. I'll have to get some thermal paste, if you have any other suggestions I'd appreciate it.
  33. Don't get any thermal paste - if you can, get Artic Silver 5. You definitely want to remove the CPU and inspect the pins to make sure that none is bent or broken.
  34. I don't recommend electrically conductive thermal compounds. Ceramique is the best I have used.
  35. So when I take the CPU out from underneath the heatsink fan, how do I remove the heatsink from the CPU? Can I just pry it upwards off the CPU?
  36. In your initial post you wrote "What comes to mind is I did remove the heat sink when I first put in the new PSU, and I had some troubles as one of the two sockets for the securing screws for the heat sink seemed to sink down lower than it should be, so that it was actually under the motherboard and I had to push on the other screw socket to push it back up above."

    How did you remove the heat sink before? It's no different this time around.
  37. Well I actually meant the heatsink fan.
  38. Ah! That's very different. If you aren't comfortable doing that kind of stuff, then you probably should have your PC checked by a technician.
  39. I just applied the thermal paste and unfortunately hardware interrupts is still there. Any other suggestions?
  40. Removing and installing a heat sink or fan can't cause issues like that, unless you broke something on the motherboard or the CPU. Unless you have another system to test the CPU, my only suggestion is to have a certified tech look at it.
  41. Before taking it all apart try resetting the router + broadband modem.
    They tend to use up most of the interupts if you have a busy network and/or problems within it.)
    By switching off the Router (and release your IP. - then restart Windows)
    I run XP and got the above issue with 16-30% used up by hardware interrupts. and it all sort itself after a router / modem restart.

    Must be something recent with all the servicepacks because never had this problems before

    To find out all you have to do is switch the router / modem off and run process explorer - check if the problem persist.
  42. Have you fixed the problem? I got what i think is exactly the same i think. Same Motherboard and everything too!
Ask a new question

Read More

CPUs Hardware