Sign in with
Sign up | Sign in
Your question

New build - Radeon HD4670

Last response: in Graphics & Displays
Share
March 23, 2009 3:54:09 PM

First time new build. Everything is hooked up. All fans turn on @ powerup EXCEPT my graphics card. AND I have no display on monitor, not even a screen flicker. SHOULD my graphics card fan turn on @ powerup or not? I'll ship it back if I think its DOA.

More about : build radeon hd4670

March 23, 2009 4:01:45 PM

DOA.
Do you have another graphics card to see if the slot works?

Makes sure the wiring was inserted Properly and was on there snug tight.

Check the Beep codes.
March 23, 2009 4:06:27 PM

I don't have another card to try. It seems to be powered solely by the PCIe slot, no power connections on the back of the card. What are beep codes?
Related resources
March 23, 2009 4:24:40 PM

When ever you turn the computer on, it should beep, which tells you, one beep is usually means everything works, 1 long beep or a couple short beeps and one long beeps will mean something, or a long beep pause, couple short beeps pause 1 long beep. Do you get anything like that. On my motherboard i get post codes which there is a box that shows a number if there is a problem like for instance :
9a or 8B.
a c 191 U Graphics card
March 23, 2009 4:25:36 PM

Make sure the card is fully seated, it`s possible a SATA connector (HDD or optical drive) is interfering with the card and preventing it from going fully home.
The `beep codes` refers to the beeps the computer should make when it is powered on, sometimes the MB has a tiny speaker to make the sounds, but some need to be connected to the case speaker to hear them.
You system should make a single, clear beep when it starts, you`ll need to tell us you MB make and model if it produces any others.
March 23, 2009 4:48:27 PM

I don't get any beeps. Even with an external speaker hooked up. Card is fully seated. Should the HD 4670 fan turn on @ startup or will it only come on when the card needs it?
My build...
MSI K9A2 CF-F mthrbrd
AMD Athlon X2 6000+ 3.0Ghz
Coolermaster Gemini II S CPU fan
Saphire Radeon HD 4670 - 512 Mb PCIe2.0
Corsair (2x1024) PC8500 memory - 1066Mhz
Seagate Barracuda 7200.10 250 Gb HD
Lite-on IHAS422-08 DVD burner
Rosewill Conqueror WSL Case
Rosewill RP600V2-S-L 600W Pwr Supply
a c 130 U Graphics card
March 23, 2009 4:50:49 PM

The fan should definatly run at start up, if its not spinning the card isnt running, at least not properly.

Mactronix
a c 191 U Graphics card
March 23, 2009 5:11:54 PM

You should get some beeps and the fan should run at startup.
You have connected both plugs to the MB? (1x24 pin 1x4 pin) It sounds rude of me to say so, but it`s happened;)
March 30, 2009 3:01:16 AM

hmm, i got a partly similiar issue with this card as well, it's only 1month old
the fan need "manual push" to spin when startup, what should i do? any setting? change the fan? or any repairing? or RMA? :S
!