Sign in with
Sign up | Sign in
Your question

USB drive disappears mid-copy

Last response: in Storage
Share
September 12, 2010 5:30:08 PM

hi

I have a "new" Dell refurb Inspiron 570 desktop, Athlon x2, 4gb ram, running Win7-x64...

I'm trying to copy files over to a Kingston 8gb DataTraveler USB thumb drive.

I plug the drive in - it gets recognized - drag the files over to it - the copy process starts, the transfer speed starts fast but drops slowly. Gets to about the 2 or 3rd file, then pops up a "Location not found" error...and the whole thing stops. The drive is no longer listed in the tree - it just disappears. Remove and reinsert will bring the drive back.

some things to note:

* I've disabled selective shutdown for the USB in Power Mgmt
* I've disable allow shutdown for all USB hubs in the device mgr
* the transfer rate seems really slow - ~5 min for 24mb?
* the USB drivers are "correct" according to windows
* the USB drive is formatted as FAT32 - which is what it has to be for my car HU
* the USB light is still on, but "twitching"
* front usb and rear usb ports act the same
* I could not locate a Kingston specific driver
* this usb drive has worked fine on every other box i've used it on - until this one.
* i do see that the "USB mass storage device" needs 500ma and each USB port provides 500ma
* put Kingston drive in old machine - works fine
* i have two other usb drives (512mb and 2gb) and both work fine - both FAT - fast transfer speed as expected.

i'm not sure if its a driver thing - usb port thing - or what!

thoughts?

THX
September 13, 2010 4:27:34 PM

Have you tried it on another PC? Have you tried to reformat the thumb drive?
!