Sign in with
Sign up | Sign in
Your question

Wireless keeps disconnecting!

Last response: in Networking
Share
July 6, 2009 5:31:37 AM

I have a linksys wrt54g router and a Super G 802.11BG Wireless Pci 64 Bit Xp Compliant Turbo Mode wireless card. I downloaded a small utility which disables wireless zero configuration tool after a connection is found on windows starting up. The problem is though, every 20-40 mins, my internet will disconnect and it won't be able to reconnect because the wireless zero configuration was disabled by the utility. Do you know what would be causing this? I have 4/5 bar connection for the most part that ranges from 36-54mbps. I also am using WPA2 TKA+AES as security. It's extremely frustrating and I don't know what to do. Any help would be appreciated. Thank you!

More about : wireless disconnecting

July 6, 2009 8:42:44 PM

Have you tried changing the wireless channel you are using?
Are there other access points in range using the same channel?

Microwave ovens and some cordless phones can also cause problems.
I selected channel 11 after testing, because of my neighbors cordless phone
July 7, 2009 4:53:37 PM

I changed to channel 11 and it took a good 5 minutes for it to finally connect. It would show "acquiring network address" then say limited or no connectivity then I would have to try to reconnect and it would again say acquiring and finally it connected. Do you know why this would happen? I will come back and post if it is still disconnecting though.
Related resources
July 7, 2009 7:58:34 PM

Well I tried changing to channel 11 and it did the same. Then went to channel 1 and did the same. After about say an hour of gaming, it will just drop my connection and won't reconnect because I have zero wireless configuration tool disabled since it make me lag every 60 secs when it looks for a new connection. So I can only play in a game for an hour until my connection is dropped, then I have to enable the ZWCT to find a connection, then disable it to play without lag. Any other suggestions?
July 8, 2009 12:26:18 PM

Try reducing the Beacon Interval setting in the router.
It is located on the Advanced Wireless tab.
Mine is set to 50 ms.

Are there other drivers available for the wireless card?
Sometimes newer or older drivers work better
in some situations.

Have you tried one of the free utilities like NetStumbler
to monitor the wireless connection?
It might help you to discover the cause of your disconnects.
July 13, 2009 9:28:16 AM

lyleb said:
Try reducing the Beacon Interval setting in the router.
It is located on the Advanced Wireless tab.
Mine is set to 50 ms.

Are there other drivers available for the wireless card?
Sometimes newer or older drivers work better
in some situations.

Have you tried one of the free utilities like NetStumbler
to monitor the wireless connection?
It might help you to discover the cause of your disconnects.



I set my wireless to unsecure and then made it only accept a few MAC addresses that use our internet. No lags or delay there. Still have to disable the wireless zero configuration in the services because it will look for a better connection every minute, but no dropping at least.
!