Sign in with
Sign up | Sign in
Your question

ATI Catalyst weird.

Last response: in Graphics & Displays
Share
March 25, 2009 2:57:41 AM

Hey guys i got the ati 4850 *2 of these in crossfire* now i just upgraded from 9.2 to 9.3 now my drivers aren't working correctly.

it shows this message when i tried upgrading. Then when i tried to uninstall it and the same thing happened. I used Driver Sweeper and the program crashes when I'm cleaning the ati drivers out. I'm confused what should i do...

*Pic*

http://i43.tinypic.com/2rnybtw.jpg

More about : ati catalyst weird

March 25, 2009 5:02:58 AM

Try System Restore.
a b \ Driver
March 25, 2009 8:25:08 AM

Reverse back to cat 9.2 and see if it works fine
Related resources
March 25, 2009 10:56:51 AM

For some reason i reversed it and the same thing still happens. I used Driver Sweeper and the same thing applies. So any other way? *Tried system restore* the ati tray doesn't even come up ...
March 25, 2009 1:09:03 PM

happened to me too, just got fed up and re-installed Windows... i'll tell you what, my handy dandy little 32GB flash drive worked wonders for that, God Bless
March 25, 2009 4:49:39 PM

Do you have AV softwre running? Sometimes this can interfere with software installation.
Also Driver Sweeper needs to be run in Safe Mode (just in case you did n`t know).
March 26, 2009 3:10:13 PM

I just posted about an odd issue so my experience _may_ help.

If you installed anything from the CDROM, and if by chance you're using vista (or not), try doing this work with the CD in the drive.

For some unknown reason to me, my OS was still searching for, and apparently finding and using a portion of the drivers on the damn CDROM drive.

Just my 2 cents learned from 2 days of hell. =)
!