Sign in with
Sign up | Sign in
Your question

Seagate hard disk not being detected

Last response: in Storage
Share
September 14, 2010 11:40:52 PM

I used an Ubuntu live disc a few hours ago to see if i can install that OS. However i didnt install and just did a hard disk check. Ubuntu reported NO ERRORS, and then i restarted my system. And since then it has been stuck at detecting ide. I have 2 Sata hard drives. 1 1 TB and another 500 gb. The first one is detected, but the other isnt. I get stuck at the first screen where it keeps trying to detect the hard drive. I cant go into the bios nor can i do anything else. I tried changing the wires, no luck. I also put the hard disk into another system , the same thing happened. I even put it in an external enclosure and plugged it in. But the system freezes once its plugged in as it seems to get stuck at trying to detect the damn hard disk.
I have an
Athlon 64 3200+
MSI K8N Platnium motherboard
1 Gb of ram
XFX Geforce 6600gt graphics card
running windows xp service pack 3

PLEASE HELP! the entire last decades worth of photos i have taken are in that drive. Please help me get it back.
January 15, 2011 2:19:32 PM

tamalsen said:
I used an Ubuntu live disc a few hours ago to see if i can install that OS. However i didnt install and just did a hard disk check. Ubuntu reported NO ERRORS, and then i restarted my system. And since then it has been stuck at detecting ide. I have 2 Sata hard drives. 1 1 TB and another 500 gb. The first one is detected, but the other isnt. I get stuck at the first screen where it keeps trying to detect the hard drive. I cant go into the bios nor can i do anything else. I tried changing the wires, no luck. I also put the hard disk into another system , the same thing happened. I even put it in an external enclosure and plugged it in. But the system freezes once its plugged in as it seems to get stuck at trying to detect the damn hard disk.
I have an
Athlon 64 3200+
MSI K8N Platnium motherboard
1 Gb of ram
XFX Geforce 6600gt graphics card
running windows xp service pack 3

PLEASE HELP! the entire last decades worth of photos i have taken are in that drive. Please help me get it back.


Well, if it has only been an year since you bought the drive, you should have warranty for the disk, and you should be able to send it back to them to get it recovered. Right now, it has been 3 years, and it is not being recognized again. Sending it back would cost $100, so does anyone have any other way to recover it?
!