Sign in with
Sign up | Sign in
Your question

Cannot insert into port

Last response: in Storage
Share
Anonymous
a b D Laptop
a b G Storage
September 17, 2010 5:12:35 AM

Hello,
I just bought this ASUS laptop and I cannot insert the device into any of the ports. it seems they are blocked.

More about : insert port

a b Ĉ ASUS
a b G Storage
September 17, 2010 10:51:10 AM

What device? What ports?

I am assuming you mean the USB ports. If so, make sure that the USB connector is oriented properly. If you still cannot, well, you just bought it so it should be under warranty. Take it back to where you bought it and show them your problem.

I suggest you find a computer literate friend and get a second opinion first. Otherwise, when you take the computer back, if the problem is something really stupid, you will be really embarrassed. I have always found it better to be embarrassed in front of a kindhearted friend than out in public in front of strangers. :) 

Please PM me and tell me what the problem was.
m
0
l
September 17, 2010 3:20:54 PM

please specifiy the problem correctly
m
0
l
September 24, 2010 4:36:15 AM

Hmm don't know what you mean by specifying the problem correctly. I'm just not a techy I guess. But my problem was identified and solved. I bought the Logitech Cordless trackball at Amazon and apparently it was an oldie and fit in an older type of usb port in my old pc. The connection is an older type that has solid plastic surrounding the upper portion of the holes that the prongs from the usb port fit into. The newer ports have the plastic protecting the prongs so the older connection could not be inserted. I finally contacted Logitech to see if I needed an adapter. I sent photos of the connection to them and they offered to replace the trackball - even though I went to them not looking for a replacement just thinking there must be some sort of converter piece necessary. They did not tell me to go to Amazon in fact the did not even ask where I purchased the trackball. Needless to say, Logitech now has a customer for life. I've always liked their product but the service they provided went beyond what I expected.

Please understand this is not a complaint about Amazon. I just did not think to ask them if they had an adapter. I know that had I been able to identify the problem and asked them to replace it they would have.

Thanks to all of you who tried to help. I hope this helps anyone that may have the same problem I did and would be happy to send a photo if it would help.
m
0
l
!