ARGH Brand New GTX 295 Not Working HELP!

I just received my GTX 295 from the EVGA step-up program, and it isn't displaying anything, just a few beeps on bootup and nothing.
Here is my setup:
EVGA 750i FTW
e8400
Corsair TX750w

I had a GTX260 core 216 before I opted for the step-up and everything worked fine.
I unpacked the video card, plugged it in, plugged in the 8pin+6pin PCI-E power connectors, hook up dvi cable, and powered on. Didn't work.
My OS still has the gtx260 drivers on it, and my motherboard doesn't have onboard video, so I can't do uninstall drivers and whatnot.
I also reset my bios settings via removing the battery incase it was conflicting with a bios setting, and reseated the card a few times, but still nothing.
It gives me 1 long beep+2 short beeps...that's a sign of a bad video card...? :(...omg. The video card also has a green light on the back of it, usually green means it's powered.
Any suggestions? :(
I want this badboy up
9 answers Last reply
More about argh brand working help
  1. I would re insall GTX260, uninstall all drivers then after shut down install that bad boy
  2. problem is i don't have the gtx260 anymore...as i sent it back to evga to step up to the 295 :(...
    am i screwed?
  3. its not the old drivers that at fault if your computer is not going by post, try the card in a friend's computer if it does not work RMA the card
  4. i don;t think your screwed, you have a cool video card. I would make sure everyhting is seated correclty and all plugs are in the vid card securely. I am thinking maybe you had to do a bios upgrade for your mobo or somehting before installing. yuo dont have any old video card to use?
  5. what is considered "seated properly"
    i just line everything up and make sure it's flush and it clicks into the locking mechanism.
    the green light means it's sufficiently powered right? when i run it without pcie cables in it, it's red.
  6. rangers said:
    its not the old drivers that at fault if your computer is not going by post, try the card in a friend's computer if it does not work RMA the card


    +1

    I had to RMA my GTX 260 upon receipt from Newegg, It would only show up as PCI-E 1x. After trying it in 2 of my friends computers and having it do the same thing, I RMA'd it, the new one worked perfectly first try.

    That's what you should do as well.

    Edit: I just found this after posting....

    Quote:
    1 long, 2 short Failure in video system An error was encountered in the video BIOS ROM, or a horizontal retrace failure has been encountered
  7. thanks, i will try that. but still pissed off as i'll have to send it back in, wait for the to receive it, give 1-2 business days for it to process, and wait for it to come back.
    i'm in canada so it takes 2 weeks, and that's express shipping.
    ridiculous for a $600 card.
    also my friends' don't have comparable PCs to mine, so i'll it'll be a hassle to be testing them on their PCs.
    i have been trying to seat in a bunch of different ways with no success, i am thoroughly pissed off at the quality control at evga.
    if anyone has any other suggestions, please don't hesitate. this is B-S
  8. Well, I am glad I opted to pay for EAR, it sped up the whole process compared to a normal RMA.
  9. so i threw in my buddy's video card into my setup and it's working fine. i didn't bother throwing the gtx295 into his setup because i would have to destroy my awesome cabling to take out my psu and put it into his setup because he's only running 600w.
    any suggestions before i send it back to rma?
Ask a new question

Read More

Graphics Cards Gtx Graphics