Sign in with
Sign up | Sign in
Your question

Sound Blaster X-Fi Surround 5.1 Buzz Noise

Last response: in Components
Share
June 4, 2009 4:05:44 AM

Guys,

I'm having a big issue here and your help will be highly appreciated!

I just built my rig with a GIGABYTE MA790GP-UD4H motherboard. There was obvious buzz noises from the speaker whenever the system playback sound (no matter what system sound, music, movie or games). I'm sure it's not the speaker's problem as it's completely quiet when nothing is played and it works fine on my laptop.

So I thought it was the issue of the motherboard's onboard card. Then I purchased a Sound Blaster X-Fi Surround 5.1 USB card, installed drivers and the problem still exists.

This really surprise me as the Sound Blaster X-Fi Surround 5.1 is connected through USB and is far away from the case so I assume none of the PSU, video card and other signal would influcence the card?

I'm using Windows 7 RC and installed Creative's Windows 7 Beta driver.

This is driving me crazy. Please kindly help!!!
a b V Motherboard
June 4, 2009 6:44:03 AM

Try muting the auxillary and cd in. Also the TAD if you're not using it.
June 11, 2009 9:41:22 AM

I have a very similar setup... I have a rampage 2 extreme with the creative x-fi riser that came standard. I get a very "tin"y noise from mine intermittenly. I found that the best way to eliminate this was to uninstall and reinstall the drivers for the card. I completely removed all creative software and just let windows handle the installation and it worked out great. On the downside I have yet to coax anything greater than 2.1 out of mine even thought I am using a fiber optic cable. Please let me know if this works for you and what ultimately solves the problem.
May 4, 2012 10:38:29 PM

How do you mute the CD in? I do not see ANYWHERE in windows 7 to do that. I also have no idea what TAD is.. much less where to find to disable it. I am using a SoundBlaster X-Fi with 6.0.1.1348 drivers. I have the creative audio control panel and going through start>control panel>sounds does not have a CD in anywhere I can see. In the properties of the speakers, I mute (and set to 0) the Microphone FP, Line-In 1/Mic, and the Digital-In None of that works and I still hear a buzz in the background that gets worse when I move the mouse.
!