SLI Artifacting for old games

Hi there, ever since I set up SLi in my PC, I've been getting major artifacting in old RTS games

It's fine for recent games for Crysis, but makes my older games glitchy as hell.

Any suggestions? I can't turn of SLi in the Nvidia Control Panel cuz it reverts to SLi-enabled
7 answers Last reply
More about artifacting games
  1. bump
  2. Strange. Usually it reverts to multiple monitors/multiple graphics cards. Well, in my experience...

    Anyway, try forcing VSync. Check that drivers are up to date, etc. If at all possible, disable the SLI by going to multiple monitor mode.

    Worst case, check EVGA's site; they've got some updated SLI drivers, but that's usually better for newer games :(

    ... That's all I got.
  3. hmm, that option is in the nvidia control panel right?
  4. Bluescreendeath said:
    hmm, that option is in the nvidia control panel right?



    You can't turn off SLI in the Nvidia control panel? I have SLI and i can swap back and forth between... (usually takes a restart) Have you downloaded the latest nvidia control panel from www.nvidia.com?
  5. mrmmacd77 said:
    You can't turn off SLI in the Nvidia control panel? I have SLI and i can swap back and forth between... (usually takes a restart) Have you downloaded the latest nvidia control panel from www.nvidia.com?


    For my control panel, there's no save option. I click the no-sli button, and 5 minutes later it reverts to SLi. It doesn't ask me for restarts or saves either
  6. Bluescreendeath said:
    For my control panel, there's no save option. I click the no-sli button, and 5 minutes later it reverts to SLi. It doesn't ask me for restarts or saves either



    Hmm ok well usually there is more than one way to skin a cat... you can try to create a profile for each game that is giving you issues... usually there is always a setting for SLI in there.. might just be that some of the games that are giving you issues are on the list that Nvidia pre programmed for SLI IE ... I just found out last night this..... I pulled RTC3 out of the dust in the back of the closet and found out that Nvidia preprogrammed a profile that auto loads in the Nvidia CP when I start the game.... Usually there is a setting for SLI in there under your .exe game file and you can choose different options... test out different configurations maybe that can help you.

    I can tell you that my Nvidia CP version 2.2.390.00 does have the option to apply after I change the setting.... when I go into SLI setup it shows nothing when I change the option to go or not go SLI then the Apply button shows up in the very far right corner of the window.... bottom far right... Then restart even if it doesn't ask you too.... I'm running Vista 32bit Ultimate OS... would most likely be the only difference that I would see ...

    What cards are you running in your SLI setup and on what board?
  7. ^ 9800GTX and a GTX+ on a 780i
Ask a new question

Read More

Graphics Cards Games SLI Graphics