P5W DH Deluxe Windows 7 Drivers.

I am about to get Windows 7 (currently using Vista 32 bit). I went on to Asus website, and I couldn't find the drivers for Windows 7. Is there a workaround for this? For example, would the vista drivers work?
26 answers Last reply
More about deluxe windows drivers
  1. Warranty has expired and ASUS support for your MB is long past. Windows 7 would supply the system drivers you need, but Vista drivers you may need will work.
  2. I used vista drivers for the oddball stuff that wasn't built into win7 and it wasn't much
  3. Thanks for the response. I have another quick question, when my Win7 says it's activated, does that mean that it has no expiration date?

    I am using the win7 RTM

    Thank you
  4. http://www.microsoft.com/windows/windows-7/get/download.aspx

    The RC will expire on June 1, 2010. Starting on March 1, 2010, your PC will begin shutting down every two hours. Windows will notify you two weeks before the bi-hourly shutdowns start. To avoid interruption, you'll need to install a non-expired version of Windows before March 1, 2010. You'll also need to install the programs and data that you want to use.
  5. Thank you very much badge.
  6. how can set mic and headphon in windows 7
    my motherboard is P5W DH Delux
    please help me.

    i can not sets!?
  7. mahdi10539 said:
    how can set mic and headphon in windows 7
    my motherboard is P5W DH Delux
    please help me.

    i can not sets!?


    If you haven't downloaded the most recent software drivers for Windows 7 from Realtek, please obtain them from this link:
    http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=14&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false
    Note, you'll have to tick the accept box, and agree, and then you'll be able to download the high definition drivers.
    Once you download the software, you should be able to adjust your microphone and headphone settings. If not, make sure your bios has been set to the high definition drivers.
  8. For some reason i cant ever download from realtek, i click the java link but then the new page loads with an error! It might be the university firewall, anyone else having this issue?
  9. Nevermind got it off a filesharing site :)
  10. Hey after i installed Windows 7 on my p5w DH deluxe my usb ports have all gone back to 1.1

    Is there anywhere I can go to to get them back to 2.0? Cause I lost the support CD and the Asus Website has nothing...
  11. Check the BIOS settings under Advanced, USB Configuration. Is the USB 2.0 Controller Enabled and in HiSpeed mode?
  12. GhislainG said:
    Check the BIOS settings under Advanced, USB Configuration. Is the USB 2.0 Controller Enabled and in HiSpeed mode?


    Its on Enabled and in HiSpeed mode. Still no 2.0...

    What now?
  13. I don't know because mine works fine and I didn't install anything but Windows 7 64-bit (and probably the latest Intel drivers). Did you download and install the latest Intel drivers? http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=816&DwnldID=18494&lang=eng

    The support CD is useless.
  14. I installed the drivers for Vista 64 from the Asus website. Still didn't work. Now going to download the latest drivers from the intel website. Though it says it won't fix USB issues :(

    God this is frustrating...
  15. How did you determine that USB is not at full speed?
  16. I used Everest to check that out. It says 1.1. And anyway everytime I plug in a USB device it says it can perform faster if put into 2.0
  17. I checked the drivers on mine:

    usbd.sys
    usbhub.sys
    usbport.sys
    usbuhci.sys

    All are version 6.1.7600.16385 and I have no problems at all.
  18. Hmmm my drivers dont show usbd.sys. Could that be the problem?
  19. Did you check all drivers? usbd.sys should definitely be there.
  20. Its there. But still no 2.0 Any other ways of fixing this? :)
  21. I just checked it out.

    Only usb hub is 6.1.7600.16445

    Whats weird is that the wireless modem that i never use runs on 2.0. According to Everest that is.
  22. My BIOS settings are as follows:

    USB Function: 8 USB Ports
    Legacy USB Support: Auto
    USB 2.0 Controller: Enabled
    USB 2.0 Controller Mode: HighSpeed
    BIOS EHCI Hand-Off: Enabled

    Plug and Play O/S: No

    Like I said before, I only installed the latest Intel drivers and I don't use the wireless modem because the PC is connected to a Gigabit network.
  23. I just did a total format. Cleaned the whole pc. Installed everything right. And still no change. Have you disabled the wireless modem through the bios?
  24. chaosdept said:
    I just did a total format. Cleaned the whole pc. Installed everything right. And still no change. Have you disabled the wireless modem through the bios?
    Mine doesn't show a setting to disable WI-FI. I can see that the RealTek controller is working properly in Windows 7 (though I don't use it) and all my USB ports are fine. I just transferred the Program Files folder and it took less than one minute to transfer 150MB to my USB key. It would definitely take a lot longer than that at 12Mbps. I'm using Windows 7 Enterprise 64-bit and 6GB of RAM. Plug&Play OS is set to No, but that shouldn't make a difference. I have an old E6300 (1.86GHz CPU) in that low use test system.
  25. I run a C2D E6750 with 4 gigs of RAM. and I use Windows 7 Ultimate. Plug and play is set to no.

    Ive been researching online and alot of websites say that there is a problem with this board and the USB drivers due to the wireless modem. They say to remove all the usb controllers and restart the pc.

    At start up it says 1 Hub recognized. I guess thats the modem and afterwards when i try to plug in a USB 2.0 device it does not work. But 1.1 works!

    Have you installed all the drivers? Like the drivers for the wireless modem? Cause some websites say its due to the conflict between that and the USB. So now i'm downloading the driver.

    Lets hope this works. Otherwise i'm going for a new board!
  26. I didn't install the RealTek Wi-fi drivers because the included Windows 7 drivers work fine. As a test, I just connected the system using Wi-fi and it works well. I might have installed the latest Intel drivers, but no other drivers were installed. Though it shouldn't matter, my case is an Antec Sonata III and I use a PS/2 keyboard and mouse.

    It looks like you could remove the Wi-fi controller if you don't need that option.
Ask a new question

Read More

Asus Windows 7 Drivers Windows Vista Motherboards