Sign in with
Sign up | Sign in
Your question

PCIe Slot Bandwidth

Last response: in Motherboards
Share
August 18, 2009 10:48:28 AM

Hello,
I recently impimented a Crossfire setup on my DFI Lan Party DK 790FX-M2RS (Link) which has 3 PCIE slots, two are used by the GPUs and one by a Creative soundcard.

Upon running GPU-Z it reported that one of the cards (Slot 2 for ref) is running at x8 instead of x16. My understanding of PCIe is limited but from the specs page it seems to indicate you can run 2 slots at x16 and one at x4 which would be perfect as the soundcard is happy from anything with x1 up.

GPU-Z Screen Cap

From device manager I got that;

GPU1 is running on Bus 4
GPU2 is running on Bus 1
Soundcard is running on Bus 2

Within the BIOS however it labeled

GFX1 (Sub options indicate this is a x16 port)
GFX3 (x8 port)
GFX4 (x16 port)

In an attempt to clear up the labeling difference I changed the speed of the x8 slot down to x1 to see if it flagged the change but the second GPU is still running at x8.

My knowledge is limited in this area so I don't know if the card could change the lane speed back up to x8 if it needed.

Any assistance would be appreciated as switching slots isn't and option due to physical clearance and I'm not even sure that is the issue.

More about : pcie slot bandwidth

a b V Motherboard
August 18, 2009 1:21:48 PM

The GPUs need to be in the top two PCIe slots for 16x/16x.
m
0
l
August 19, 2009 8:40:47 AM

jitpublisher said:
The GPUs need to be in the top two PCIe slots for 16x/16x.


Currently the confirguration from top to bottom is GPU1, GPU2 and Soundcard.

m
0
l
Related resources
a b V Motherboard
August 19, 2009 8:13:17 PM

check in bios to see if theres asetting for maximum speed
m
0
l
August 19, 2009 8:15:20 PM

Are you sure the x16 slot is x16 electrical and not just x16 mechanical and x8 electrical
m
0
l
August 20, 2009 9:18:54 AM

I have checked the BIOS and set it to x16/x16/x1. GPU-Z and catalyst control centre still report that the second slot is running at x8.
m
0
l
August 21, 2009 10:37:08 AM

Solved. BIOS setting for "Slot 3,4" must be set to 16/NC rather than AUTO or 8/8. A BIOS update takes away this option all together and assigns full speed automatically.
m
0
l
!