Sign in with
Sign up | Sign in
Your question
Solved

XP Pro won't detect storage drive, but Linux does

Last response: in Storage
Share
September 28, 2010 7:13:24 AM

I'm not the most familiar with hardware, but I will do my best to describe what's going on. First, a little history:

This computer came with Windows XP, and at one point I installed a new internal SATA HD. This was a few years ago. It worked fine and served me well. Years later, for reasons I don't care to explain, I decided to install Ubuntu. Again, I was able to get my storage drive working fine.

Now: I've just recently wiped my main drive, installed both XP Pro and Ubuntu (dual boot). As far as I can tell, they work fine.

The Problem: XP does not seem to recognize the storage drive. READ VERY CAREFULLY: The drive is NOT listed in Disk Management. I'm not talking about volume labels -- it is not detected AT ALL. Dsk Mgmt shows my main drive (Disk 0) with its two partitions -- but there is NO Disk 1 (storage drive). NOTHING. (Just wanted to be clear.)

Bonus Info: When I boot into Ubuntu, the drive shows up just fine, and I can use it like normal.

More Bonus Info: Under Device Manager, there is a ? with "Mass Storage Controller" listed. It says the device is not configured correctly (missing drivers).

I think this may be the problem -- let me explain:

This is an old computer. In order to install the SATA HD, I needed to buy an extra chip (this is where my knowledge is lacking). I think it's called "SATALink Host Controller." I needed this in order for my computer to access the drive.

Problem is, if it came with any driver disks, I don't think I have them anymore. Stupid, I know... If this IS the problem, is there a way I could download them again? If so, how will I know I have the right driver?

Thanks in advance.
a b G Storage
September 28, 2010 8:28:10 AM

Looks like the SATA drivers aren't installed during the installation of Windows XP. Did you install XP yourself?
m
0
l
September 28, 2010 8:57:22 AM

Yes, I did.

From what I've read, XP doesn't come with SATA drivers. (I've seen thousands of threads about people having trouble installing XP on SATA HDs for this reason.)
m
0
l
Related resources
a b G Storage
September 28, 2010 9:45:35 AM

Yes, they don't. You have install them manually during the OS installation. At the start by pressing F6 and installing from a Floppy Drive. One other workaround is to go to your BIOS, select the SATA HDD and select the option of making it work as an IDE HDD.
m
0
l

Best solution

September 28, 2010 1:22:33 PM

F6 information would apply if user was looking to install the OS to this drive. Good info to have nonetheless as that is what many people attempt.

But in this case, the OS installed fine and is up and running. It really is as simple as just getting the driver for the SATA card you are using for your "storage drive".

We can help further if you list the make/model of that controller. With that we (or you, the original poster) can just google for the drivers. Once you've found the drivers simply install them and the drive should now be usable.
Share
September 28, 2010 10:30:43 PM

nocheese said:
We can help further if you list the make/model of that controller. With that we (or you, the original poster) can just google for the drivers. Once you've found the drivers simply install them and the drive should now be usable.

This has been my thinking, but although I've apparently gotten the appropriate drivers, Windows seems to think they're the wrong ones.

This is the controller and attached drive (as seen from Linux):
Quote:
*-storage
description: Mass storage controller
product: SiI 3112 [SATALink/SATARaid] Serial ATA Controller
vendor: Silicon Image, Inc.
physical id: 9
bus info: pci@0000:02:09.0
logical name: scsi2
version: 02
width: 32 bits
clock: 66MHz
capabilities: storage pm bus_master cap_list rom emulated
configuration: driver=sata_sil latency=64
resources: irq:21 ioport:2420(size=8) ioport:2414(size=4) ioport:2418(size=8) ioport:2410(size=4) ioport:2400(size=16) memory:D 0100400-d01005ff memory:D 0180000-d01fffff(prefetchable)
*-disk
description: ATA Disk
product: ST3160812AS
vendor: Seagate
physical id: 0.0.0
bus info: scsi@2:0.0.0
logical name: /dev/sdb
version: 3.AA
serial: 4LS0EFWN
size: 149GiB (160GB)
capabilities: partitioned partitioned:D os
configuration: ansiversion=5 signature=359b5e0d
*-volume
description: Windows NTFS volume
physical id: 1
bus info: scsi@2:0.0.0,1
logical name: /dev/sdb1
version: 3.1
serial: 68649c3e-a612-445a-a490-092b2d5cb7f2
size: 149GiB
capacity: 149GiB
capabilities: primary ntfs initialized
configuration: clustersize=4096 created=2010-09-28 00:23:21 filesystem=ntfs label=shared state=clean


Silicon Images drivers are listed here: http://www.siliconimage.com/support/searchresults.aspx?...

Common sense tells me I should use the "SiI3x12 32-bit Windows BASE Driver", right? But when I tried installing the driver via Windows' Hardware Update Wizard, it says it cannot detect the proper software.

Suggestions?
m
0
l
September 28, 2010 11:08:21 PM

I've figured it out! It was a silly little thing...

While looking at Silicon's driver page, something caught my eye:
Quote:
Silicon Image does NOT support End-Users directly. Silicon Image designs and develops chips for manufacturers. These manufacturers develop their own drivers, firmware and software for their boards.


When I start my computer, it shows the black screen with white text, listing some of my hardware, etc. (What are they called? Diagnostic text?) It lists my SATA controller... but the FIRST line says: "Adaptec SATA Host Controller 1205SA..." Apparently, Silicon provided the chips, but Adaptec made the board.

I Googled my Adaptec board and BOOM -- found the list of drivers: http://www.adaptec.com/en-US/support/sata/sata_host/ASH...

So the moral of the story: Know the difference between chips and boards.

Thank you all for your help. :) 
m
0
l
September 28, 2010 11:08:45 PM

Best answer selected by cmf.
m
0
l
!