Sign in with
Sign up | Sign in
Your question

Problems with my intel 80GB SSD G2

Last response: in Storage
Share
October 5, 2010 7:11:53 AM



My SSD is a 80GB Intel G2
Looking at other people's scores, im starting to have a feeling that I did something wrong. Don't get me wrong, my SSD does seem very fast compared to my other hardrive but I was wondering if someone can point me in the right direction to making my drive faster.
a b G Storage
October 5, 2010 11:53:23 AM

You're running in PATA (IDE) mode rather than AHCI. This doesn't make a big difference with some SSDs but Intel drives like AHCI. Run regedit and change the values of the "start" entry to 0 for the following registry keys:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStorV
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStor

You may not have one of the latter two, which is fine. After doing this, reboot and go into your BIOS. Look for any mention of SATA mode (or something similar) and change it from IDE to AHCI. Without knowing which BIOS/motherboard you are running I can't tell you where it is, but if it uses AwardBIOS it will likely be under Integrated Peripherals. Make sure you change the registry entries first or Windows will BSoD on startup.
m
0
l
October 5, 2010 12:37:10 PM

If the method specified by randomizer doesn't work for you as for me:
1) Turn off the computer. Restart will NOT work!!
2) Turn on the PC. Enter the BIOS by pressing "delete" during POST/boot screen.
3) change the mode of ATA devices from IDE to AHCI(Advanced Host Controller Interface)
4) Save and exit the BIOS. Done!
m
0
l
Related resources
a b G Storage
October 5, 2010 12:52:53 PM

Isn't that the same thing as I said, minus the registry changes? :??: 
m
0
l
October 5, 2010 1:06:07 PM

Reboot won't work and will cause problem with my method. You will have to shut down the PC first.
m
0
l
October 5, 2010 5:49:39 PM

Iv got a problem with the same card. iv got BIOS to see the card (original hard drive is in SATA 1, SSD is in SATA 2) but when i get into windows, it doesn't show it in my hard disk drives section when i click on computer. but it's shown in device manager as working properly. Is it supposed to do that?

also iv got windows 7, amd phenom 2 quad core 3.4, 8 gigs ram and 2 HD5770s if that helps any.
m
0
l
a b G Storage
October 6, 2010 12:08:38 AM

Occasionally you'll find that Windows fails to mount the drive under a drive letter. Search for "computer management" in the start menu, open it and navigate to "disk management" (or something along those lines). There you'll see all drives in the system. You'll be able to assign a drive letter to it from there.
m
0
l
October 6, 2010 5:05:06 AM

alright awesome, i got to disk managment. it shows disk 0 (the 500g standard HD), disk 1 (80g SSD) and of course the CD drive. for disk 1 it shows the space as unallocated. from there im not sure what to do.
m
0
l
a b G Storage
October 6, 2010 5:10:28 AM

Well unallocated space means that it contains no partitions.
m
0
l
October 6, 2010 1:42:18 PM

i wasn't sure what that meant, but i right clicked on the disk space and selected something like "create volume". and from there it was pretty much just clicking ok a couple of times. it's showing up as a standard hard drive now. thanks!
m
0
l
a b G Storage
October 7, 2010 2:07:48 AM

Ah, I assumed you had already created one or more partitions and formatted it, but you hadn't. That's why it wasn't showing up in Explorer. It was a raw, and thus unusable disk.
m
0
l
!