Sign in with
Sign up | Sign in
Your question

I7 875k Turbo core ratio.

Last response: in Overclocking
Share
November 8, 2010 1:06:00 AM

Hello,

Im busy trying to overclock my i7 875k on my Asus maximus extreme III.

Atm I changed my turbo core ratio into:
1 Core: +9 (@4.1)
2 Core: +8 ( @4.0)
3 Core: +5 ( @3.6)
4 Core: +5 ( @3.6)

However as soon as I up my bclk the multipliers dont change a thing if its 2 or 4 cores active.
It always stays @3.6.

Im a noob at overclocking, could anyone please tell me what im doing wrong?

Thanks in advance !

More about : 875k turbo core ratio

November 11, 2010 12:11:30 AM

no one? :( 
m
0
l
December 9, 2010 12:02:17 AM

I have a similar problem:

i7 875K / P7P55D-E LX / BIOS ver 1501 / Win 7 x64
I have my BIOS settings at BCLK=160, DRAM = XMP (DDR3-1600), SpeedStep on, CPU multiplier = 22, core1=+3, core2=+2,core3=+2, core4=+1 (and some increased voltage levels). Thus turbo mode should give 23x (3695 MHz) for 4 cores and 25x (4016 MHz) for 1 core under load. When I run prime95 with 8 threads the multiplier (monitored in CPU-Z) goes to 23x like it should. When I run 1 thread (or restrict the CPU affinity to 1 core), the multiplier is still only 23x. Why isn't it moving to 25x ?? If I turn off turbo mode, then the multiplier drops to 22 as you would expect. If I do nothing, then the multiplier drops to 9x as it should. If I run TurboV (an ASUS utility) and hit "Turbo Unlocker" then the multiplier does exactly as you would expect (up to 25x for single core if I set it that way in TurboV). However, when I run Turbo Unlocker, the system seems to crash whereas it doesn't at 23x (8 threads) when running from the BIOS. Thus, I would like to get this to work from the BIOS and not mess around with TurboV. I have tried CPU multiplier to "Auto" which gives a 9 to 22 range and get the same results (max at 23x). Looking at the YouTube video (http://www.youtube.com/watch?v=6s1n3eTl-0g) which has a similar ASUS MB, it works fine for him. Why is it not working for me? Before I overclocked, the multiplier ranged from 9x to 27x as it should.
m
0
l
December 17, 2010 7:18:04 PM

In the bios; Is full phase power enabled? also some people it seems have gotten by with just 4 pins connected to the 8 pin power connector, definitely 8 should be connected for overclocking. Play with C states also.. higher levels of C states put the cpu in levels of powersaving and restrict our overclocking efforts, I would disable c states if possible. It's prolly on auto, if you can set to C-0 or disable do so, or the lowest state allowed.
m
0
l
!