Sign in with
Sign up | Sign in
Your question

Very poor fsx perfomance on high end system:( help!

Last response: in Graphics & Displays
Share
April 12, 2009 11:00:06 AM

Hey, last year i got a high end pc for 2500 euros, and im getting really bad performance in fsx, here are the specs:
Nvidia nforce 780i Sli
intel core 2 quad q9550 runnin at stock 2,83ghz, liquid cooled
2x nvidia 9800 gtx in sli oced to 760/1885/1150
8 gig ram ddr2-800/1066 dual channel
vista home premium 64
Psu 750w
samsung syncmaster t220 tft 22 inch
ok, so no matters at which settings im runnin the game, low, ultra high, i never get over 20 fps, the fps locker is set at 60, i also tried unlimited fps lock. Im runin 1680x1050, but i also tried 640 res and no fps increase. I checked the cpu usage and mem usage and just 1st core is used 60-70%, other ones are at 5-10%. Mem usage in desktop at idle is around 1.5 gigs, mem usage in fsx is 2 gigs. I applied sp1 and sp2, tried also reinstalling fsx and reapply the pathes. I know that fsx dont support sli,so i turn single gpu mode.When i try using sli, the game run as same as b4. The gp1, is at 55-60º when playin fsx, the same as in idle.I also tried enabling dx10 mode, but i get the same bad performance and runways and shadows makes like flashing. Whats the problem? All other games such as crysis, gta 4, cod4, cs:source, left4 dead, fallout 3 got excellent frame rates, never under 35fps. For example, in crysis i hav 41-45 fps in benchmark at ultra high. I read problems of other persons, with quad cores xtreme, gtx 280, gtx 295, gx2s, having the same bad performance than me. I hav gpu and mobo drivers updated. Please help me, i dont wanna play fs2004 forever, fsx is the latest on the series, microsoft cancelled flight sim series:( 
a b Î Nvidia
April 12, 2009 2:50:53 PM

Flashing runways is a glitch in DX10 mode that nobody will take responsibility for (and now that Aces is gone, it will probably never be fixed). I have it too. The biggest draw on FSX is CPU. I'd suggest looking at a tweak guide such as this one:

http://members.cox.net/spambait/FSXTweakGuide.pdf

Though I'm sure you can find better. One thing to double check is at the bottom of this pdf is the number of threads. Make sure that it is set to whatever equals 4 threads for best performance. Good luck, that is a difficult game to get running decently.
April 13, 2009 6:53:08 PM

The setting that I found to offer the most help is under aircraft the cast shadows on itself.
Turning it off seems to help the most.
And dont go crazy with the clouds.
Right click the shortcut and goto compatability and make sure to disable visual themes. For some people this works automatic and other dont so just to be sure check it.
One other thing to look at is the Nvidia control panel. Set most to application controlled.

Also ext64 is correct in that FSX is very dependent on GHZ more so than the number of cores. If you can get that cpu up to 3.0G or higher it will help.
!