Sign in with
Sign up | Sign in
Your question

Asus P5N7A-VM Sata Problem

Last response: in Motherboards
Share
September 3, 2009 9:40:48 AM

I recently changed my failed Mobo to an ASUS P5N7A-VM but I can't get all my SATA connections to work (only 3/5 work).

When I first boot up my system with the new mobo, it was set on RAID Mode and therefore I was getting a blue screen and auto-restart when it reached the Windows Vista loading screen. However, all my SATA devices (4HDDs & 1DVD) were correctly found and shown in BIOS.

I decided to change the setting from BIOS to "SATA Mode", like it was with my old mobo. It loaded Windows normally, no problems at all except the fact that it couldn't detect 2 of my 5 SATA devices (the ones connected to the black ports). It doesn't even show them on BIOS.

I installed the new motherboard's drivers, I even tried a BIOS update but the problem persists.

Any help would be much appreciated!
September 3, 2009 3:00:46 PM

Those black SATA connectors are on a separate controller, are numbered 5&6, and use AHCI or raid only, the drivers for them are on the DVD that came with the board.
September 3, 2009 3:23:26 PM

Thanks for the reply.

I've found the drivers you mentioned, but (it might sound stupid) how can I install them? There is no such option in the ASUS Setup. I also checked the Device Manager and there is no component without drivers installed.

One more thing, you say the black connectors only use AHCI or RAID... So, how is it possible to have 4HDDs and use them in normal SATA mode? I can't believe this motherboard doesn't support that, there must be a way.
Related resources
September 3, 2009 3:36:28 PM

The DVD should auto run and load to a install menu. I have this board and use it as a media machine it has two internal hard drives, 1 SATA DVD drive, and 1 external for recording TV shows, movies and football.
September 3, 2009 6:52:07 PM

Problem solved. :) 

I activated AHCI Mode but it was crashing on windows loading screen.

It only needed a change in the registry to fix that:

How to enable AHCI under Vista

To resolve this issue, enable the AHCI driver in the registry before you change the SATA mode of the boot drive. Just follow the below steps:

1. Exit all Windows-based programs.
2. Click Start, type regedit in the Start Search box, and then press ENTER.
3. If you receive the User Account Control dialog box, click Continue.
4. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\Msahci
5. In the right pane, right-click Start in the Name column, and then click Modify.
6. In the Value data box, type 0, and then click OK.
7. On the File menu, click Exit to close Registry Editor.

via: http://forums.techarena.in/operating-systems/1133831.ht...
September 8, 2011 8:02:13 PM

Hi, and I can confirm that works also on Win7 64bit, great that you found it :) 
!