Sign in with
Sign up | Sign in
Your question

IRQ out of range

Tags:
  • Comm Port
  • PCI
  • Modem
  • Components
Last response: in Components
Share
June 24, 2009 9:18:55 PM

I have a PCI 56K smart modem in stalled on a WinXP Pro machine and the IRQ is listed as 16 com port is 3. Isn't the IRQ supposed to be 4? my applications do not recognize the modem as being installed yet the machine says it's there and has no conflicts.

More about : irq range

June 24, 2009 9:58:26 PM

I'm surprised people still use 56K modems. You should investigate the price difference between your modem plan and a basic ethernet plan.

My sister lives in Ottawa and can download at speeds up to 825KB/second which is roughly 200x faster than a 56K modem can handle.

As for your problem, it's difficult to troubleshoot in this manner. You can try:

1) removing any drivers from Add/Remove
2) Reinstall drivers (test again)
3) remove the hardware from Device Manager and reboot

There's also a setting in your BIOS that has to do with managing IRQ's. I forget the name. Switch it from Yes to No. or vice versa. It has to do with your Operating System managing the IRQ or the BIOS doing it.

56K Modems have always been a pain to get working correctly.
June 24, 2009 10:50:09 PM

Rather than starting with the above, I'd start by inactivating your COM1 or COM2 in the BIOS, then setting the modem's port to be COM1 or COM2.
Related resources
June 25, 2009 3:34:47 AM

photonboy said:
I'm surprised people still use 56K modems. You should investigate the price difference between your modem plan and a basic ethernet plan.

My sister lives in Ottawa and can download at speeds up to 825KB/second which is roughly 200x faster than a 56K modem can handle.

As for your problem, it's difficult to troubleshoot in this manner. You can try:

1) removing any drivers from Add/Remove
2) Reinstall drivers (test again)
3) remove the hardware from Device Manager and reboot

There's also a setting in your BIOS that has to do with managing IRQ's. I forget the name. Switch it from Yes to No. or vice versa. It has to do with your Operating System managing the IRQ or the BIOS doing it.

56K Modems have always been a pain to get working correctly.



It's NOT 1992, if you have a painful problem with setting up any modem, then YOU SHOULDN'T BE RESPONDING TO THIS QUESTION/PROBLEM... You are the problem!

"1) removing any drivers from Add/Remove
2) Reinstall drivers (test again)
3) remove the hardware from Device Manager and reboot "

Remove ANY drivers from Add/Remove: WHAT?

Reinstall drivers: Which ones? Test for what?

remove the hardware from Device Manager and reboot: What will that do? What are we looking for...Maybe a golden sunset over a computer that still doesn't have the modem setup correctly!

GOOD COMPUTER SUPPORT FROM A COMPLETE IDIOT! A basic ETHERNET plan, I think your sister knows more than you..tell her to respond to ANY tech questions you may want to deal with, anything she might have a thought about would be enlightenment compared to your BS...

Mondoman is correct, turn off the one or two serial ports in the BIOS, that should free up the Com1/2 ports using IRQ 3/4, which would then allow your software to identify the modem correctly...
June 25, 2009 12:45:01 PM

@marcellis22: WOAH! Calm down! Bad day?!

@superchikn: Did this modem used to work? is it a new addition?
June 25, 2009 4:46:22 PM

Yes the modem used to work, then all of a sudden it just stopped working.
Anonymous
June 25, 2009 5:22:47 PM

Have you had any windows updates regarding the modem, check the updates installed to see if there was a hardware update, have you installed any other hardware recently?

The Bios needs to be set to deal with IRQ and Mondoman has given a good work around

@marcellis22 jeesh man blow off your steam playing a game of badminton or something ;p
June 25, 2009 5:43:58 PM

Some older cards (modems, sound cards...) only support specific IRQs.
June 25, 2009 7:12:07 PM

Mondoman said:
Rather than starting with the above, I'd start by inactivating your COM1 or COM2 in the BIOS, then setting the modem's port to be COM1 or COM2.


Disabled COM1 and COM2 in BIOS. Modem still boots on COM3 IRQ16 change COM3 to COM2 in Properties and it still sets th IRQ to IRQ16. COM1 always shows "in use." Hyper terminal can use the modem. Other dialer programs do not regonize it as installed.
June 26, 2009 3:12:55 AM

It's not clear to me if you also set the internal modem to "be" COM1 -- perhaps there's a jumper or something on the card to do this?

I always found it easier to use an external modem with a serial cable, but I don't even know if they make those anymore.
!