O/S partition problem? GA-MA785GM-US2H

I recently upgraded my my motherboard, CPU, and ram and got things working just fine. On bootup, however, I kept getting the message, "SATA is found running at IDE MODE!" There was another message after it asking if I wanted to change it to AHCI mode or continue in IDE mode. It did this on every bootup, just like the manual said it would. I didn't know what it meant, so I just let it wait the 8 seconds until it moved on on its own. Well, that got old after a while, so I pressed "Y" to set it to AHCI mode. That was clearly the wrong choice.

After that, it would only go to the Safe Mode option screen. Every time I chose to start in the most recent bootable condition, or whatever that choice is, it just restarted and brought me to the same screen. I booted in safe mode, and then restarted, which brings me to my current problem.

It seems to be booting off the wrong partition on the hard drive. I don't really know what it's doing. When it boots now, I see the desktop that I had 2 years ago. It's now saying that major changes have taken place and I have to register Windows again. Well, I did that last week when it booted up properly on what I assume was the correct partition. It will boot far enough to tell me it's found new hardware and wants to help me with some drivers. Very shortly after, it restarts on it's own now.

I'm guessing I have to tell it to boot from somewhere else on the hard drive, but I don't know how. It restarts by itself when it goes into the "old" desktop. I'm very confused. Any ideas?

BTW: My 2nd drive that I use for storage is SATA. My OS drive is IDE. I unplugged the SATA while trying to figure the problem out so it's out of the loop.

I reset the CMOS, to no avail...
7 answers Last reply
More about partition problem ma785gm us2h
  1. Someone suggested I need to find the option (usually under "storage options") in your bios that says:

    Set SATA Emulation Mode: Y/N

    Turn it on to turn SATA IDE emulation back on.

    I shouldn't have to reinstall the OS.

    Is there anything on the gigabyte board that is similar to this?
  2. Yes. That is exactly what the problem is.
    You cannot just change to AHCI mode if you installed Windows XP in native IDE mode. XP does not contain the drivers for AHCI mode. To use that mode, you must INSTALL Windows with that mode turned on, and install the proper drivers using F6 during the install. (There is a work around, you can change to AHCI mode after install but it is a lenghty complicated process that envolves several manual registry changes, just Google for it)
    The BIOS will display this message the first time you boot, but you should have had an option to acknowledge you want to run in IDE mode and then it would never ask again.
    The only advantage to AHCI mode is it enables Native Commnad Queing if you your drive supports it, and hot swapping. Other than that, there is hardly any difference at all.
  3. Thanks for the info. That explains what happened then.

    Is there anything I can do at this point to change it back? I changed the setting back in BIOS, but it's still booting to the other partition. How can I change it back?
  4. i have the same mobo on my other other computer. it's a pain in the ass to work with the ahci. just stick to native ide mode.

    i'd reformat the hard drive and reinstall the os at this point.

    i'm not sure if you have two differnet os (xp ,vista 7) or just two versions of the same one.
  5. I somehow got 2 versions of the same XP on it through the years. It could probably use a fresh install. Thanks for the help!
  6. lol. just do a fresh install. format the rest.
  7. Well, the strangest thing just happened. My DVD drive wasn't working, so I thought it might be the cord going from the HD, to the DVD drive, then to the MB because I had to really stretch it to get it to fit. I thought maybe I had pulled a wire out or something (turned out it was a jumper set wrong). I swapped out the wire, and it booted up like nothing bad had ever happened. It's all back to normal and working just fine. I'm not even going to pretend to know why. :D
Ask a new question

Read More

Gigabyte Motherboards