Building rite now-have a few questions please!!

hey guys, well i am in the process of building my pc rite now. it is going pretty well.
i do have one question though
the corsair 750tx psu has me confused. which way should it go with the fan facing up or down? the antec p182 guide doesn't say anything about it and the corsair guide says go with the case guide.
thanks
16 answers Last reply
More about building rite have questions please
  1. The screws holes on the back of the case should match up with the screw holes on the back of the power supply. It should only fit one way.

    -Wolf sends
  2. Wolfshadw said:
    The screws holes on the back of the case should match up with the screw holes on the back of the power supply. It should only fit one way.

    -Wolf sends


    Oh snap, thanks yea the p182 has an inside cage so i thought that held it in place i did not see the screwholes on the back. thanks im sure i will be back with a few more questions!
  3. I have the corsair 750tx in a cm690 case and i'm pretty sure it will mount either way...could be different on the p182. In either case, you will be fine either way you mount it, but I would suggest having the fan facing down if you have a vent on the bottom of the case to intake cold air.
  4. yea thats how i mounted it...thanks
    i am now lost in connected all the cables, everything is in the case, i am just lost in all the wires and where they all need to be connected!
    for the psu i do not need all of them to be plugged into something rite?
  5. Right. You should have quite a few left over cables from the power supply after all the components that need power are connected.
  6. k thanks i have everything connected and running but my monitor doesnt display anything. everything appears to be working fine just nothing displaying. hmmmm any help?
  7. nevermind!!!! fixed it im an idiot! : ) next problem is the motherboard is not recognizing my keyboard so i need to fix that rite now...flash the bios lol
  8. everything is running perfect...installing windows rite now. pictures will come tomorrow after i do cable management i am too tired rite now to get the cables organized i am just happy everything is running rite
  9. hmm i have a problem actually. it doesnt recognize my hard drive when i am installing windows. what should i do?
  10. anybody? please
  11. aevm, i see that you are on. do you have any suggestions? this is really killing me i thought i had it all set
  12. What do you mean it doesn't recognize your hard drive...did it not install at all? Make sure the sata cable from the hdd is securely connected from both the hdd and the motherboard and make sure you have the power securely connected to the hdd.

    When you go into the bios it should recognize all the sata devices (probably only cd/dvd drive and hdd) Does it see the cd drive?
  13. foolycooly said:
    What do you mean it doesn't recognize your hard drive...did it not install at all? Make sure the sata cable from the hdd is securely connected from both the hdd and the motherboard and make sure you have the power securely connected to the hdd.

    When you go into the bios it should recognize all the sata devices (probably only cd/dvd drive and hdd) Does it see the cd drive?


    See this is what is confusing me also. The cd drive works fine. they are both plugged in and sata cables to the mobo too. in the bios, this is where i get confused, the dvd drive is listed as IDE Channel 2 Master and the HDD is under IDE Channel 3 Master. I don't understand why they are under IDE when they are SATA. Is there something I can change in the bios to fix this?
  14. Nothing?
  15. i am going to try one more time but if it doesnt work i give up until tomorrow...thanks for ne input i got earlier feel free to help!
  16. Precisely what happens - what are you doing and what if any error messages do you get when trying to load windows?
Ask a new question

Read More

New Build Corsair Systems