Sign in with
Sign up | Sign in
Your question

Non-Optimal Speeds on my 80GB Intel SSD

Last response: in Storage
Share
October 20, 2010 1:10:59 AM

Hey everyone-

I just received my 80GB X25M SSD from Intel. I'm seeing an issue here though. Seems as if my sequential read is only hitting around 160MB/s, and write is around 80MB/s. My drive is in IDE mode (forgot to change before install), could this be the issue? If so, is there a way I can enable AHCI mode without re-installing Windows? I'm running this drive on a Gigabyte H55M-USB3 motherboard. If you need any other information, feel free to let me know.

Regards,

Coheed


EDIT: Here is the log from AS SSD:


a b å Intel
a c 351 G Storage
October 20, 2010 1:58:09 AM

quote from link below
I researched this a bit more and discovered two resources with information on this. First a Microsoft Knowledgebase article describing how to enable the AHCI drivers via the registry:
http://support.microsoft.com/kb/922976

Also information on how to force the load of the AHCI driver from the Windows GUI:
http://www.eggheadcafe.com/software/aspnet/29976834/ahc...

Link Note title indicates vista, but comments indates it works with Win 7
http://www.tomshardware.com/forum/244840-32-convert-sat...
a b G Storage
October 22, 2010 12:15:23 AM

1. Open up regedit. (Windows Key + R > "regedit" ).

2. Navigate to HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Services > Msahci.

2. In the right pane, right-click "Start" (look under the Name column) and then click Modify.

3. In the Value data box, type "0" (this is a zero, not a "O" ), and then click OK.

4. Restart PC, go into BIOS and set it to "AHCI".

5. Windows should start and install the Microsoft AHCI drivers.

6. Reboot and then go online and download the latest chipset drivers for your chipset from the Intel website.

7. Install the drivers. Reboot once done.

8. Congrats! Now you have AHCI using the Intel drivers!
!