Sign in with
Sign up | Sign in
Your question

WD Caviar Blue - Can't boot but can use in dual boot. Help plz

Last response: in Storage
Share
October 22, 2010 12:19:16 AM

Hi,

I just got a new Western Digital 1TB Caviar Blue SATA 7200 32MB (WD10EALS).

Now, I can use this drive fine from inside Windows 32-bit. I partitioned it to prepare for installing Windows 7 64-bit.

I shutdown PC, removed all other drives and booted. I checked BIOS and drive is showing correctly. I set the correct boot priority of drives.

Here's the problem. The drive cannot be detected at boot-up.

Funny thing it, I went ahead and installed Windows 7 64-bit on the new drive and it finished the installation fine.. but it just will not be detected during boot up. So I can't boot from it to go into the new operating system I installed.

I can plug my other drives in and go back into Windows 7 32-bit and the new drive is clearly shown there. it even shows the new files which were installed during Windows 7 64-bit installtion. I can write to this drive, use it without a problem in Windows 32-bit.

The BIOS even detects the drive. However, I just cannot boot from it. It does not appear in the list of drives detected during boot up.

I have tried every jumper on this drive while removing all other drives. it just doesn't boot, although (1) BIOS detects it, (2) Windows installation detects it and can even install successfully, (3) it can be detected through another operating system from a different drive.

Please help.
October 22, 2010 2:02:47 PM

Anyone?
a c 415 G Storage
October 22, 2010 4:30:40 PM

Does the drive have a 100MB "System Reserved" partition on it? That's the REAL boot partition in a Windows 7 installation. If you install Windows 7 it will try to put the boot partition on a different drive than the one you install the OS into.

If you want to OS drive itself to be bootable then you need to make sure that no other drives are connected when you do the Windows 7 install.
Related resources
a c 104 G Storage
October 22, 2010 8:21:37 PM

Hi there,

I agree with Sminlal.

Win-7 can be installed in several different ways, with the EFI reserved system partition being placed at the beginning of the new HDD, on a different HDD if connected at time of installation, or just as a BIOS type BCD if the new HDD was separately Formatted before installation.

I would guess you had the other HDD connected when you installed Win-7 on the new HDD, and the EFI was placed on the "other" HDD. Tha's why it boots when the other HDD is attached.

I would seriously consider reinstalling Win-7 on the new WD HDD with only that drive connected. Nothing else. It's an hour's time but will get it right so you don't have these kinds of problems.

You do that by installing from the DVD, add date/time, language, keyboard, then use Custom Install, choosing to delete all partitions presently on the drive, and dial in your Primary Partition Size, leaving unallocated space at the end to later create another partition or resize this one. With just 1 HDD attached, your only choice is a Basic Disk, Simple Volume, which is the way you want it. Win-7 will then place the 100Mb "reserved system" EFI partition first on the drive, then the OS using the NTFS file system on the Partition you created.

When completed, then you can go to Disk Management to adjust the Partition Size, give it a friendly name, or even create another Primary Partition. Then when you connect other HDD's to your system, you will be fine.
October 22, 2010 8:24:47 PM

Well, windows 7 creates that 100MB partition only if the drive hasn't been partitioned before.

I partitioned the drive from a different installation of windows and so when I installed the new operating system, it did not create any 100MB partition. It was the only drive present when installing windows.

Anyway, what I did was, I deleted all the partitions DURING Windows installation and formatted the drive there. I then created a partition for Windows installation and it seems to have installed correctly this time.

I can now boot from this drive without any problems. Looks like my previous installation was corrupt or something because I partitioned it from another operating system.

However, there is still one problem I have:

During bootup, my motherboard displays a list of detected drives connected to it. I see all my other SATA drives and my DVD writer. But I do not see this new drive I bought. I can't make it show up no matter what config I choose. I've disconnected all other drives and tried every jumper setting, I've tried different sata ports... but the drive is just not being listed in the list of drives.

Although, the good news it that the BIOS does detect it and I can now boot from this drive without a problem.

My motherboard is P5K Premium.

Should I be worried and send the drive back, or can that list of drives during bootup be incomplete and there's nothing to worry about?
!